Jump to content
  • 0

VPN-ът работи, но няма интернет.


mladentod

Question

Здравейте, 

Не знам как да си формулирам въпроса за да търся в гуугъл, затова пиша тук.

Отскоро започнах да експериментирам с мрежата си вкъщи и да се уча да я конфигурирам.

Накратко . Като доставчик ползвам ВИВАКОМ и след тяхното устройство имам hAP AC2. Изтрих цялата конфигурация и започнах от началото. 

По LAN съм закачил  3 РС-та, 2 телевизора и NAS (който закупих скоро).    По WI-FI са - 6 телефона и 2 лаптопа.  Дотук всичко е ОК.

Проблемът ми е при VPN-ите, когато не съм вкъщи.  Телефоните и лаптопите се закачат и обменям информация с  NAS-а , но опитам ли да влезна в Интернет,  ми показва че страницата не може да бъде достъпена. Това става и на PPTP, и L2TP IPSec.  Във Вивакомския модем съм пренасочил портове 4500 и 500.

На вилата ми също пуснах VPN за пробата (там съм на Мтел,  при който няма такива схеми с портове на модем-ът им) и пак същото.

Предполагам че пропускам някаква дребна настройка.

 Предварително благодаря.

Edited by mladentod
edit
Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 1

Когато настройваш клиента, който се закача с РРР-то махни отметката на "add default route"

Link to post
Share on other sites
  • 0
  • Administrator

Ревизирай си правилото за маскарадиране

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites
  • 0
JohnTRIVOLTA
Преди 3 часа, mladentod написа:

Здравейте, 

Не знам как да си формулирам въпроса за да търся в гуугъл, затова пиша тук.

Отскоро започнах да експериментирам с мрежата си вкъщи и да се уча да я конфигурирам.

Накратко . Като доставчик ползвам ВИВАКОМ и след тяхното устройство имам hAP AC2. Изтрих цялата конфигурация и започнах от началото. 

По LAN съм закачил  3 РС-та, 2 телевизора и NAS (който закупих скоро).    По WI-FI са - 6 телефона и 2 лаптопа.  Дотук всичко е ОК.

Проблемът ми е при VPN-ите, когато не съм вкъщи.  Телефоните и лаптопите се закачат и обменям информация с  NAS-а , но опитам ли да влезна в Интернет,  ми показва че страницата не може да бъде достъпена. Това става и на PPTP, и L2TP IPSec.  Във Вивакомския модем съм пренасочил портове 4500 и 500.

На вилата ми също пуснах VPN за пробата (там съм на Мтел,  при който няма такива схеми с портове на модем-ът им) и пак същото.

Предполагам че пропускам някаква дребна настройка.

 Предварително благодаря.

Локалната мрежа ли изнасяш с ВПН или друга сетната само за ВПНа ?

Link to post
Share on other sites
  • 0
JohnTRIVOLTA
преди 33 минути, cna написа:

Когато настройваш клиента, който се закача с РРР-то махни отметката на "add default route"

По този начин не се ползва ван минипорта за достъп до интернет, а само до локалните му ресурси, а до колкото разбирам се търси обратното !

Link to post
Share on other sites
  • 0

Аз никъде не прочетох че трябва И-нета да минава през домашния му адрес.

Казва че получава достъп до локалните(за дома му) ресурси, но няма интернет...

Няма И-нет, защото не си е пуснал... Няма и нужда да си пуска от домашния, след като може да излезе в И-нет директно.

Само трябва да премахне добавянето на пътя по подразбиране...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • JohnTRIVOLTA
      By JohnTRIVOLTA
      Колеги здравейте, дали някой е запознат какви ограничения имат на L4 /изградени връзки/ виваком в предлаганите бизнес планове ! Няма да питам при вас как процедирате , че темата си е малко табу 🤫
    • mladentod
      By mladentod
      Здравейте, проблемът е следния:
      Преди няколко дни лаптопът ми (Asus с win 10) изведнъж спря да се свързва с L2TP/IPSec от hAP AC 2.
      Рестартирах рутера , гледах настройките - нищо.
      Същото име и парола от се закача за смартфона и един друг лаптоп. На PPTP също се свързва.
      Само и единствено на ASUS-a на L2TP не успява.
    • Sakrayaami
      By Sakrayaami
      Здравейте, 
      След като си закупих hAP ac2 и 2 дни борене, учене и проклинане и най вече с жокер от приятел, успях да си махна рутера на виваком и го замених изцяло с тик-а + пуснах STB box-a и IPTV на Ethernet 5 (5ти порт).
      Ето как стана:
      Мрежата в която съм е 192.168.1.0/24, конфигурацията на рутера ми е стандартния сетъп след рисет.
      1. Сетваме в MyContact.bg->Настройки за достъп MAC адреса на Wan порта(eth01) на МикроТик-а
      2. Пускаме и виждаме дали интернета работи
      3. Отваряме конзолата и създаваме нов бридж със сищия мак адрес като wan porta: 
      /interface bridge add name=bridge-wan disabled=no
      /interface bridge set bridge-wan admin-mac=xx:xx:xx:xx:xx:xx auto-mac=no         (сменяме xxx със мак адреса)
      4. Отиваме във Bridge->Ports и настройваме Ethernet port 5 да използва новия бридж bridge-wan
      5. Добавяме Нов порт - >Interface: Ethernet 1 Bridge:bridge-wan
      6. Отиваме в Ip->DHCP client и Добавяме нов клиент с Interface=bridge-wan
      7. Отиваме на Interfaces-> Interface List и променяме WAN интерфейса на bridge-wan

      Това е в общи линий, трябва да се има напредвид че конфигурацията която правя е върху RouterOS 6.45.1 Stable. 

      Интернета и IPTV тръгнаха след тази конфигурация, използването на конзолата е неизбежно тъй като няма как през графичния интерфейс да се сетне мак на бриджа който създаваме.

      Може ли по-знаещите да кажат какво мислят за по-горната конфигурация, дали е ОК от гледна точка на сигурност например? 
      Благодаря ви.
    • windwalker78
      By windwalker78
      Здравейте,
                Опитвам се да вдигна един SSTP VPN  между mikrotik 6.40.4 (Намира се зад NAT с port forward на 443) - Windows 7 x64 sp1 и виждам зор със сертификата май:
      Генерирам ги така и пускам и sstp услугата + ppp:
      /system identity set name=sstp.tbrook /certificate add name=ca-template common-name=sstp.tbrook days-valid=3650 key-size=2048 key-usage=crl-sign,key-cert-sign add name=server-template common-name=*.sstp.tbrook days-valid=3650 key-size=2048 key-usage=digital-signature,key-encipherment,tls-server add name=client-template common-name=client1.sstp.tbrook days-valid=3650 key-size=2048 key-usage=tls-client sign ca-template name=ca-certificate sign server-template name=server-certificate ca=ca-certificate sign client-template name=client-certificate ca=ca-certificate /ip pool add name=”vpn-pool” ranges=10.30.0.2-10.30.0.10 /ppp profile add name=”vpn-profile” use-encryption=yes local-address=10.30.0.250 dns-server=10.30.0.250 remote-address=vpn-pool secret add name=client1 profile=vpn-profile password=TestPass /interface sstp-server server set enabled=yes default-profile=vpn-profile authentication=mschap2 certificate=server-certificate force-aes=yes pfs=yes /certificate export-certificate ca-certificate export-passphrase=”” След това копирам cert_export_ca-certificate.crt на Win7 и го вмъквам под  Certificates (Local Computer) -> Trusted Root Certification Authorities
      Вкарах и  sstp.tbrook с ip адрес в hosts файла.
      Като опитам да се свържа, в windows виждам това:
      Error is again 0x800B010F The certificate’s CN name does not match the passed value. В логовете на микротика само това:
      sstp,ppp,debug: LCP lowerdown sstp,ppp,debug: LCP down event in initial state Някой с идея какво да пробвам?
    • Taner
      By Taner
      Привет, съфорумници.


      Ще ми помогнете ли да си направя пълен списък с всички VPN протоколи, чрез които могат да се изградят VPN мрежи прод Mikrotik Router OS, както и различните комбинации?
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.