Jump to content
  • 0

Крайно устройство спря да се свързва с VPN


mladentod

Question

mladentod

Здравейте, проблемът е следния:

Преди няколко дни лаптопът ми (Asus с win 10) изведнъж спря да се свързва с L2TP/IPSec от hAP AC 2.

Рестартирах рутера , гледах настройките - нищо.

Същото име и парола от се закача за смартфона и един друг лаптоп. На PPTP също се свързва.

Само и единствено на ASUS-a на L2TP не успява.

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 1

Религията ви нне позволява микротика да държи vpn-a  а вие да направите правила. 

Сега и нормално. Асус... Ма. Клиент.. Ма ОС.... Метаме боба и звездите ще ни кажат :)

Link to post
Share on other sites
  • 0

Може ли да постеш какво пише в лога на рутера,ако се стига до него де. Ако не стига до него проблем със защитната стена на вин10. Тя неговата стена е едно мазало.

Link to post
Share on other sites
  • 0
JohnTRIVOLTA
На 6.03.2020 г. at 9:59, mladentod написа:

Здравейте, проблемът е следния:

Преди няколко дни лаптопът ми (Asus с win 10) изведнъж спря да се свързва с L2TP/IPSec от hAP AC 2.

Рестартирах рутера , гледах настройките - нищо.

Същото име и парола от се закача за смартфона и един друг лаптоп. На PPTP също се свързва.

Само и единствено на ASUS-a на L2TP не успява.

Тези устройства зад нат на един и същи публичен адрес ли се намират или ползват различен ? Имаше преди проблем с l2/ipsec , че можеше само едно устройство да се свърже от един адрес .

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • mladentod
      By mladentod
      Здравейте, 
      Не знам как да си формулирам въпроса за да търся в гуугъл, затова пиша тук.
      Отскоро започнах да експериментирам с мрежата си вкъщи и да се уча да я конфигурирам.
      Накратко . Като доставчик ползвам ВИВАКОМ и след тяхното устройство имам hAP AC2. Изтрих цялата конфигурация и започнах от началото. 
      По LAN съм закачил  3 РС-та, 2 телевизора и NAS (който закупих скоро).    По WI-FI са - 6 телефона и 2 лаптопа.  Дотук всичко е ОК.
      Проблемът ми е при VPN-ите, когато не съм вкъщи.  Телефоните и лаптопите се закачат и обменям информация с  NAS-а , но опитам ли да влезна в Интернет,  ми показва че страницата не може да бъде достъпена. Това става и на PPTP, и L2TP IPSec.  Във Вивакомския модем съм пренасочил портове 4500 и 500.
      На вилата ми също пуснах VPN за пробата (там съм на Мтел,  при който няма такива схеми с портове на модем-ът им) и пак същото.
      Предполагам че пропускам някаква дребна настройка.
       Предварително благодаря.
    • windwalker78
      By windwalker78
      Здравейте,
                Опитвам се да вдигна един SSTP VPN  между mikrotik 6.40.4 (Намира се зад NAT с port forward на 443) - Windows 7 x64 sp1 и виждам зор със сертификата май:
      Генерирам ги така и пускам и sstp услугата + ppp:
      /system identity set name=sstp.tbrook /certificate add name=ca-template common-name=sstp.tbrook days-valid=3650 key-size=2048 key-usage=crl-sign,key-cert-sign add name=server-template common-name=*.sstp.tbrook days-valid=3650 key-size=2048 key-usage=digital-signature,key-encipherment,tls-server add name=client-template common-name=client1.sstp.tbrook days-valid=3650 key-size=2048 key-usage=tls-client sign ca-template name=ca-certificate sign server-template name=server-certificate ca=ca-certificate sign client-template name=client-certificate ca=ca-certificate /ip pool add name=”vpn-pool” ranges=10.30.0.2-10.30.0.10 /ppp profile add name=”vpn-profile” use-encryption=yes local-address=10.30.0.250 dns-server=10.30.0.250 remote-address=vpn-pool secret add name=client1 profile=vpn-profile password=TestPass /interface sstp-server server set enabled=yes default-profile=vpn-profile authentication=mschap2 certificate=server-certificate force-aes=yes pfs=yes /certificate export-certificate ca-certificate export-passphrase=”” След това копирам cert_export_ca-certificate.crt на Win7 и го вмъквам под  Certificates (Local Computer) -> Trusted Root Certification Authorities
      Вкарах и  sstp.tbrook с ip адрес в hosts файла.
      Като опитам да се свържа, в windows виждам това:
      Error is again 0x800B010F The certificate’s CN name does not match the passed value. В логовете на микротика само това:
      sstp,ppp,debug: LCP lowerdown sstp,ppp,debug: LCP down event in initial state Някой с идея какво да пробвам?
    • Taner
      By Taner
      Привет, съфорумници.


      Ще ми помогнете ли да си направя пълен списък с всички VPN протоколи, чрез които могат да се изградят VPN мрежи прод Mikrotik Router OS, както и различните комбинации?
    • полуемигрант
      By полуемигрант
      Здравейте,
      Имам си интернет и телевизия в София от Мтел.
      Живея обаче в Шотландия, и се чудя дали мога с два микротика (един в софия и е един на острова) да направя така, че като си взема STB-то да си гледам телевизия?
      Също се чудя дали някой може да ми продаде две рутерчета баш настроени, така че да ги бодна и всичко да потече красиво?
      Последното ми чудене ще мога ли да вземам банани от замунда?
    • mr_joker
      By mr_joker
      Здравейте,
      Може ли малко помощ. До скоро имах два рутера флашнати с DD-WRT - в офиса и в къщи и правех EoIP връзка по между им и като отворя файл експлорера виждах наредени всичките ми компютри зад рутерите и шернатите папки в тях. Сега смених рутерите с Микротици, като за целта съм напрвил L2TP тунел. (Забележете, че мрежите не са в един сегмент.) Не искам клиента да черпи интернет от сървъра, защото всеки рутер е вързан към PPOE доставчик на интернет.
      Къща (Сървър), Windows 7, ESET Smart Security 10
      Public IP: 1.1.1.1, Gateway:172.16.1.1, DHCP Pool:172.16.1.150-254
      Офис (Клиент), Windows XP, Windows Firewall
      Public IP: 2.2.2.2, Gateway:172.16.2.1, DHCP Pool:172.16.2.150-254
      НАСТРОЙКИ Kъща:
      /ppp secret add name=user1 password=12345678 local-address=172.16.100.1 service=l2tp profile=default-encryption remote-address=172.16.100.2 routes="172.16.2.0/24 172.16.100.2 1" /interface l2tp-server server set enabled=yes /ip firewall filter add disabled=no action=accept chain=input place-before=4 protocol=udp dst-port=500,4500,1701 comment="IPSec Tunnel IKE, NAT Traversal - test !!!" add disabled=no action=accept chain=input place-before=4 protocol=ipsec-esp comment="IPSec Tunnel ESP - test !!!"
      НАСТРОЙКИ Офис:
      /interface l2tp-client add connect-to=1.1.1.1 disabled=no name=l2tp-out1 user=user1 password=12345678 /ip route add distance=1 dst-address=172.16.1.0/24 gateway=l2tp-out1 /ip firewall filter add disabled=no action=accept chain=input place-before=4 protocol=udp dst-port=500,4500,1701 comment="IPSec Tunnel IKE, NAT Traversal - test !!!" add disabled=no action=accept chain=input place-before=4 protocol=ipsec-esp comment="IPSec Tunnel ESP - test !!!" ПРОБЛЕМ 1:
      За да има пинг до всеки компютър трябваше да ги разреша РЪЧНО в антивирусната и защитната стена, докато при DD-WRT-то не съм парвил нищо и пак се виждаха компютрите по между си.
      Къща->windows 7->ESET->Разширени настройки->ЛИЧНА ЗАЩИТНА СТЕНА->РАЗШИРЕНИ->Зони->Редактиране->Доверена зона->Редактиране->Адрес на отдалечен компютър:172.16.2.0/24
      Офис->Windows XP->Control Panel->Security Center->Windows Firewall->Exceptions->File and Printer Sharing->Edit->Port 445->Change scope->Custom list:172.16.1.0/24
      ВЪПРОС 1: Как да настроя микротиците без да настройвам антивирусната и файъруола?
      --------
      ПРОБЛЕМ 2:
      Компютрите не искат да се наредят автоматично във Файл експлорера->Мрежа
      --------
      ПРОБЛЕМ 3:
      Компютрите се виждат само чрез IP адреса им и не могат чрез името си, докато при DD-WRT се виждаха с имената си:
      \\172.16.2.150\SharedFolder вместо \\ComputerName\SharedFolder
      ВЪПРОС 3: Как да настроя микротиците за да се виждат компютрите в общата мрежа чрез имената си?
      --------
      ПРОБЛЕМ 4:
      Когато компютър влезе в "стенд бай" режим (изгаснал му е екрана след 15-тата минута, но не и харда (след 30-тата)), но не е заспал, вече няма пинг до него, като при DD-WRT имаше пинг.
      --------
      Пуснал съм UpNP и на двата рутера с ether1: external и bridge: internal
      Всички правила във файъруола са след ресет и няма добавено нищо освен в Mangle:
      ---- Когато някой сайтове не искат да се отварят:
      Правилата трябва да са най-отгоре, като изтривам динамичните създадени от Микротик
      /ip firewall mangle add chain=forward action=change-mss new-mss=1400 passthrough=yes tcp-flags=syn protocol=tcp out-interface=all-ppp tcp-mss=1401-65535 comment="Mikrotik unable to load websites - Out" add chain=forward action=change-mss new-mss=1400 passthrough=yes tcp-flags=syn protocol=tcp in-interface=all-ppp tcp-mss=1401-65535 comment="Mikrotik unable to load websites - In" Да ползвам долното а не горното, че генерира много голям трафик може би заради all-ppp
      / ip firewall mangle add chain=forward action=jump jump-target=mss comment="{tcp}, mss" disabled=no add chain=mss protocol=tcp tcp-flags=syn tcp-mss=!536-1460 action=change-mss new-mss=1440 comment="{tcp}, mss fixation" disabled=no add chain=mss protocol=tcp tcp-flags=syn tcp-mss=1453-65535 action=change-mss new-mss=1440 comment="{tcp}, mss 1440 for mtu 1492" disabled=no add chain=mss protocol=tcp tcp-flags=syn action=change-mss new-mss=clamp-to-pmtu comment="{tcp}, mss clamp-to-pmtu" disabled=no --------
      ТЕСТОВЕ:
      Тествах с различни вариации на долните правила, но без успех, като или нямаше никакъв ефект или разкачаха връзката. Променях ETH1 и Bridge интерфейсите на ARP-Proxy и на двата рутера, на пак без успех.
      /ip firewall nat (не минава никакъв трафик през това!!!) add disabled=yes action=accept chain=srcnat place-before=0 src-address=172.16.2.0/24 dst-address=172.16.1.0/24 out-interface=ether1 comment="IPSec Tunnel - NAT bypass rule - test !!!" /ip firewall filter (няма ефект и в NAT, но е за FILTER - не минава никакъв трафик през тях!!!) add disabled=yes action=accept chain=input protocol=tcp src-address=172.16.2.0/24 dst-port=139,445 comment="IPSec Tunnel - Shared folders LAN TCP - test !!!" add disabled=yes action=accept chain=input protocol=udp src-address=172.16.2.0/24 dst-port=137,138 comment="IPSec Tunnel - Shared folders LAN UDP - test !!!" add disabled=yes action=accept chain=input protocol=tcp src-address=1.1.1.1/31 dst-port=139,445 comment="IPSec Tunnel - Shared folders WAN TCP - test !!!" add disabled=yes action=accept chain=input protocol=udp src-address=1.1.1.1/31 dst-port=137,138 comment="IPSec Tunnel - Shared folders WAN UDP - test !!!" /ip firewall filter (не минава никакъв трафик през тях!!!) add disabled=yes action=accept chain=forward place-before=1 src-address=172.16.2.0/24 dst-address=172.16.1.0/24 connection-state=established,related comment="IPSec Tunnel - If fasttrack enabled - Slow!!! must use RAW firewall" add disabled=yes action=accept chain=forward place-before=1 src-address=172.16.1.0/24 dst-address=172.16.2.0/24 connection-state=established,related comment="IPSec Tunnel - If fasttrack enabled - Slow!!! must use RAW firewall" да използвам долното, защото горното е много бавно
      /ip firewall raw add disabled=yes action=notrack chain=prerouting src-address=172.16.2.0/24 dst-address=172.16.1.0/24 add disabled=yes action=notrack chain=prerouting src-address=172.16.1.0/24 dst-address=172.16.2.0/24 ======================================
      Тествах и на какво MTU се отваря локалната мрежа без да дава нито една грешка и промених MTU-то в интерфейсите, но без успех:
      Find proper MTU:
      netsh interface ipv4 show subinterfaces
      ping www.vbox7.com -f -l 1452
      Proper MTU: 1452+28=1480 Къща & Офис за www.vbox7.com
      Proper MTU: 1394+28=1422 Къща & Офис за Local network
      netsh interface ipv4 set subinterface "Local Area Connection" mtu=1480 store=persistent
      netsh interface ipv4 set subinterface "Wireless Network Connection" mtu=1480 store=persistent
      netsh interface ipv4 set subinterface "Bluetooth Network Connection" mtu=1480 store=persistent
      DEFAULT: eth1=pppoe-out1, eth2=bridge - MTU=1500, L2MTU=1598
      NEW:  eth1=pppoe-out1, eth2=bridge - MTU=1422
      ======================================
      Това което си мисля, че ми се изясни от четенето в нета е, че трябва да разреша по някаъв начин broadcast трафика и другото е, че WINS сървър не ми трябва. Моля, да ми помогнете да реша проблемите.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.