Jump to content
  • 0

Проблем с NTP Server на RB с 5.25


master
 Share

Question

В началото имах проблем с подкарването на самия server и след инсталация на пакета стана.

Схемата е следната:

 

Доставчик Х <-> Микротик RB като връзката от доставчика до микротика е с P2P линк изграден на базата на UBNT.

Радиата са във вътрешна мрежа 192.168.ХХ.ХХ и се виждат от микротика който има добавена въпросната мрежа.

 

Искам Микротика да играе роля на NTP server за да могат да се сверяват през него тъй като на тяхната мрежа няма интернет.

 

Вдигнах server-a на миктотик, въведох IP то на МТ като GW на радиата, както и в полето NTP но ефект няма.

 

Някаква идея ?

Analog Audio™

Link to comment
Share on other sites

Recommended Posts

  • 0

Провери защитната стена на NTP-то.В полето трябева да е въведен ИП адреса на NTP сървъра.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • 0

/ip firewall nat add action=src-nat chain=srcnat comment="NTP" disabled=no
protocol=udp src-port=123 to-addresses=192.168.0.1 

 

?


Приемам и други идеи за сверяване на радиата :) Може и моя подход да не е правилен.

Analog Audio™

Link to comment
Share on other sites

  • 0

Не,това не ти трябва изобщо.

Имах предвид да се добави на радиата в менюто sntp client  ИП адреса на NTP сървъра,протокола е unicast.

Ако МТ е с адрес 192.168.0.1 и радиата са в същата мрежа или субнет би трябвало да нямаш никакви проблеми.Вероятно си филтрираш ntp port-а  или MT ntp сървъра не ти слуша на локалния адрес.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • 0

Да на NTP Client на радиата в полето е посочен IP адреса на микротика примерно той е 192.168.192.254 те са съответно .1 и .2

 

Не филтрирам 123 порт.

 

NTP клиента на микротика си е настроен и се сетва след всеки рестарт успешно.

 

Server-a e сетна по следния пример:

/system ntp server
set broadcast=no enabled=yes manycast=yes multicast=no


........ или MT ntp сървъра не ти слуша на локалния адрес.

Ами локалния адрес е на входящия интерфейс за да могат да се виждат .


Да не би да може да работи само към изходящия си интерфейс ?

 

То на практика няма никъде как да се зададе към кой интерфейс да работи.

Analog Audio™

Link to comment
Share on other sites

  • 0

Трябва да направиш disable/enable на ntp сървъра когато добавяш адреси по интерфеиските,за да слуша и на тях.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • 0

Когато сетна на някой от радиата зад MT т.е. на изходящия му интерфейс IP то му радиото се сверява. Но на тези които са на входящия му не става.

Те адресите бяха сложени преди да се сложи пакета за NTP server.

Edited by master

Analog Audio™

Link to comment
Share on other sites

  • 0

Неможе да не става,пробвано е и работи.

От радиата вижда ли се с пинг адреаса на ntp сървъра ?

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • 0

Микротика има 2 мрежи на входящия и 2 на изходящия интерфейс.

 

Като една от мрежите на входящия е въпросната 192.... и се пингва на 0,5s. без никакви проблеми.

То и от там се администрират радиата.

Analog Audio™

Link to comment
Share on other sites

  • 0

Няма значение,може и 20 мрежи да им сложиш.

Пусни си ntp лога  или си сложи превило да ти брои пакетите на ntp порта за да разбереш къде какво отива/идва.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • 0

В лога нищо за сега..


Много странно, че клиентското радио се свери макар и с 3 часа отклонение което не е проблем и е най-вероятно от часова зона, но AP то все още не е.


п.п. И АП то се свери като дори гейта му не е микротика, а само съм посочил NTP server-a. Не разбрах обаче защо стана толкова бавно. На другите радиа зад рутера се свериха за секунди но те са към външен NTP.

Благодаря за помощта!

Edited by master

Analog Audio™

Link to comment
Share on other sites

  • 0
  • Administrator

като втори NTP-сървър слагай съседното така един да се свери всички ще се сверят

задай в защитната стена правило

input :123 allow

без да задаваш интерфейс и да е над дроп правилата

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Нямам опция за 2ри NTP.

 

Обаче нещо не разбрах това за imput-a

Edited by master

Analog Audio™

Link to comment
Share on other sites

  • 0
  • Administrator

За това става въпрос

/ip firewall filter
add chain=input comment="NTP udp :123" dst-port=123 protocol=udp place-before=0 action=accept
трябва директно да се появи най отгоре и да отчита пакети при заявка
Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Мерси сега ще пробвам.

 

През определено време по 1 пакет отчита :)

Edited by master

Analog Audio™

Link to comment
Share on other sites

  • 0
  • Administrator

сега провери дали се сверяват

за да нямаш 2 алтернативи нямаш NTP пакет-а на клиентите и караш с вградения SNTP

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.