Jump to content
  • 0

Въпрос за Netwatch


dobatavision

Question

dobatavision

Здравейте,

 

Имам 2 доставчика на нет които използвам едновременно.

Пуснах 2 правила в Netwatch едното следи 8.8.4.4 за единия доставчик, другото правило следи 8.8.8.8 за 2рия доставчик.

Ако спре да пингва спира съответния /ip routes ако дойде пинг го активира пак.

Дайте идея как да деактивирам другото правило в netwatch ако едно премине в статус Down.

Така ще остане поне единия доставчик да работи, защото ако спрат и 2та dns-a ще ми се деактивират и 2та доставчика... :)

2011UAS-2HnD

Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0
  • Administrator

Просто променяй рутинг дистанцията
примерно:

при обстоятелство 1
единия доставчик е с дистанция 1 а втория с 2
при обстоятелство 2 
наобратно

 

Същото става и с DHCP клиента или РРР сесията

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites
  • 0
dobatavision

Кои дистанции да сменям защото използвам и Rules ?

В момента eth1 взима от eth9, eth2 & eth3 взимат от eth6.

И в двата случая всяка локална мрежа си има отделно ip от доставчика.

Ако нещо стане с единия ISP,  eth1,2,3 минават на този който все още е жив.

 

rulesss.png.35a300a1830bd040febcf965e2b266e8.pngroutesss.png.24047d567b8f22653afe958506aa30ac.png

 

2011UAS-2HnD

Link to post
Share on other sites
  • 0
JohnTRIVOLTA

Маркирал си определен трафик т.е. имаш повече от една рутинг таблица . Гледам имаш рекурсивни пътища и нуждата от нетуач не е нужна. Просто ще ги повториш за всяка таблица рекурисвните пътища с нужната дистанция. Ласт рисорт маршрутите ги пусни с дитанция 3 като резерв, за да се активират при отпадане на ДНС сървърите евентуално.

И ако те е страх толкова може да добавиш още рекурсивни пътища по таблиците !

Edited by JohnTRIVOLTA
Link to post
Share on other sites
  • 0
dobatavision
Преди 12 часа, JohnTRIVOLTA написа:

Маркирал си определен трафик т.е. имаш повече от една рутинг таблица . Гледам имаш рекурсивни пътища и нуждата от нетуач не е нужна. Просто ще ги повториш за всяка таблица рекурисвните пътища с нужната дистанция. Ласт рисорт маршрутите ги пусни с дитанция 3 като резерв, за да се активират при отпадане на ДНС сървърите евентуално.

И ако те е страх толкова може да добавиш още рекурсивни пътища по таблиците !

Можеш ли да дадеш пример върху скрийншота?

Check gateway ми е празно за всички routes.

2011UAS-2HnD

Link to post
Share on other sites
  • 0
JohnTRIVOLTA

Сега като се загледах в зачеркнатите , се оказа че нямаш точно тези пътища.

Първо сейвни си конфигурацията. След това изтрий всички статични пътища и добави тези:

/ip r
add dst-address=8.8.8.8 scope=10 gateway=8......
add dst-address=8.8.4.4 scope=10 gateway=9......
add dst-address=8.8.8.8 scope=10 gateway=8...... routing-mark=xxxx
add dst-address=8.8.4.4 scope=10 gateway=9...... routing-mark=xxxx
add dst-address=8.8.8.8 scope=10 gateway=8...... routing-mark=yyyy
add dst-address=8.8.4.4 scope=10 gateway=9...... routing-mark=yyyy
add dst-address=0.0.0.0/0 gateway=8.8.8.8 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=8.8.4.4 check-gateway=ping distance=2
add dst-address=0.0.0.0/0 gateway=8...... distance=3
add dst-address=0.0.0.0/0 gateway=9...... distance=4
add dst-address=0.0.0.0/0 gateway=8.8.8.8 check-gateway=ping routing-mark=xxxx
add dst-address=0.0.0.0/0 gateway=8.8.4.4 check-gateway=ping routing-mark=yyyy
add dst-address=0.0.0.0/0 gateway=8.8.4.4 check-gateway=ping routing-mark=xxxx distance=2
add dst-address=0.0.0.0/0 gateway=8.8.8.8 check-gateway=ping routing-mark=yyyy distance=2
add dst-address=0.0.0.0/0 gateway=8...... routing-mark=xxxx distance=3
add dst-address=0.0.0.0/0 gateway=9...... routing-mark=yyyy distance=3
add dst-address=0.0.0.0/0 gateway=8...... routing-mark=yyyy distance=4
add dst-address=0.0.0.0/0 gateway=9...... routing-mark=xxxx distance=4

Замести си публичните гейтове с 8 и 9 и също марките за съответната таблица.

До колкото разбирам едната мрежа минава през основната рутинг таблица и през гейт с основен адрес 8....

Втора мрежа през втора таблица с гейт също 8....

и трета мрежа през трета таблица с гейт с 9.... адрес

При отпадане на някой ще ползват другият , а при отпадане и на двата ползват ласт рисорт пътищата първо 8... ако падне ще мине към 9... и обратната за първа и втора лан и обратната за 3тата лан !

Ако са други таблиците ти може да се ориентираш за принципа и дали ще добавиш още таблици и какви пътища са нужни

 

Edited by JohnTRIVOLTA
Link to post
Share on other sites
  • 0
dobatavision

@JohnTRIVOLTA

Това изглежда интересно, но ще ми отнеме доста време да го тествам.

Mойта конфигурация съм я изтествал и ако има начин да спра правилото Х когато Y=down и когато Y стане 'up' да прави X enable и обратно ще ми реши проблема за сега.

netwatchhh.JPG.54a609753bbfef89863bc36e31e1690b.JPG 

Edited by dobatavision

2011UAS-2HnD

Link to post
Share on other sites
  • 0
JohnTRIVOLTA

Колко пък време може да отнеме да си направиш бекъп на устройството, да дадеш дисейбъл на статичните пътища и да копираш тези които ти дадох ?

Както и да е , по въпроса какво да напишеш , най-елементарното, което се сещам е при ъп или даун да сложеш респективно нужният номер път които ще ги видиш номера пример от :

/ip r print

да се активира или спира път в правилото на нетуоч:

/ip r set numbers=1 disabled=no
или
/ip r set numbers=1 disabled=yes
или пък един спираш , а друг се пуска
/ip r set numbers=0 disabled=no
/ip r set numbers=1 disabled=yes
и т.н.

 

Link to post
Share on other sites
  • 0
dobatavision

Мисля, че го оправих с по един if в 2та Up-a в netwatch.

Да прави enable другия, само ако е disable в момента.

Ще постна скрипта по-късно.

Но пък нещо странно стана и не виждам от какво може да е. Ако съм в мрежа 172.16.1.0 не мога да достъпя устройства от 172.16.2.0...

Не ми се вярва да е от L2TP servera който активирах.

2011UAS-2HnD

Link to post
Share on other sites
  • 0
JohnTRIVOLTA
Преди 7 часа, dobatavision написа:

Но пък нещо странно стана и не виждам от какво може да е. Ако съм в мрежа 172.16.1.0 не мога да достъпя устройства от 172.16.2.0...

Пример с правило може да окажеш в мангъл да не се маркират заявки със сорс 72.16.1.0/24 и дстн 172.16.2.0/24 . Но това е само предположение след като нямям конфига пред мен

Link to post
Share on other sites
  • 0
dobatavision

netwatchhh.thumb.png.5e68db89e2aa41f76f086a8c2412b27e.png

Това направих с netwatch-a и работи, тоест това ми беше питането в началото.

А NAT го качвам да се вижда, ако има някакъв лесен начин да виждам локалните устройства и от 3те мрежи без значение в коя съм.

NAT правилата от снимката са action=src-nat, to-addresses=ip-от доставчик, всяка мрежа ползва различно ip и за 2та доставчика.

IP-тата съм си ги описал в /ip addresses - x.x.x.x/29 и за 6-те които използвам.

Пробвах по-горе mangle не стана(или не съм оцелил chain,action), стана с NAT action=srcnat, chain=masquerade , src.address=172.16.1.0/24, dst.address=172.16.3.0/24 и когато съм в мрежа х.х.1.0 виждам устройства от мрежа x.x.3.0, възможно ли е да стане проблем с горните правила така ?

🙃

 

Edited by dobatavision

2011UAS-2HnD

Link to post
Share on other sites
  • 0
JohnTRIVOLTA

Вкарай си в адрес лист локалните мрежи. В мангъл задай правило с аксепт сорс и дистинейшън нея листа :

/ip fi m add chain=prerouting src-address-list=myLANs dst-address-list=myLANs place-before=1

По този начин заявките в локалните сегменти няма да се маркират и ще четат основната рутинг таблица и трябва да се рутират по между си стига в стената да не си добавил някакво друго ограничаващо правило във форуард потока! .... ако го пробваш разкарай излишните сорс правила !

 

Link to post
Share on other sites
  • 0
JohnTRIVOLTA
преди 8 минути, dobatavision написа:

Кои са излишните сорс правила ?

Оставаш тези с които натваш към публичното пространство само !

Edited by JohnTRIVOLTA
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • JoroNikolaev
      By JoroNikolaev
      Привет, 
      Някой може ли да ми даде съвет с каква апратура да направя бридж (дистанция по карта 12км), търся нещо около 50-100mbps (за лично ползване е). Повече търся стабилност на линка. Първоначално се насочих към LHG 5, но прочетох, че се влиае от шум. Притеснявам се, че сигнала ще го пращам от връх на планина на който има 3 кули с антени на оператори и интернет доставчици. 
      Бюджета е около 250-300лв
      Поздрави, 
    • bgoptic
      By bgoptic
      Използвани
      RBLHGG-60ad kit                                                    2 комплекта                       210лв./комплекта
      Нови
      RBLHGG-60ad kit                                                    2 комплекта                       350лв./комплекта
      MIKROTIK RBwAPG-60ad kit                                1 комплект                         220лв./комплекта
      SXT SA5AC                                                              6бр.                                       130лв./бр.

      PowerBeam 2AC-400                                            1бр.                                       160лв./бр.
       
      За повече инфо телефон: +420 77 три 016 шест 17(viber) или на Л.С.
    • new1
      By new1
      Продавам малко мрежова техника:
      1. Рутер борд RB433AH в кутия CA433U  с две безжични карти DNMA-91 и 4 антенки 2db -65лв (продават се на комплект)

      2. борд RB411+ безжична карта APC11 - 20лв
      3. безжични карти RB52Hn -20 лв.
      4. безжични карти R52n-M - 15 лв.
      5. безжични карти r52 , 3бр DNMA-91 - по 5лв/бр

      6. кутия алуминиева херметична за външен монтаж на MikroTik + Mini UPS 1225 Neomontana (батерия бонус-не е работила 5год) - 25лв

      7. кутия алуминиева масивна херметична за външен монтаж от усилвател за кабелна (бонус пигтейл ACMMCX ) - 15лв

      8. кутия за вътрешен монтаж CA433U - 15лв

      9. антена външна JPA-9 - 8лв
      10. антена омни от грууви - 15лв
      11. антени 2,4-5ghz конектор rpsma плоски 5db 4бр - по 7лв/бр
      12. антени 2,4-5ghz конектор rpsma дълги 27 см 7db 4бр - по 12 лв/бр
      13. антени 2,4-5ghz конектор mmcx плоски 5db 4бр - по 5лв/бр




      14. пигтейли нов ACUFL - U.fl-Nfemale 1бр - 5лв.
      15. пигтейли нови ACMMCX - MMCX-Nfemale 10бр - 7лв/бр.
      16. пигтейли U.fl-RpSMA нови и употребявани 4бр - 2лв/бр (на някои липсват шайбите за застопоряване )
      17. пигтейли MMCX-RpSMA нови и употребявани 5бр - 3лв/бр (на някои липсват шайбите за застопоряване )
      18. преходници Nfemale-Nfemale 2бр - 5лв/бр.

      19. POE активно ubiquiti gp-a240-050 - 15лв
      20. POE пасивни 2бр - 5лв/бр.

      За поръчка: O885I98992 
      За допълнителна информация Viber и ЛС.
      Цените са твърди при интерес само от един артикул. Възможно договаряне над 100лв.
      Намират се в София. Възможно лично предаване в града. За страната по куриер. 
      Не мога да издам фактура.

       
    • master
      By master
      Продавам следните нови устройства без гаранция пълен комплект :
      - SXT SA5 AC  8броя / 145лв. за брой
      - Omnitik AC 1брой / 150лв. за брой
      - Mikrotik Disc AC 5 2броя / 80лв. за брой
      Намират се във Варна, за повече информация на Л.С. / О886811477.
    • bgoptic
      By bgoptic
      Нови
      MikroTik Omnitik 5AC-5HacD                                                 2бр.                             90лв./бр.
      PowerBeam 2AC-400                                                               1бр.                             165лв.
      Захранване  MEANWELL AD-155C                                       5бр.                             30лв./бр.      
                              MEANWELL AD-155B                                       5бр.                              30лв./бр.
       
      За повече инфо телефон: +420 77 три 016 шест 17(viber) или на Л.С.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.