Jump to content
  • 0

RB2011 vlans switched или bridged


windwalker78
 Share

Question

      Здравейте,

      От скоро имам RB2011 6.40.4 с 5 gigabit и 5 fast ethernet порта на различни switch групи. Ще пускам vlan-и преди стандартно го правех като за всеки vlan правех отделен бридж и на него слагах DHCP server и т.н. Сега искам да го направя със switch чиповете, като накрая само вържа в бридж master-ports на двата switch-a (ETH2 и ETH6).

Това целя:

ETH1 – WAN

ETH2(master port for ETH3-ETH5) – Trunk to HP switch vlan10,vlan20,vlan99 (tagged)

ETH3 – Access vlan99 (untagged)

ETH4 – Access vlan20 (untagged)

ETH5 – Access vlan20 (untagged)

 

ETH6 (master port for ETH7-ETH10)– Acess vlan20 (untagged)

ETH7 – Access vlan20 (untagged)

ETH8 – Access vlan20 (untagged)

ETH9 – Access vlan20 (untagged)

ETH10 – Access vlan20 (untagged)

 

Чудя се ще има ги разлика в производителността, ако направя vlan-ите през switch? Примерно да не се товари CPU за трафик между ETH4 и ETH5.

 

Поздрави

 

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

        Добрем, DIY ще е работата. Снощи поджитках по нощите и ето равносметка за питащите се същото:

Оказва се че Микротик добре са си свършили capacity planning работата и дори в бридж нещата между съседни портове в един VLAN (за една switch група), процесора се товари не повече от 80% за 110MB/sec трансфер. Никак не е лошо, но аз пак си го направих със суич, че да няма никакво натоварване. За разлика от официалното howto при този конкретен модел имаше зор като се сетне default vlan-id на switch-cpu1. Ако се сетне и всичко умира. Ето конфигурацията само за основа с два VLAN-a:

 

 

/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2
set [ find default-name=ether5 ] master-port=ether2
set [ find default-name=ether7 ] master-port=ether6
set [ find default-name=ether8 ] master-port=ether6
set [ find default-name=ether9 ] master-port=ether6
set [ find default-name=ether10 ] master-port=ether6
/interface vlan
add interface=bridge1 name=vlan20 vlan-id=20
add interface=bridge1 name=vlan99 vlan-id=99
/interface ethernet switch port
set 2 default-vlan-id=20 vlan-header=add-if-missing vlan-mode=secure
set 3 default-vlan-id=99 vlan-header=always-strip vlan-mode=secure
set 4 default-vlan-id=20 vlan-header=always-strip vlan-mode=secure
set 5 default-vlan-id=20 vlan-header=always-strip vlan-mode=secure
set 6 default-vlan-id=20 vlan-header=always-strip vlan-mode=secure
set 7 default-vlan-id=20 vlan-header=always-strip vlan-mode=secure
set 8 default-vlan-id=20 vlan-header=always-strip vlan-mode=secure
set 9 default-vlan-id=20 vlan-header=always-strip vlan-mode=secure
set 10 default-vlan-id=20 vlan-header=always-strip vlan-mode=secure
set 11 vlan-mode=secure
set 12 vlan-mode=secure
/ip pool
add name=office ranges=192.168.99.100-192.168.99.150
add name=secure ranges=10.20.0.100-10.20.0.150
/ip dhcp-server
add address-pool=office disabled=no interface=vlan99 name=office
add address-pool=secure disabled=no interface=vlan20 name=secure
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether6
/interface ethernet switch vlan
add independent-learning=no ports=switch1-cpu,ether2,ether4,ether5 switch=switch1 vlan-id=20
add independent-learning=no ports=switch1-cpu,ether2,ether3 switch=switch1 vlan-id=99
add independent-learning=no ports=switch1-cpu switch=switch1 vlan-id=10
add ports=switch2-cpu,ether6,ether7,ether8,ether9,ether10 switch=switch2 vlan-id=20
/ip address
add address=192.168.99.1/24 interface=vlan99 network=192.168.99.0
add address=10.20.0.1/24 interface=vlan20 network=10.20.0.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=10.20.0.0/24 dns-server=10.20.0.1 gateway=10.20.0.1 netmask=24
add address=192.168.99.0/24 dns-server=192.168.99.1 gateway=192.168.99.1 netmask=24

 

Това гарантира, че примерно при трансфер между портове 4, 5 и трънка на 2ри няма да ви се товари процесора. Ако се прави трансфер между switch1 и switch2 натоварването не е повече от 15% за тези 100MBIT-a.

 

Поздрави,

Тодор

 

 

Edited by windwalker78
  • Like 1
Link to comment
Share on other sites

  • 0

Обработката на пакета (във суич чипа) винаги ще е по бърза във суича отколкото във бридж.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • 0

Аз целя изолация на трафика от различните VLAN-и.  Единствено ми е любопитно дали при обновлението intervlan пакетите ще се обработват изцяло от switch частта или пак ще минават през CPU. Първото ще е супер яко.

Ако обновя пише, че ще има някои особености при downgrade и засега не мисля да го пробвам:

Note: Downgrading to previous RouterOS versions will not restore master-port configuration. The bridge with no hw-offload will appear instead and master-port configuration will have to be redone from the beginning.


Ако някой знае или разбере да пише.

Благодаря

Link to comment
Share on other sites

  • 0
Преди 11 часа, kokaracha написа:

Обработката на пакета (във суич чипа) винаги ще е по бърза във суича отколкото във бридж.

До колкото знам суич чипът обработва единствено хедъра на фреймовете т.е. пакета хич го не пипа , та от там и действията , които извършва са доста малко, като вид са несъпоствимо по-малко от колкото са на по-горно ниво. Ако бъркам нещо може да ме поправите.

 

На 10/19/2017 at 11:58, windwalker78 написа:

  add independent-learning=no ports=switch1-cpu switch=switch1 vlan-id=10

И към колегата , да ми разясни този ред , че не можах да схвана от къде се пръкна?

Link to comment
Share on other sites

  • 0
1 hour ago, JohnTRIVOLTA said:

До колкото знам суич чипът обработва единствено хедъра на фреймовете т.е. пакета хич го не пипа , та от там и действията , които извършва са доста малко, като вид са несъпоствимо по-малко от колкото са на по-горно ниво. Ако бъркам нещо може да ме поправите.

Аз също смятам, че това ще разтовари процесора, но ми се иска някой с 6.41 да потвърди. Така или иначе в моя сценарий няма полза, тъй като всичко ще ходи към ETH1.

 

1 hour ago, JohnTRIVOLTA said:

И към колегата , да ми разясни този ред , че не можах да схвана от къде се пръкна?

Заданието ми горе е:
ETH2(master port for ETH3-ETH5) – Trunk to HP switch vlan10,vlan20,vlan99 (tagged)

Просто не съм сложил останалия конфиг за vlan10, който ще се ползва също. Реално vlan-ите ще са 3, но RB2011 няма да има access points към този vlan.

 

Link to comment
Share on other sites

  • 0

https://wiki.mikrotik.com/wiki/Manual:Switch_Chip_Features#Bridge_Hardware_Offloading

 

За L2 трафик на същия vlan, не би трябвало да се товари ЦПУ (тестваш за всеки случай)

AR8327, AR8227 Features in Switch menu - желаната конфигурация изглежда ще използва hw offloading 

 

image.thumb.png.1288dcdef6d285e7c36adb086fbcd5c4.png

 

разбира се освен за трафик между 1..5 <-> 6..10 

За този трафик можеш да не използваш 6..10 изобщо (disabled),  след като имаш и суич със VLANи

6..10 на този модел не са удобни L2 трафик до 1..5 дори и да е едва 15% за 100Мбит , ресурса се запазва за routing, connection tracking, firewall, management, troubleshooting tools etc.

 

За L3 трафик, ще се товари ЦПУ, но ако активираш fast track, ще е пренебрежителен товарът (тестваш за всеки случай)

https://wiki.mikrotik.com/wiki/Manual:IP/Fasttrack

 

Link to comment
Share on other sites

  • 0
On 10/21/2017 at 6:42 AM, NetworkPro said:

https://wiki.mikrotik.com/wiki/Manual:Switch_Chip_Features#Bridge_Hardware_Offloading

 

За L2 трафик на същия vlan, не би трябвало да се товари ЦПУ (тестваш за всеки случай)

AR8327, AR8227 Features in Switch menu - желаната конфигурация изглежда ще използва hw offloading 

 

 

 

разбира се освен за трафик между 1..5 <-> 6..10 

За този трафик можеш да не използваш 6..10 изобщо (disabled),  след като имаш и суич със VLANи

6..10 на този модел не са удобни L2 трафик до 1..5 дори и да е едва 15% за 100Мбит , ресурса се запазва за routing, connection tracking, firewall, management, troubleshooting tools etc.

 

За L3 трафик, ще се товари ЦПУ, но ако активираш fast track, ще е пренебрежителен товарът (тестваш за всеки случай)

https://wiki.mikrotik.com/wiki/Manual:IP/Fasttrack

 

 

Много благодаря за детайлните скрийншотове и съвета за FastTrack. Това с tagged и untagged са го направили да изглежда като на другите вендори, което също ми допада. Исках да те попитам това на RB2011 ли е и ROS коя версия е?

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.