Jump to content
  • 0

Load Balancing/File-Over


Стоян Иванов
 Share

Question

Здравейте! Предполагам ви е писнало от въпроси относно балансинга, но тъй като ми се налага да направя такава конфигурация търся съвет. Правил съм и преди ECMP/PCC. и самата конфигурация е последното нещо което ме притеснява. Този начин на балансиране според мен е проблемен. Могат да се очакват проблеми с https, ssl, проблеми с натнати усроиства като dvr-ри или дори една съвсем проста RDP връзка. Въпроса ми е, някой успял ли е да конфигурира balancing/fail-over където да са избегнати тези проблеми или поне да не са толкова силно изразени. Може и да не ми обяснявате лично тук, ако нямате време. Просто споделете някакво линкче и аз ще прочета това, което ми трябва. Надявам се да има някакво по-стабилно решение вече. И още един въпрос: - Някой ползвал ли е dual wan ( balancing/fail-over рутер) и какви са впечатленията ви от тях. Имаt ли същите проблеми? Благодаря на отзовалите се.

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0
  • Administrator

Маркирането на трафика помага на изходящия трафик.

За входящия става по сложно с DNS Failover.

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0
Преди 11 часа, Стоян Иванов написа:

Здравейте! Предполагам ви е писнало от въпроси относно балансинга, но тъй като ми се налага да направя такава конфигурация търся съвет. Правил съм и преди ECMP/PCC. и самата конфигурация е последното нещо което ме притеснява. Този начин на балансиране според мен е проблемен. Могат да се очакват проблеми с https, ssl, проблеми с натнати усроиства като dvr-ри или дори една съвсем проста RDP връзка. Въпроса ми е, някой успял ли е да конфигурира balancing/fail-over където да са избегнати тези проблеми или поне да не са толкова силно изразени. Може и да не ми обяснявате лично тук, ако нямате време. Просто споделете някакво линкче и аз ще прочета това, което ми трябва. Надявам се да има някакво по-стабилно решение вече. И още един въпрос: - Някой ползвал ли е dual wan ( balancing/fail-over рутер) и какви са впечатленията ви от тях. Имаt ли същите проблеми? Благодаря на отзовалите се.

Пробвай NTH балансиране - там поне се балансира на L3 и не би трябвало да имаш горните проблеми !

Link to comment
Share on other sites

  • 0

Load Balance Incoming Connections /  Load Balance Outgoing Traffic

Това са различния понятия момчета,правете ралика.

  • Like 1

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • 0
  • Administrator
Преди 14 часа, gbdesign написа:

BGP му е майката. 

Ама не работи с NAT и частни адреси.

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Подобно нещо ще ми се налага да правя и аз, за това да подкрепя малко темата.

Ако е само балансинг - преди съм правил под Линукс с маркиране на пакети и рутиране по WAN-овете - но това е схема, в която имаме използване на всички линии едновременно (определени видове трафик минават през конкретни WAN-ове, а някои ползват всички едновременно (примерно торрент)).

Сега ми е нужен точно fail-over с Микротик, понеже няма как да се вкара x86 машина, ако може да го прави на Layer2 - схемата при мен е двоен failover, като първия е с Микротик, втория е със рутер (TP-Link и подобни).
Всяка линия влиза на отделен SFP порт на Микротик комутатор, a втория failover е на рутер с налична SIM карта през мобилен.
Замислям се над вариант с пинг да следя коя линия е "жива", ако е жива основната да пуска трафика само от него. Ако тя падне - скрипта да прехвърля към другия порт.
Мислих и за бондинг с failover, но единия от интерфейсите няма да падне при прекъсване на комуникацията през него порт.

Поздрави.

“...ние, можещите водени от незнаещите, вършим невъзможното за кефа на неблагодарните. И сме направили толкова много, с толкова малко, за толкова дълго време, че сме се квалифицирали да правим всичко от нищо...”, Константин Йозеф Иречек, 13.12.1881 г.

Link to comment
Share on other sites

  • 0
Преди 3 часа, Networker написа:

Подобно нещо ще ми се налага да правя и аз, за това да подкрепя малко темата.

Ако е само балансинг - преди съм правил под Линукс с маркиране на пакети и рутиране по WAN-овете - но това е схема, в която имаме използване на всички линии едновременно (определени видове трафик минават през конкретни WAN-ове, а някои ползват всички едновременно (примерно торрент)).

Сега ми е нужен точно fail-over с Микротик, понеже няма как да се вкара x86 машина, ако може да го прави на Layer2 - схемата при мен е двоен failover, като първия е с Микротик, втория е със рутер (TP-Link и подобни).
Всяка линия влиза на отделен SFP порт на Микротик комутатор, a втория failover е на рутер с налична SIM карта през мобилен.
Замислям се над вариант с пинг да следя коя линия е "жива", ако е жива основната да пуска трафика само от него. Ако тя падне - скрипта да прехвърля към другия порт.
Мислих и за бондинг с failover, но единия от интерфейсите няма да падне при прекъсване на комуникацията през него порт.

Поздрави.

С рекурсивен път стават нещата лесно !

/ip route
add dst-address=8.8.8.8 gateway=192.168.1.1 scope=10
add gateway=8.8.8.8 distance=1 check-gateway=ping comment="Primary Route"
add dst-address=80.80.80.80 gateway = 192.168.1.1 scope=10
add gateway=80.80.80.80 distance=2 check-gateway=ping comment="Primary Route"
add dst-address=1.1.1.1 gateway=192.168.2.1 scope=10
add gateway=1.1.1.1 distance=3 check-gateway=ping comment="Secondary Route"
add dst-address=4.2.2.1 gateway = 192.168.2.1 scope=10
add gateway=4.2.2.1 distance=4 check-gateway=ping comment="Secondary Route"
add gateway=192.168.1.1 distance=5
add gateway=192.168.2.1 distance=6

Тука се ползват дори по два публични адреса за всеки WAN за да се подсигури пътя , ако се загуби достъп до него адрес да има втори за всеки случай!

Edited by JohnTRIVOLTA
  • Like 1
Link to comment
Share on other sites

  • 0
  • Administrator

Шедулера може да сменя дистанцията като допълнение.

  • Like 1
Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

За да не отварям друга тема ,да подпитам и аз нещо :)
Имам два линка единия го ползвам като основен другия ако се срине нещо го ползвам за бекъп ,но уви превключването се случва ръчно...
Двата линка от страната на града са на различни точки , но в една мрежа.
Идеята е дали може да се направи да се превключва автоматично и знае ли някой как става евентуално . 
Поздрави!

 

Link to comment
Share on other sites

  • 0
  • Administrator

Става със scheduler задачка която проверява има няма и подменя TTL 

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0
На 1.06.2021 г. at 10:31, nikymix_pz написа:

За да не отварям друга тема ,да подпитам и аз нещо :)
Имам два линка единия го ползвам като основен другия ако се срине нещо го ползвам за бекъп ,но уви превключването се случва ръчно...
Двата линка от страната на града са на различни точки , но в една мрежа.
Идеята е дали може да се направи да се превключва автоматично и знае ли някой как става евентуално . 
Поздрави!

 

При мене това работи:

/ip route
add gateway=gateway1ip distance=1 comment=WAN1
add gateway=gateway2ip distance=2 comment=WAN2
add dst-address=8.8.8.8/32 gateway=gateway1ip

/tool netwatch
add down-script="/ip route set [find where comment=\"WAN1\"] distance=3;\r\
    \n:log warning \"WAN1 down, switching to WAN2\"" host=8.8.8.8 up-script="/ip\
    \_route set [find where comment=\"WAN1\"] distance=1;\r\
    \n:log warning \"WAN1 restored\""

 

  • Thanks 1
Link to comment
Share on other sites

  • 0

Бях забравил че съм отворил такава тема тук и се извинявам че не съм отговорил. Тъй като единия доставчик предостави много добри скорости 300-400 Mbps, балансинга стана излишен и за да си спестя излишни главоболия оставих само failover, като за него използвам само четири реда конфигурация без скриптове.

 

/ip route
add check-gateway=ping comment="ISP1 DEFAULT" distance=1 gateway=8.8.4.4
add check-gateway=ping comment="ISP2 ALTERNATIVE" distance=2 gateway=8.8.8.8
add comment="GOOGLE ISP1" distance=1 dst-address=8.8.4.4/32 gateway=X.X.X.X scope=10
add comment="GOOGLE ISP2" distance=2 dst-address=8.8.8.8/32 gateway=X.X.X.X scope=10

 

 

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.