Jump to content
  • 0

DHCP Client се активира при старт


Philip Petev
 Share

Question

Здравейте!

Имам следния проблем: при рестарт се появява нов активен ред в /IP DHCP-Client, като обаче връзката ми с доставчика е по PPPoE. След като се появи този ред, интернета ми започва да се влачи, като на повечето сайтове се чупят я картинки, я нещо друго и се зареждат с векове. Когато спра или изтрия реда, който стартира DHCP Client на ether1, след рестарта този ред автоматично се появява, сякаш нещо го създава. Може ли някой да обясни какво се случва?

Благодаря предварително!

Link to comment
Share on other sites

Recommended Posts

  • 0
преди 37 минути, Philip Petev написа:

Здравейте!

Имам следния проблем: при рестарт се появява нов активен ред в /IP DHCP-Client, като обаче връзката ми с доставчика е по PPPoE. След като се появи този ред, интернета ми започва да се влачи, като на повечето сайтове се чупят я картинки, я нещо друго и се зареждат с векове. Когато спра или изтрия реда, който стартира DHCP Client на ether1, след рестарта този ред автоматично се появява, сякаш нещо го създава. Може ли някой да обясни какво се случва?

Благодаря предварително!

Случайно да се ползва TR069 ?

Link to comment
Share on other sites

  • 0

Това не знам какво е.
Поразрових се из нета и се оказа, че това се е появило от някоя версия нa RouterOS. DHCP-client създава и активира ред за master интерфейсите, ако няма назначен адрес на него. Така че, отидох в IP/Addresses и назначи статичен адрес на ether1 и така редовете спряха да се появяват, но това е само workaround.

Sent from my POCOPHONE F1 using Tapatalk

Link to comment
Share on other sites

  • 0

Ако говориш за RESET, а не за REBOOT на рутера, то това е нормално да ти се появи DHCP client на ether1 ! Все пак това е част от настройките на дефоултният скрипт - 

script: #| CPE RouterMode:
                    #|  * wireless interface connected to providers network (WAN port);
                    #|  * WAN port is protected by firewall and enabled DHCP client
                    #| LAN Configuration:
                    #|     IP address 192.168.88.1/24 is set on bridge (LAN port)
                    #|     DHCP Server: enabled;
                    #|     DNS: enabled;
                    #| WAN (gateway) Configuration:
                    #|     gateway:  lte1 ;
                    #|     ip4 firewall:  enabled;
                    #|     NAT:   enabled;
                    
                    :log info Starting_defconf_script_;
                    #-------------------------------------------------------------------------------
                    # Apply configuration.
                    # these commands are executed after installation or configuration reset
                    #-------------------------------------------------------------------------------
                    :if ($action = "apply") do={
                    # wait for interfaces
                    :local count 0; 
                    :while ([/interface ethernet find] = "") do={ 
                    :if ($count = 30) do={
                    :log warning "DefConf: Unable to find ethernet interfaces";
                    /quit;
                    }
                    :delay 1s; :set count ($count +1); 
                    };
                    
                      :local count 0;
                      :while ([/interface lte find] = "") do={ 
                        :set count ($count +1);
                        :if ($count = 40) do={
                          :log warning "DefConf: Unable to find LTE interface(s)"; 
                          /ip address add address=192.168.88.1/24 interface=ether1 comment="defconf";
                          /quit
                        }
                        :delay 1s;
                      };
                     /interface list add name=WAN comment="defconf"
                     /interface list add name=LAN comment="defconf"
                     /interface bridge
                       add name=bridge disabled=no auto-mac=yes protocol-mode=rstp comment=defconf;
                     :local bMACIsSet 0;
                     :foreach k in=[/interface find where !(slave=yes  || name~"lte1" || name~"bridge")] do={
                       :local tmpPortName [/interface get $k name];
                       :log info "port: $tmpPortName"
                       :if ($bMACIsSet = 0) do={
                         :if ([/interface get $k type] = "ether") do={
                           /interface bridge set "bridge" auto-mac=no admin-mac=[/interface ethernet get $tmpPortName mac-address];
                           :set bMACIsSet 1;
                         }
                       }
                       /interface bridge port
                         add bridge=bridge interface=$tmpPortName comment=defconf;
                     }
                       /ip pool add name="default-dhcp" ranges=192.168.88.10-192.168.88.254;
                       /ip dhcp-server
                         add name=defconf address-pool="default-dhcp" interface=bridge lease-time=10m disabled=no;
                       /ip dhcp-server network
                         add address=192.168.88.0/24 gateway=192.168.88.1 comment="defconf";
                      /ip address add address=192.168.88.1/24 interface=bridge comment="defconf";
                     /ip dns {
                         set allow-remote-requests=yes
                         static add name=router.lan address=192.168.88.1
                     }
                    
                     /interface list member add list=LAN interface=bridge comment="defconf"
                     /interface list member add list=WAN interface=lte1 comment="defconf"
                     /ip firewall nat add chain=srcnat out-interface-list=WAN ipsec-policy=out,none action=masquerade comment="defconf: masquerade"
                     /ip firewall {
                       filter add chain=input action=accept connection-state=established,related,untracked comment="defconf: accept established,related,untracked"
                       filter add chain=input action=drop connection-state=invalid comment="defconf: drop invalid"
                       filter add chain=input action=accept protocol=icmp comment="defconf: accept ICMP"
                       filter add chain=input action=drop in-interface-list=!LAN comment="defconf: drop all not coming from LAN"
                       filter add chain=forward action=accept ipsec-policy=in,ipsec comment="defconf: accept in ipsec policy"
                       filter add chain=forward action=accept ipsec-policy=out,ipsec comment="defconf: accept out ipsec policy"
                       filter add chain=forward action=fasttrack-connection connection-state=established,related comment="defconf: fasttrack"
                       filter add chain=forward action=accept connection-state=established,related,untracked comment="defconf: accept established,related, untracked"
                       filter add chain=forward action=drop connection-state=invalid comment="defconf: drop invalid"
                       filter add chain=forward action=drop connection-state=new connection-nat-state=!dstnat in-interface-list=WAN comment="defconf:  drop all from WAN not DSTNATed"
                     }
                       /ip neighbor discovery-settings set discover-interface-list=LAN
                       /tool mac-server set allowed-interface-list=LAN
                       /tool mac-server mac-winbox set allowed-interface-list=LAN
                    }
                    #-------------------------------------------------------------------------------
                    # Revert configuration.
                    # these commands are executed if user requests to remove default configuration
                    #-------------------------------------------------------------------------------
                    :if ($action = "revert") do={
                    /user set admin password=""
                     /system routerboard mode-button set enabled=no
                     /system routerboard mode-button set on-event=""
                     /system script remove [find comment~"defconf"]
                     /ip firewall filter remove [find comment~"defconf"]
                     /ip firewall nat remove [find comment~"defconf"]
                     /interface list member remove [find comment~"defconf"]
                     /interface detect-internet set detect-interface-list=none
                     /interface detect-internet set lan-interface-list=none
                     /interface detect-internet set wan-interface-list=none
                     /interface detect-internet set internet-interface-list=none
                     /interface list remove [find comment~"defconf"]
                     /tool mac-server set allowed-interface-list=all
                     /tool mac-server mac-winbox set allowed-interface-list=all
                     /ip neighbor discovery-settings set discover-interface-list=!dynamic
                       :local o [/ip dhcp-server network find comment="defconf"]
                       :if ([:len $o] != 0) do={ /ip dhcp-server network remove $o }
                       :local o [/ip dhcp-server find name="defconf" !disabled]
                       :if ([:len $o] != 0) do={ /ip dhcp-server remove $o }
                       /ip pool {
                         :local o [find name="default-dhcp" ranges=192.168.88.10-192.168.88.254]
                         :if ([:len $o] != 0) do={ remove $o }
                       }
                       :local o [/ip dhcp-client find comment="defconf"]
                       :if ([:len $o] != 0) do={ /ip dhcp-client remove $o }
                     /ip dns {
                       set allow-remote-requests=no
                       :local o [static find name=router.lan address=192.168.88.1]
                       :if ([:len $o] != 0) do={ static remove $o }
                     }
                     /ip address {
                       :local o [find comment="defconf"]
                       :if ([:len $o] != 0) do={ remove $o }
                     }
                     :foreach iface in=[/interface ethernet find] do={
                       /interface ethernet set $iface name=[get $iface default-name]
                     }
                     /interface bridge port remove [find comment="defconf"]
                     /interface bridge remove [find comment="defconf"]
                    }
                    :log info Defconf_script_finished;

 

Link to comment
Share on other sites

  • 0

Не, за Reboot иде реч. Махаш реда и след Reboot се появява пак. Нещо повече: даваш Disable на реда и след Reboot се появява втора инстанция на този ред, активна при това.

Ако направиш това упражнение няколко пъти, ще имаш толкова изключени интерфейси и един активен, който ще се появява на всеки рестарт.

Edited by Philip Petev
Link to comment
Share on other sites

  • 0

Ако споделиш малко повече ще можем и да се ориентираме, като един EXPORT пример !

Рутера твой ли е или на ISP ?

Edited by JohnTRIVOLTA
Link to comment
Share on other sites

  • 0

Рутера е hAP AC2 и е мой.

Какво точно искаш да ти експортирам?

Link to comment
Share on other sites

  • 0
преди 4 минути, Philip Petev написа:

Рутера е hAP AC2 и е мой.

Какво точно искаш да ти експортирам?

Конфигурацията -

/export hide-sensitive file=PhilipConfig

и постваш тук да я разгледаме. Разбира се ако има още нещо конфиденциално може да го заместиш с Х-ове .

Link to comment
Share on other sites

  • 0

Ето:

Цитат

/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether1 ] mac-address=4C:5E:0C:53:6A:4A speed=100Mbps
set [ find default-name=ether2 ] speed=100Mbps
set [ find default-name=ether3 ] speed=100Mbps
set [ find default-name=ether4 ] speed=100Mbps
set [ find default-name=ether5 ] speed=100Mbps
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 \
    service-name=escom-pppoe use-peer-dns=yes user=philippetev
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=3 band=2ghz-g/n channel-width=\
    20/40mhz-eC country=bulgaria disabled=no frequency=2462 frequency-mode=\
    regulatory-domain mode=ap-bridge ssid="Philip Petev"
set [ find default-name=wlan2 ] antenna-gain=3 band=5ghz-a/n/ac \
    channel-width=20/40/80mhz-eeeC country=bulgaria disabled=no frequency=\
    5240 frequency-mode=regulatory-domain mode=ap-bridge ssid="Philip Petev"
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk eap-methods="" mode=\
    dynamic-keys supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.0.11-192.168.0.30
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge1 name=dhcp1
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface detect-internet
set detect-interface-list=all
/interface list member
add interface=pppoe-out1 list=WAN
add interface=bridge1 list=LAN
/ip address
add address=192.168.0.1/24 interface=ether2 network=192.168.0.0
add address=192.168.0.111 interface=ether1 network=192.168.0.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-server lease
add address=192.168.0.3 client-id=1:90:2b:34:5e:2a:e1 mac-address=\
    90:2B:34:5E:2A:E1 server=dhcp1
add address=192.168.0.7 client-id=1:78:2:f8:20:97:c7 mac-address=\
    78:02:F8:20:97:C7 server=dhcp1
add address=192.168.0.5 client-id=1:28:c2:dd:8f:90:e9 mac-address=\
    28:C2:DD:8F:90:E9 server=dhcp1
add address=192.168.0.6 client-id=1:18:4f:32:f4:d:6f mac-address=\
    18:4F:32:F4:0D:6F server=dhcp1
add address=192.168.0.8 client-id=1:b4:e1:c4:15:aa:f8 mac-address=\
    B4:E1:C4:15:AA:F8 server=dhcp1
add address=192.168.0.4 client-id=1:90:2b:34:5e:2a:e3 mac-address=\
    90:2B:34:5E:2A:E3 server=dhcp1
/ip dhcp-server network
add address=192.168.0.0/24 gateway=192.168.0.1 netmask=24
/ip dns
set servers=8.8.8.8,195.24.90.1
/ip dns static
add address=192.168.0.1 disabled=yes name=ruter
/ip firewall address-list
add address=192.168.0.0/24 list=LocalNet
/ip firewall filter
add action=add-src-to-address-list address-list=knock1 address-list-timeout=\
    15s chain=input disabled=yes dst-port=8004 log=yes log-prefix=knock1 \
    protocol=tcp
add action=add-src-to-address-list address-list=knock2 address-list-timeout=\
    15s chain=input disabled=yes dst-port=22222 log=yes log-prefix=knock2 \
    protocol=tcp src-address-list=knock1
add action=add-src-to-address-list address-list=trusted address-list-timeout=\
    20s chain=input disabled=yes dst-port=8441 log=yes log-prefix=trusted \
    protocol=udp src-address-list=knock2
add action=accept chain=input comment="SSH with port knocking" disabled=yes \
    dst-port=1234 in-interface=pppoe-out1 protocol=tcp src-address-list=\
    trusted
add action=drop chain=input comment="Drop Intruders" src-address-list=\
    Intruders
add action=drop chain=forward comment="Drop Invalid Forward" \
    connection-state=invalid in-interface=pppoe-out1
add action=drop chain=input comment="DROP Invalid Input" connection-state=\
    invalid in-interface=pppoe-out1
add action=drop chain=input comment="Drop UDP DNS remote requests" dst-port=\
    53 protocol=udp src-address-list=!LocalNet
add action=drop chain=input comment="Drop TCP DNS remote requests" dst-port=\
    53 protocol=tcp src-address-list=!LocalNet
add action=drop chain=input comment="Drop SSH" dst-port=1234 protocol=tcp \
    src-address-list=!LocalNet
add action=drop chain=input comment="Drop WinBox" dst-port=8291 protocol=tcp \
    src-address-list=!LocalNet
add action=drop chain=input comment="Drop PING" protocol=icmp \
    src-address-list=!LocalNet
add action=add-src-to-address-list address-list=Intruders \
    address-list-timeout=2w chain=input comment="Port Scanners" protocol=tcp \
    psd=21,3s,3,1
add action=add-src-to-address-list address-list=Intruders \
    address-list-timeout=2w chain=input comment="NMAP FIN Stealth scan" \
    protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg
add action=add-src-to-address-list address-list=Intruders \
    address-list-timeout=2w chain=input comment="SYN/FIN scan" protocol=tcp \
    tcp-flags=fin,syn
add action=add-src-to-address-list address-list=Intruders \
    address-list-timeout=2w chain=input comment="SYN/RST scan" protocol=tcp \
    tcp-flags=syn,rst
add action=add-src-to-address-list address-list=Intruders \
    address-list-timeout=2w chain=input comment="FIN/PSH/URG scan" protocol=\
    tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack
add action=add-src-to-address-list address-list=Intruders \
    address-list-timeout=2w chain=input comment="ALL/ALL scan" protocol=tcp \
    tcp-flags=fin,syn,rst,psh,ack,urg
add action=add-src-to-address-list address-list=Intruders \
    address-list-timeout=2w chain=input comment="NMAP NULL scan" protocol=tcp \
    tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg
add action=accept chain=forward comment=\
    "Allow Established/Related Forward Chain" connection-state=\
    established,related
add action=accept chain=input comment="Allow Established/Related Input Chain" \
    connection-state=established,related
add action=drop chain=input comment="Drop Input" in-interface=pppoe-out1
add action=drop chain=forward comment="Drop Forward" connection-nat-state=\
    !dstnat connection-state=new in-interface=pppoe-out1
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
add action=dst-nat chain=dstnat comment="SSH to NAS" dst-port=222 \
    in-interface=pppoe-out1 protocol=tcp to-addresses=192.168.0.2 to-ports=22
add action=dst-nat chain=dstnat comment="SSH to buildroot" dst-port=2022 \
    in-interface=pppoe-out1 protocol=tcp to-addresses=192.168.0.111 to-ports=\
    22
add action=dst-nat chain=dstnat comment="NAS BitTorrent" dst-port=44551 \
    in-interface=pppoe-out1 protocol=tcp to-addresses=192.168.0.2 to-ports=\
    44551
add action=dst-nat chain=dstnat comment="PC BitTorrent" dst-port=44552 \
    in-interface=pppoe-out1 protocol=tcp to-addresses=192.168.0.3 to-ports=\
    44552
add action=dst-nat chain=dstnat comment="430 G3 BitTorrent" dst-port=44554 \
    in-interface=pppoe-out1 protocol=tcp to-addresses=192.168.0.6 to-ports=\
    44554
add action=dst-nat chain=dstnat comment=vlmcsd dst-port=1688 in-interface=\
    pppoe-out1 protocol=tcp to-addresses=192.168.0.2 to-ports=1688
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www address=192.168.0.0/24
set ssh port=1234
set api address=192.168.0.0/24
set api-ssl address=192.168.0.0/24
/ip ssh
set forwarding-enabled=both strong-crypto=yes
/ip upnp interfaces
add interface=bridge1 type=internal
add interface=pppoe-out1 type=external
/system clock
set time-zone-name=Europe/Sofia
/system scheduler
add disabled=yes interval=10m name="Cloud Update" on-event=CloudUpdate \
    policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive \
    start-time=startup
add comment="Enable WIFI" interval=1d name=schedule_enable_wifi on-event=\
    "interface wireless set [ find default-name=wlan1 ] disabled=no" policy=\
    read,write,policy,test start-date=feb/12/2019 start-time=08:00:00
add comment="Disable WIFI" interval=1d name=schedule_disable_wifi on-event=\
    "interface wireless set [ find default-name=wlan1 ] disabled=yes" policy=\
    read,write,policy,test start-date=feb/12/2019 start-time=00:00:00
add comment="Enable WIFI 5G" interval=1d name=schedule_enable_wifi_5g \
    on-event="interface wireless set [ find default-name=wlan2 ] disabled=no" \
    policy=read,write,policy,test start-date=feb/13/2019 start-time=08:00:00
add comment="Disable WIFI 5G" interval=1d name=schedule_disable_wifi_5g \
    on-event=\
    "interface wireless set [ find default-name=wlan2 ] disabled=yes" policy=\
    read,write,policy,test start-date=feb/13/2019 start-time=00:00:00
/system script
add dont-require-permissions=no name=CloudUpdate owner=admin policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive source=":local \
    previousIP [:resolve \"a97409bbe9a3.sn.mynetname.net\"]\r\
    \n:local currentIP [/ip address get [find interface=\"pppoe-out1\" disable\
    d=no] address]\r\
    \n\r\
    \n:for i from=([:len \$currentIP] - 1) to=0 do={\r\
    \n   :if ([:pick \$currentIP \$i] = \"/\") do={\r\
    \n      :set currentIP [:pick \$currentIP 0 \$i]\r\
    \n   }\r\
    \n}\r\
    \n\r\
    \n:if (\$currentIP != \$previousIP) do={\r\
    \n   :log info \"CloudUpdate: Host a97409bbe9a3.sn.mynetname.net: old IP: \
    \$previousIP, current IP: \$currentIP, force-updating...\"\r\
    \n   /ip cloud force-update\r\
    \n   :delay 20\r\
    \n   :local newIP [:resolve \"a97409bbe9a3.sn.mynetname.net\"]\r\
    \n   :log info \"CloudUpdate: current IP: \$newIP.\"\r\
    \n} else={\r\
    \n     :log info \"CloudUpdate: Previous IP \$previousIP is equal to curre\
    nt IP (\$currentIP), no update needed\"\r\
    \n}"
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
/tool romon port
add disabled=no forbid=yes interface=wlan1
add disabled=no forbid=yes interface=wlan2

 

Link to comment
Share on other sites

  • 0

/ip address
add address=192.168.0.1/24 interface=ether2 network=192.168.0.0  - смени интерфейса с bridge1
add address=192.168.0.111 interface=ether1 network=192.168.0.0 - за къв чеп си сложил адреса ? Разкарай го ! респективно и нат правилото също:

add action=dst-nat chain=dstnat comment="SSH to buildroot" dst-port=2022 in-interface=pppoe-out1 protocol=tcp to-addresses=192.168.0.111 to-ports=22

  • Like 1
Link to comment
Share on other sites

  • 0

Този ред предотвратява автоматичното създаване на реда за DHCP Client на ether1. Ако го няма, след reboot на рутера този ред се появява автоматично и активиран.

 Както казах, това е само workaround.

Link to comment
Share on other sites

  • 0
преди 6 минути, Philip Petev написа:

Този ред предотвратява автоматичното създаване на реда за DHCP Client на ether1. Ако го няма, след reboot на рутера този ред се появява автоматично и активиран.

 Както казах, това е само workaround.

Искаш да кажеш , че и нат правилото за него адрес само се е появило или ? Спри скрипта за ъпдейтването на адреса - може просто да си добавиш задача да ти ръннва /ip cloud force-update 

Махни и това също - дай му NO

/interface detect-internet
set detect-interface-list=all

След като направиш тези промени вкл. и тези по-горе сподели какво се случва след рибутване !

Link to comment
Share on other sites

  • 0

 

Преди 1 час, JohnTRIVOLTA написа:

Искаш да кажеш , че и нат правилото за него адрес само се е появило или ? Спри скрипта за ъпдейтването на адреса - може просто да си добавиш задача да ти ръннва /ip cloud force-update 

Махни и това също - дай му NO

/interface detect-internet
set detect-interface-list=all

След като направиш тези промени вкл. и тези по-горе сподели какво се случва след рибутване !

NAT правилото за SSH to buildroot е към 192.168.0.111 от вътрешната, което е една виртуалка с Linux. Това правило съм го правил аз, не се е появило само. Сега пипнах адреса, който да дава на ether1 и го направих да е 200. Това е обаче за външната мрежа, тъй като на ether1 е вързан кабела от ISP.

Скрипта е спрян в Scheduler-а, не се изпълнява. Беше workaround за по-стара версия на RouterOS и сега не се изпълнява вече.

Когато detect-interface-list е all, след рестарт се появява реда в DHCP Client. Когато е на none, реда изчезва и след рестарт не се появява повече.

Edited by Philip Petev
Link to comment
Share on other sites

  • 0

Добре, изясниха се нещата с едно последно - каква е нуждата от - " Сега пипнах адреса, който да дава на ether1 и го направих да е 200. Това е обаче за външната мрежа, тъй като на ether1 е вързан кабела от ISP." ? 

Link to comment
Share on other sites

  • 0

Нуждата е да има фейк адрес. Когато има зададен статичен адрес на този интерфейс, ред в DHCP Client не се създава, независимо от това каква е стойността на detect-interface-list.

Това е единия workaround, другия е да направиш detect-interface-list на none.

Edited by Philip Petev
Link to comment
Share on other sites

  • 0
  • Administrator

Нарушил си йерархията на интерфейсите.
Бриджа е висшестоящ и всички подчинени му не би трябвало да имат зададени адреси.

Дори при стартиране в лога трябва да ти го изписва.

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.