Jump to content

Recommended Posts

bojko91

Здравейте,

Имам микротак RB951G-2HnD (6.43rc56). Опитвам се да свържа android smart tv box (x96) към него, но без успех. Забелязвам че в DHCP leases се опитва да си вземе адрес от DHCP, но седи само на offering и нищо. Пробвах и с набит адрес в бокса, но няма промяна. След като сложа обаче обикновен монтански суия (neomontana 100mb порт) след микротика бокса тръгва без проблем image.png.35469e3e791d5b96ea7d050bac47486f.png  

Всички портове са във бридж

Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU    
 0  RS LAN-2                               ether            1500  1598       4074 
 1   S LAN-3                               ether            1500  1598       4074 
 2   S LAN-4                               ether            1500  1598       4074 
 3   S LAN-5                               ether            1500  1598       4074 
 4  R  WAN                                 ether            1500  1598       4074 
 5  RS Wireless                            wlan             1500  1600       2290 
 6  R  PPPoE                               pppoe-out        1480
 7  R  bridge1                             bridge           1500  1598           
 8  X  ;;; Vivacom USB Modem
       ppp-out2                            ppp-out   
--------------------------

 R name="bridge1" mtu=1500 actual-mtu=1500 l2mtu=1598 arp=enabled arp-timeout=auto mac-address=D4:CA:6D:7C:D1:28 protocol-mode=rstp fast-forward=no igmp-snooping=no auto-mac=no admin-mac=D4:CA:6D:7C:D1:28 ageing-time=5m priority=0x8000 
     max-message-age=20s forward-delay=15s transmit-hold-count=6 vlan-filtering=no dhcp-snooping=no 
 

Пробвах няколко неща на порта, на който е закачен бокса.
1. Флоу контрол (ауто, без, вкл.)
2. Сетване на порта ръчно на 100мб.

3. Махане и връщане на отметката Hardware offload.

4. и безброй други глупости..... (RSTP-то на порта, на бриджа) Връщах и дефаулт конфигурацията на рутера, но отново без успех. 

Някой има ли си на идея, какво трябва да напратя за да подкарам този бокс

 

 

Редактирано от bojko91

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
bojko91
преди 14 минути, master написа:

Съмнявам се да е от там но все пак си направи ъпдейт.

До последна версия е (даже вдигнах RC версия)...  ?

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
gbdesign

Смени пач кабела. За да не работи коректно DHCP обикновенно причината е, че от едната страна мрежовата карта се включва в режим Half Duplex.

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
bojko91
преди 3 минути, gbdesign написа:

Смени пач кабела. За да не работи коректно DHCP обикновенно причината е, че от едната страна мрежовата карта се включва в режим Half Duplex.

3 пача съм сменил (даже пробвах и с кроснат кабел), и 4 бокса смених ?

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
gbdesign

Аз имам същата разстановка в къщи, като само рутера ми е 100 mbps /RB951UI-2HnD/ и не съм имал никакви драми. Е на Х96-та съм и сложил Armbian и я ползвам за уебсървър, но и с оригиналният фирмуер, както и с този на Tanix си работеще без никакви ядове.

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
bojko91
преди 11 минути, gbdesign написа:

Аз имам същата разстановка в къщи, като само рутера ми е 100 mbps /RB951UI-2HnD/ и не съм имал никакви драми. Е на Х96-та съм и сложил Armbian и я ползвам за уебсървър, но и с оригиналният фирмуер, както и с този на Tanix си работеще без никакви ядове.

Мойта е нагласена за IPTV и други глупости. Съмнява ме че е някоя стойност като цяло в конфигурацията на бриджа или порта, но не мога да намеря кое точно се чупи... А относно халф дуплекса, в лога излиза, че пали на 100, но това май е че пали на 100 от страна на рутера не на бокса.

Редактирано от bojko91

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
Щирлиц

Колега, ъпдейтни до 6.42.7 - мисля, че там са оправяли нещо по въпроса. Имал съм подобни проблеми от калпави RJ-та и калпави кабели ....

Редактирано от Щирлиц

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
hgd
Преди 1 час, bojko91 написа:

Пробвах и с набит адрес в бокса, но няма промяна. След като сложа обаче обикновен монтански суия (neomontana 100mb порт) след микротика бокса тръгва без проблем

 

 

Проблемът ти е или кабела (не може да работи на 1 гигабит) и/или Autonegotiation.

Ако боксът ти е с 100 мегабитов LAN, в микротика твърдо фиксирай скоростта на порта на 100 мегабита и изключи Autonegotiation.

Ако боксът ти е с 1 гигабит LAN (съмнявам се да е), смени кабела между него и микротика.

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
bojko91
преди 14 минути, hgd написа:

Проблемът ти е или кабела (не може да работи на 1 гигабит) и/или Autonegotiation.

Ако боксът ти е с 100 мегабитов LAN, в микротика твърдо фиксирай скоростта на порта на 100 мегабита и изключи Autonegotiation.

Ако боксът ти е с 1 гигабит LAN (съмнявам се да е), смени кабела между него и микротика.

Това беше 1вото което направих. И в лога се вижда, че пали на 100. Не мога да си обясня обаче защо се получава така. Махнато е неготейшъна, сложен е на 100 фул и не пали през микротика, обаче с междинен суич е ок. Преди съм пробвал да давам ресет на един buffalo рутер и помня, че слагах суич защото имаше някаква хватка с ТТЛ , да не би и тук това да е проблема?

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
hgd

Т.е. нагласил си го както е на снимката и не тръгва?

Моля, влезте или се регистрирайте, за да видите този attachment.

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
bojko91
Just now, hgd написа:

Т.е. нагласил си го както е на снимката и не тръгва?

Моля, влезте или се регистрирайте, за да видите този attachment.

абсолютно

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
hgd

Отчита ли се трафик в 2-те посоки на порта? Най-лесно ще разбереш, ако сложиш статично IP на бокса и го пингваш от някой компютър на друг порт (в същия бридж, влан и т.н.)

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
Inkas

Божко, проблема ти е китайския дивайс. И аз много си играх и на края сложих междинен суич. Ако го вържеш към Микротик със 100Мбит/с порт (примерно hAP), няма да имаш грижа. Проблема e, че STB нещо не си говори както трябва с Микротика. Няма смисъл да търсите под вола теле. Да, дори и ръчно да се сетне порта на 100Mbit/s, не си получава устройството адрес.

Редактирано от Inkas

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
bojko91
преди 3 минути, Inkas написа:

Божко, проблема ти е китайския дивайс. И аз много си играх и на края сложих междинен суич. Ако го вържеш към Микротик със 100Мбит/с порт (примерно hAP), няма да имаш грижа. Проблема e, че STB нещо не си говори както трябва с Микротика. Няма смисъл да търсите под вола теле. Да, дори и ръчно да се сетне порта на 100Mbit/s, не си получава устройството адрес.

Вчера с Тео цял ден го гърбихме и няма. Със старата IPTV няма грам проблем, лети...

Сподели публикацията


Адрес на коментара
Сподели в други сайтове
Inkas
Преди 2 часа, bojko91 написа:

Вчера с Тео цял ден го гърбихме и няма. Със старата IPTV няма грам проблем, лети...

Казах ти какъв е проблема. Не знам защо го търсиш в Микротика.

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Гост
Отговорете в темата...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Потребители разглеждащи страницата   0 потребители

    No registered users viewing this page.

×
×
  • Създай нов...

Important Information

By using this site, you agree to our Terms of Use.