Jump to content
  • 0

Микторик с 2 доставчика


Pavlov
 Share

Question

Искам да сложа 2 доставчика на микротик 2.9.6 - БТК и лан доставчик. Имам вътрешна мрежа изградена и досега микротика работи само с лан доставчика.  Искам да сложа и втори доставчик, за да имам възможност ако единия увисни другия да поеме трафика. БТК е с по голяма скорост. Искам да направя така, че трафика основно да минава през БТК, а ако модема забие или ако нещо се случи трафика да минава през лан доставчика.

Ако някои има идеи. Четох за load balance но не съм сигурен дали е точно това което искам аз да направя и не ми стана много ясно. Извинявам се предварително ако във форума има подобна тема.

Благодаря на всички, които ще споделят идеи и щеми помогнат

Link to comment
Share on other sites

Recommended Posts

  • 0

А имам и още 1 въпрос. Има ли значение че на 1 мрежа е ххх.ххх.ххх.ххх/24 а другата е ххх.ххх.ххх.ххх/25

Има ли някакъв проблем или и 2те мрежи трябва да са с /24

различават им се маските

Link to comment
Share on other sites

  • 0
  • Administrator

ако ще и /29 и /30 на WAN вътре в лана не ти дреме ;)

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

да беше поразровил тук там....не се получава с тези адсл-и...постоянно забиват,ако искаш да ставаш доставчик купувай сериозен нет

Link to comment
Share on other sites

  • 0
  • Administrator

Защо някои хора си мислят че МТ е само за доставчици?

Неможе ли да се ползва вкъщи и в офиса ?

Понякога "сериозните доставчици" ги няма там кадето трябва.

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Няма да бъда доставчик. Просто в офиса искам да подсигуря 100 % интернет затова ще използвам 2 доставчика. Въпроса е че малко трудно сигурно ще се справя с тоя микротик. Изпълних всичко то wiki  обаче ми увисва нета. Четох и други статии, но уви резултата е пак същия.

Link to comment
Share on other sites

  • 0

check gateway пробвай да сложиш. Всъщност като имаш някакво питане обикновено се излага с print какво си направил досега. Как работи в момента и въобще опитай да ни ориентираш какво си направил до момента. Дори да има желание някой да помогне му е нужно инфо. Докато пишеш общи отговори от сорта "опитах всичко и неще" ще получаваш и подобни съвети.

Link to comment
Share on other sites

  • 0

Здравейте,

с бтк adsl ще ти е трудно да използваш check gateway.

освен ако модема ти не е в bridge, и pppoe сесията се стартира от микротика.

в противен случай ще имаш ефект от 'бекъпа' само ако модема ти забие, което не е много ефективно.

а с инструкцийте в wiki-то не би трябвало да ти увисва нета.

покажи до къде си стигнал наистина.

Link to comment
Share on other sites

  • 0

Ето каква е ситуацията до тук:

/ ip address

add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local

add address=192.168.1.2/25 network=192.168.1.0 broadcast=192.168.1.127 interface=wlan2

add address=93.123.14.97/24 network=93.123.14.0 broadcast=93.123.14.255 interface=wlan1

След това

/ ip firewall mangle

add chain=prerouting src-address-list=odd in-interface=Local action=mark-connection new-connection-mark=odd passthrough=yes

add chain=prerouting src-address-list=odd in-interface=Local action=mark-routing new-routing-mark=odd

add chain=prerouting src-address-list=even in-interface=Local action=mark-connection new-connection-mark=even passthrough=yes

add chain=prerouting src-address-list=even in-interface=Local action=mark-routing new-routing-mark=even

add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes

add chain=prerouting in-interface=Local action=add-src-to-address-list address-list=odd address-list-timeout=1d connection-mark=odd passthrough=yes

add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no

add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes

add chain=prerouting in-interface=Local action=add-src-to-address-list address-list=even address-list-timeout=1d connection-mark=even passthrough=yes

add chain=prerouting in-interface=Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no

add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 src-address-list=!odd action=mark-connection new-connection-mark=even passthrough=yes

NAT

add chain=srcnat connection-mark=odd action=src-nat to-addresses=93.123.14.97 to-ports=0-65535

add chain=srcnat connection-mark=even action=src-nat to-addresses=192.168.1.2 to-ports=0-65535

Routing

add dst-address=0.0.0.0/0 gateway=93.123.14.1 scope=255 target-scope=10 routing-mark=odd

add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 routing-mark=even

add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10

Това е всичко, което съм направил до тук. Адресът 93.123.14.97 е реален, но след тези настройки се губи пинг-а към него и нямам достъп до сървъра. Това което искам да направя е да ползвам скоростта на АДСЛ а да имам достръп до сървъра през реалното ip на другия доставчик. Също при забиване на модема на БТК трафика да се поема от лан доставчика. Погледнете дотук какво съм направил и ми кажете дали съм допуснал някъде грешка.

Има и още нещо. След тези настройки нямам пинг към 192.168.1.1 имам пинг само към 93.123.14.1

Link to comment
Share on other sites

  • 0
  • Administrator

това да гаси единия при липса става чрез скрипт

в /tools netwatch

като си пишеш какво да става

като го има и като го няма някой от гейтовете

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

пробвай така:

/ip firewall nat

add action=masquerade chain=srcnat comment="ISP1" disabled=no out-interface=ether1

add action=masquerade chain=srcnat comment="ISP2" disabled=no out-interface=ether2


/ip firewall mangle

add action=mark-connection chain=prerouting comment="To ISP1" disabled=no in-interface=clients new-connection-mark=isp1 passthrough=yes src-address-list=isp1_users

add action=mark-routing chain=prerouting comment="" disabled=no in-interface=clients new-routing-mark=isp1 passthrough=no src-address-list=isp1_users

add action=mark-connection chain=prerouting comment="To ISP2" disabled=no in-interface=clients new-connection-mark=isp2 passthrough=yes src-address-list=isp2_users

add action=mark-routing chain=prerouting comment="" disabled=no in-interface=clients new-routing-mark=isp2 passthrough=no src-address-list=isp2_users


/ip route

add check-gateway=ping comment="main Gateway" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=93.123.14.1 scope=30 target-scope=10

add check-gateway=ping comment="backup Gateway" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=212.39.87.240 scope=30 target-scope=10

add check-gateway=ping comment="isp1 Gateway" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=93.123.14.1 routing-mark=isp1 scope=30 target-scope=10

add check-gateway=ping comment="isp2 Gateway" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=212.39.87.240 routing-mark=isp2 scope=30 target-scope=10

add check-gateway=ping comment="backup isp1 Gateway" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=212.39.87.240 routing-mark=isp1 scope=30 target-scope=10

add check-gateway=ping comment="backup isp2 Gateway" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=93.123.14.1 routing-mark=isp2 scope=30 target-scope=10

добави в адрес листа isp1_users и isp2_users кои потребители искаш да ползват единия, и кои другия доставчик.

ако не добавиш нищо в адрес листа, isp1 ти е стандартен, като ако отпадне - минава на isp2.

ако направиш първи доставчик да ти е бтк, бекъпа ще сработва само ако модема ти забие и не отдоваря на ping.

махни опцията add default route на dhcp клиентите на двата доставчика.

Link to comment
Share on other sites

  • 0

Пробвал съм го работи без отказно.

Идинствение недостатък че трябва да маскираш трафика на изходящите интерфейси.

т.е. не проложим при Реални IP-ta

Link to comment
Share on other sites

  • 0

Горе написаното от стартер работи добре , но самоче забелязвам в някой моменти Down-a на клиентите минава през единия доставчик само , а UP-a през другия и това се оправя с рест на рутера.

Та въпроса ми е защо се получава така с тази конфигурация или има нещо в самата версия на МТ-ка 2.9.27.

Link to comment
Share on other sites

  • 0

Горе написаното от стартер работи добре , но самоче забелязвам в някой моменти Down-a на клиентите минава през единия доставчик само , а UP-a през другия и това се оправя с рест на рутера.

Та въпроса ми е защо се получава така с тази конфигурация или има нещо в самата версия на МТ-ка 2.9.27.

това не съм го забелязал при моя MT (последна версия).

ще обърна внимание, но мисля, че си е добре.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.