Jump to content
  • 0

Рутер RouterBOARD 951G-2HnD и voip рутер spa3102


pro
 Share

Question

Здравейте на всички форумници.

Смених рутера с  RouterBOARD 951G-2HnD за да рутира 1gb.

намерих този форум които е свързан с марката на рутера.

запитвам знаещите от този форум.

След смяната spa3102 не иска да получава изходящи обаждания прави само изходящи.

направил съм порт пренасочванията към портовете които знам, че ползва сип акаунта но не се получава. 

 

Link to comment
Share on other sites

Recommended Posts

  • 1

1.Ъпдейтваш рутер до последната стейбъл версия "6.41.2" и фърмуера!

2.Рисетваш без да зарежда деф. конфиг и без бекъп

3.Пастваш в терминала тази конфигурация:

/interface bridge
add auto-mac=yes name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
    disabled=no distance=indoors mode=ap-bridge radio-name="" ssid=MikroTik \
    wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MyRouter
/ip pool
add name=default-dhcp ranges=192.168.0.100-192.168.0.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge lease-time=1d10m \
    name=LanDHCP
/interface bridge port
add bridge=bridge interface=ether2
add bridge=bridge interface=ether3
add bridge=bridge interface=ether4
add bridge=bridge interface=ether5
add bridge=bridge interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/ip settings
set rp-filter=strict tcp-syncookies=yes
/interface list member
add interface=bridge list=LAN
add interface=ether1 list=WAN
/ip address
add address=192.168.0.1/24 interface=bridge network=192.168.0.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1 use-peer-dns=\
    no
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,4.2.2.1
/ip dns static
add address=192.168.0.1 name=myrouter.lan
/ip firewall filter
add action=accept chain=input comment="accept established,related,untracked" \
    connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=drop chain=input comment="drop invalid" connection-state=invalid
add action=accept chain=input comment="allow winbox,http from LAN" dst-port=\
    80,8291 in-interface=bridge protocol=tcp
add action=accept chain=input comment="Allow TCP ports...." dst-port=\
    5060,5061,1000,7078,8000,8001,8080,10000 protocol=tcp
add action=accept chain=input comment="Allow UDP ports...." dst-port=\
    5060,5061,1000,7078,8000,8001,8080,10000,16384,16385 protocol=udp
add action=accept chain=input comment="accept ICMP" protocol=icmp
add action=drop chain=input comment="drop all not coming from LAN" \
    in-interface=!bridge
add action=accept chain=forward comment="accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="drop invalid" connection-state=invalid
add action=drop chain=forward comment="drop all from WAN not DSTNATed" \
    connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=dst-nat chain=dstnat dst-port=8000 in-interface=ether1 protocol=\
    tcp to-addresses=192.168.0.93 to-ports=8000
add action=dst-nat chain=dstnat dst-port=8001 in-interface=ether1 protocol=\
    tcp to-addresses=192.168.0.93 to-ports=8001
add action=dst-nat chain=dstnat dst-port=5061 in-interface=ether1 protocol=\
    udp to-addresses=192.168.0.91 to-ports=5061
add action=dst-nat chain=dstnat dst-port=5061 in-interface=ether1 protocol=\
    tcp to-addresses=192.168.0.91 to-ports=5061
add action=dst-nat chain=dstnat dst-port=5060 in-interface=ether1 protocol=\
    tcp to-addresses=192.168.0.91 to-ports=5060
add action=dst-nat chain=dstnat dst-port=1000 in-interface=ether1 protocol=\
    tcp to-addresses=192.168.0.91 to-ports=1000
add action=dst-nat chain=dstnat dst-port=8080 in-interface=ether1 protocol=\
    tcp to-addresses=192.168.0.93 to-ports=8080
add action=dst-nat chain=dstnat dst-port=8291 in-interface=ether1 protocol=\
    tcp to-addresses=192.168.0.99 to-ports=8291
add action=dst-nat chain=dstnat dst-port=5228 in-interface=ether1 port="" \
    protocol=udp to-addresses=192.168.0.91 to-ports=5228
add action=dst-nat chain=dstnat dst-port=7078 in-interface=ether1 protocol=\
    tcp to-addresses=192.168.0.91 to-ports=7078
add action=dst-nat chain=dstnat dst-port=7078 in-interface=ether1 protocol=\
    udp to-addresses=192.168.0.91 to-ports=7078
add action=dst-nat chain=dstnat dst-port=16384 in-interface=ether1 protocol=\
    udp to-addresses=192.168.0.91 to-ports=16384
add action=dst-nat chain=dstnat dst-port=16385 in-interface=ether1 protocol=\
    udp to-addresses=192.168.0.91 to-ports=16385
add action=dst-nat chain=dstnat dst-port=5061 in-interface=ether1 protocol=\
    udp to-addresses=192.168.0.91 to-ports=5061
add action=dst-nat chain=dstnat dst-port=5060 in-interface=ether1 protocol=\
    udp to-addresses=192.168.0.91 to-ports=5060
add action=dst-nat chain=dstnat dst-port=10000 in-interface=ether1 protocol=\
    tcp to-addresses=192.168.0.91 to-ports=10000
add action=dst-nat chain=dstnat dst-port=10000 in-interface=ether1 protocol=\
    udp to-addresses=192.168.0.91 to-ports=10000
/ip firewall raw
add action=drop chain=prerouting comment="deny dns" dst-port=53 in-interface=\
    ether1 protocol=tcp
add action=drop chain=prerouting comment="deny dns" dst-port=53 in-interface=\
    ether1 protocol=udp
/ip firewall service-port
set sip disabled=yes
/ip service
set telnet disabled=yes
set ftp disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system routerboard settings
set silent-boot=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

4.Сложи си парола на рутера ... може и на wlan1 т.е. на безжичната мрежа !

Edited by JohnTRIVOLTA
Link to comment
Share on other sites

  • 0

Много общ е въпроса , никакво инфо за конфига или поне на Firewall частта, но изгледай този клип, да не би там да е разковничето !

Edited by JohnTRIVOLTA
Link to comment
Share on other sites

  • 0

За препращане на портове по nat обаче кои точно това е въпроса.

Като получи рутера заявка за даден порт да знае на кое устройство да е препрати.

Защитната стена на рутера е деактивирана.

voip специалист или човек който се занимава с тези неща може да ме посъветва кои портове освен стандартните за свързване със сървара се ползват.

Стандартните по tcp i udp съм направил препращането. 

 

 

Благодарности за видеото.

разбрах от него, че sip и nat не  се получава. Говори за sip alg което на 7 layer.

Търсих в рутера за alg но не го открих.

Link to comment
Share on other sites

  • 0
Преди 15 часа, pro написа:

Търсих в рутера за alg но не го открих.

Хелпърите са в  ip firewall service-port !

Link to comment
Share on other sites

  • 0

В този мод е пуснат sip  и пак не се свързва.

какво да се направи там.

 

не намерих и пренасочване по rtp протокола.

 

Link to comment
Share on other sites

  • 0

Колега, много е важно да разбереш кое точно не работи.

 

На 2/23/2018 at 14:14, pro написа:

След смяната spa3102 не иска да получава изходящи обаждания прави само изходящи.

да не би да не може да получава входящи обаждания по SIP. Ако е това провери дали работи веднага след като рестарираш и двете у-ва - микротика и spa3102. Ако работи проблема ти е ясен.

SPA3102 е с FXS и FXO портове. Разбери кое на кой порт очакваш и кое точно не работи. Ако чакаш да получиш обаждане на FXO порта и не работи трябва да гледаш в съвсем различна посока.

Link to comment
Share on other sites

  • 0

Точно входящи до spa3102 не се получават.

когато звънне телефонната линия fxo акаунта които е регистриран прави връзка към акаунт към телефон с андроид и се осъществява разговор.

не ми дава да набирам телефонни номера от pstn линията дава ми че няма такъв акаунт а от същият получавам входящите обаждания от pstn линията.

Link to comment
Share on other sites

  • 0
  • Administrator

Хайде да обясниш по читаво без фрази оксиморони  от рода "получава изходящи"

какво си сътворил и кое как е вързано.

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

От воаипито акаунта които е на spa3102 може да се свързва с акаунта на андроид телефон.

Но неможе от андроид телефон аканта да се свърже с акаунта на spa3102. дава му че няма такав акаунт.

Просто акаунта на андроид телефона като набере акаунта на spa3102 изписва, че акаунта е недостъпен.

Под акаунт значи трънк или разбираем български телефонен номер.

Като гледам мойте писания ви са неразбираеми а ако прочете voip литература сигурно ще си помислите че са на китаиски. 

 

Link to comment
Share on other sites

  • 0
  • Administrator

Значи нищо не можеш да обясниш, да ти кажа.

Нито кой къде е свързан нито нищо.

Не седиме в стаята при теб, постарай се повече.

Преди 2 часа, pro написа:

От воаипито акаунта които е на spa3102 може да се свързва с акаунта на андроид телефон.

Но неможе от андроид телефон аканта да се свърже с акаунта на spa3102. дава му че няма такав акаунт.

Просто акаунта на андроид телефона като набере акаунта на spa3102 изписва, че акаунта е недостъпен.

Под акаунт значи трънк или разбираем български телефонен номер.

Като гледам мойте писания ви са неразбираеми а ако прочете voip литература сигурно ще си помислите че са на китаиски. 

 

 

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0
Преди 2 часа, pro написа:

Като гледам мойте писания ви са неразбираеми а ако прочете voip литература сигурно ще си помислите че са на китаиски. 

LOL

казва човека който не може да се оправи и търси помощ.

Колега, твоите писания са или на човек под 18 години или на технически неграмотен човек.

  • Like 1
Link to comment
Share on other sites

  • 0

точно за fxo порта акаунта му се обажда към андроид телефона, но когато от андроид телефона се обади към fxo  не се получава обаждането.

Рестартирах устроиствата не се свързва не прави обаждане.

 

Link to comment
Share on other sites

  • 0

значи говорим за следното нещо

PSTN (1) -> spa3102 FXO (2) -> SIP android client (3)

Сигурен ли си че между 2 и 3 няма някакъв сип сървър ? Някак не мога да си представя как spa3102 се регистрира в android клиента

Link to comment
Share on other sites

  • 0

има сървър за него нямам достъп да му променям настроиките, преди да сложа рутера се свързваше. 

В този форум voip специалисти няма ли, на лично чакам оферта колко ще ми струва, да се настрои spa3102.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.