Jump to content
  • 0

Смяна адрес на management интерфейса


s_kolew
 Share

Question

Здравейте,

средно напреднал съм в областа на Микротик, за нов офис си взехме няколко устройства Mikoritk, като Core рутера е RB962U. След стартирането се опитвам да сменя адреса на management интерфейса, но ако ръчно добавя адрес към bridge-а не мога да отворя management по това IP, съумях да сменя default IP-to 192.168.88.1 с друго от Initial Config-a при логин в устройството, но този тип сетъп не ми е удачен. Искам да имам различни VLAN-и и адреси към тях ( това дори е направено ), но проблема е че всичко работи както трябва, но не мога да отворя management на някое от тези IP-та, а са на мастър ИП-то което задавам при initial config-a. 

Някой сблъсквал ли се е с подобно нещо и как се решава задачката, рових по различни документации, но никъде не се споменава за точно такъв случай. RouterOS v6.40

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0
  • Administrator

Дай един експорт.

Така обясняваш като че ли идваш от дриско академия.

При Mикротик няма такова понятие "management interface"

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0
Преди 1 час, 111111 написа:

Дай един експорт.

Така обясняваш като че ли идваш от дриско академия.

При Mикротик няма такова понятие "management interface"

 

[admin@MikroTik] > export 
# jan/02/1970 00:08:39 by RouterOS 6.40
# software id = PC33-NERL
#
# model = RouterBOARD 962UiGS-5HacT2HnT
# serial number = 6737052E08AF
/interface bridge
add name=br1_lan
add admin-mac=E4:8D:8C:6B:F0:73 auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-6BF079 wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-6BF078 wireless-protocol=802.11
/ip neighbor discovery
set ether1 discover=no
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=sfp1
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge comment=defconf interface=wlan2
add bridge=br1_lan interface=ether4
add bridge=br1_lan interface=ether5
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=10.132.1.1/24 comment=defconf interface=ether2 network=10.132.1.0
add address=10.132.2.1/24 interface=br1_lan network=10.132.2.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=10.132.1.0/24 comment=defconf gateway=10.132.1.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat out-interface=ether1
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=bridge
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=bridge
[admin@MikroTik] > 


 

Супер default-ни настройки (наложи се да го почна отначало), като единственото което е променено е eth4-5 са махнати от default bridge-a и са закачени към br1_lan, а на този bridge има закачен 10.132.2.1 имам ping до адреса, но не мога да отворя webmin там или ssh. Ако същия този адрес го преместя на default бриджа се отварят. 

 

Link to comment
Share on other sites

  • 0
  • Administrator
преди 16 минути, s_kolew написа:

/interface list member

add comment=defconf interface=bridge list=LAN

/ip firewall filter

add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN

Описано точно и ясно

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0
преди 4 минути, 111111 написа:

Описано точно и ясно

Дам, дам, точно го видях :) 

П.С. Не съм "дрисковец" просто firewall-ите с които работя са BSD и до този момент Микротик съм бутал колкото да си направя мрежата у дома :) 

Благодаря за съдействието :)

Link to comment
Share on other sites

  • 0
  • Administrator

Задай някое NTP и оправи DNS-a ;)

може софта и биоса да обновиш.

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Боря се с още един проблем от вчера, опитвам се да настроя CapsMan за централизирано управление на Wireless-a, имам и един wAP, с него няма проблем вързва се с CapsMan-a който работи на RB-то и си се provision-ва, връзвам се към  WiFi-то на с друго устройство и си работи, но когато се опитам локалния Wireless на RB-то да го добавя към CAPsMan-a, не се поява изобщо. Пробвах както WiFi-картата е член на bridge-a така и когато не е, все едно и също, прилагам и експорт:

[admin@MikroTik] > export
# jan/02/1970 01:23:05 by RouterOS 6.40
# software id = PC33-NERL
#
# model = RouterBOARD 962UiGS-5HacT2HnT
# serial number = 6737052E08AF
/caps-man channel
add band=2ghz-b/g/n control-channel-width=20mhz frequency=2412 name=ch1_2.4GhZ
/interface bridge
add admin-mac=E4:8D:8C:6B:F0:73 auto-mac=no name=br1_lan
/interface wireless
# managed by CAPsMAN
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-6BF079 wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-6BF078 wireless-protocol=802.11
/ip neighbor discovery
set ether1 discover=no
/caps-man datapath
add bridge=br1_lan client-to-client-forwarding=yes local-forwarding=yes name=datapath
/caps-man security
add authentication-types=wpa-psk,wpa2-psk encryption=aes-ccm name=security1 passphrase="\$Credit\$"
/caps-man configuration
add channel=ch1_2.4GhZ datapath=datapath mode=ap name=conf1 security=security1 ssid=Credit
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp interface=br1_lan name=defconf
/caps-man manager
set enabled=yes
/caps-man provisioning
add action=create-dynamic-enabled master-configuration=conf1 name-format=prefix name-prefix=ofcWiFi_
/interface bridge port
add bridge=br1_lan interface=ether3
add bridge=br1_lan interface=sfp1
add bridge=br1_lan interface=ether4
add bridge=br1_lan interface=ether5
add bridge=br1_lan interface=ether2
/interface list member
add interface=br1_lan list=LAN
add comment=defconf interface=ether1 list=WAN
/interface wireless cap
# 
set bridge=br1_lan discovery-interfaces=br1_lan enabled=yes interfaces=wlan1
/ip address
add address=10.132.1.1/24 interface=br1_lan network=10.132.1.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=10.132.1.0/24 comment=defconf gateway=10.132.1.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat out-interface=ether1
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=br1_lan
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=br1_lan
[admin@MikroTik] > 


 

Бих бил благодарен за съвет.

Link to comment
Share on other sites

  • 0
Преди 4 часа, s_kolew написа:


/interface wireless cap
#
set bridge=br1_lan discovery-interfaces=br1_lan enabled=yes interfaces=wlan1
 

Бих бил благодарен за съвет.

Мисля тук ти е грешката ! Пробвай с тези настройки, все пак CAP трябва да се обърне към себе си , защото менаджера си е на едно и също устройство с радиата!

/interface wireless cap set interfaces=wlan1,wlan2 caps-man-addresses=127.0.0.1

Edited by JohnTRIVOLTA
Link to comment
Share on other sites

  • 0

Не, все същия резултат, както и ако поставя 10.132.1.1, което е адреса на Bridge, макар че по изчетеното по темата АП-тата ползват L2 и тръгва и без зададен адрес на CAPsMAN-a. Странна работа, ще проверя дали е последна версия и дали има ъпдейт, възможно е да е бъг във версията на ОС-а.

П.П Искам да се уверя, че WiFi интерфейсите не трябва да са членове на Bridge-a предварително.

Edited by s_kolew
Link to comment
Share on other sites

  • 0

Fixed: След ъпгрейд и малко допълнителна конфигурация в CAP интерфейса просто добавих настройки за Discovery Interfaces, CAPsMAN Addresses и Bridge. 

Благодаря за съдействието!

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.