Jump to content
  • 0

Проблем с настройката на RIP протокол


Mateev6012
 Share

Question

Имам проблем с настройката на Prefix List-а на RIP протокола по рутерите в нашата фирма. В този Prefix List настройвам маршрутите, които не трябва да се излъчват към другите рутери. Има обаче някакъв бъг в операционната система на самия рутер и полета, които ги оставям празни, след рестарт на рутера се запълват със стойност 0-32, което автоматично разкъсва размяната на маршрути между рутерите.

Ето го оригиналния линк с хелпа за настройките не Prefix List: https://wiki.mikrotik.com/wiki/Manual:Routing/Prefix_list

Позовавам се на този текст за полето prefix, и го оставям празно, защото искам да важи само за този маршрут и за никакъв друг:

"network prefix to match. If prefix-length is not set, only exact match is done. For example, 0.0.0.0/0 then matches only the default route and nothing else"

Да, ама след рестарт на рутера в полето prefix-length се появява стойност 0-32, която създава голям мазал - разширява обхвата на маршрута 10.0.0.0/8 и на практика блокира изпращането на всякакви други маршрути между рутерите.

Някой може ли да ми помогне какво трябва да се направи?

И някой може ли да информира Mikroтик каква простотия са направили в последдната версия?

 

Ето и какъв хелп са написали от Mikrotik за попълване на полето prefix-length. Ако може някой да ми каже на чист български език какво са искали да напишат, защото аз не мога да го разбера:

"network prefix mask length to match. If prefix-length is set, for a route to match the prefix and prefix-length of a rule, the following should hold:

  • the network prefix of the route falls within the range of the prefix of the rule, (i.e.
  • the network mask of the route is greater of equal than the network mask of the prefix;
  • the network address of the route masked out by the network mask of the prefix is equal to the network address of the prefix;)
  • the length of the network mask of the route falls within the range of the prefix-length

"

 

Забравих да ви кажа - принуден съм да работя с RIP протокол, защото коректно работещия OSPF от предишната версия тотално се сбъгяся след ъпдейта към последната версия. :)

Тези пичове от Mikrotik имат ли нещо, което работи така, както е описано в хелповете им?

Edited by Mateev6012
Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.