Jump to content
  • 0

Mikrotik VPN (HMA) setup


jsnow
 Share

Question

Здравейте,

имам въпрос относно настройка на hide my ass vpn с микротика ми.

Следвах инстукциите от тук https://support.hidemyass.com/hc/en-us/articles/204558497-Mikrotik-Client-Setup и всичко върви що годе добре с default configa на микротика, като сега целия ми нет минава през впн-а.

Изпозлвам го да гледам SKY UK  с tvbox безжично. Въпросът ми обаче е как да го нстроя така че впн-а да работи само на единия eth порт където да закаюа тбож-а а акес пойнта ми да е извън него т.е да си ползвам домашния нет директно?

 

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0
  • Administrator

Правиш НАТ правило на този порт да излиза през ВПН-а

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Привет пробвах с нат на enth3 но как да настроя рутовете?

сега са следните:

 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  0.0.0.0/0                          pptp-out1                 1
 1 ADS  0.0.0.0/0                          101.88.0.1                0
 2  DS  0.0.0.0/0                          131.214.170.1             1
 3 ADS  5.42.33.186/32                      131.214.170.1           0
 4 ADC  101.88.0.1/32      100.99.7.19     pptp-out1                 0
 5 ADC   131.214.170.1/22   131.214.162.168 ether1                    0
 6 ADC  172.16.3.0/24      172.16.3.1      bridge                    0

 

Link to comment
Share on other sites

  • 0
  • Administrator
/ip fi nat 
add action=masquerade chain=srcnat out-interface=VPN dst-address=192.168.50.0/27

 

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Привет,

ще ми трябва повече разяснение, че все още съм нов с този микротик за което благодаря за търпението:)

Не разбирам се га след нат-а и закача на eth3 port tv-boxa как да спра нета на аксес пойнта да минава през впн-а? сега 0.0.0.0/0 ми излиза през впн-а. Искам всички останали устройства да си ползват нет директно от доставчика и да не минават през впн-а както до сега.

За потвърждение горе в нат правилото dst-address трябва да е адреса на тв бокса закачен на eth3 порта, нали?

Link to comment
Share on other sites

  • 0
  • Administrator

По лесно от това на дали

/interface pptp-client
add connect-to=vpn-provider disabled=no max-mru=1500 max-mtu=1500 name=pptp-vpn password=pass user=user
/ip pool
add name=dhcp_pool1 ranges=192.168.25.2
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether5 name=dhcp1
/ip address
add address=192.168.25.1/30 interface=ether5 network=192.168.25.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.25.0/30 dns-server=8.8.8.8 gateway=192.168.25.1
/ip firewall filter
add chain=input comment=winbox dst-port=8291 protocol=tcp
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add chain=forward comment="default configuration" connection-state=established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" connection-state=invalid
/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=vpn src-address=192.168.25.2
add action=jump chain=forward comment="tcp, mss" jump-target=mss
add action=change-mss chain=mss comment="tcp mss fixation" new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=!536-1460
add action=change-mss chain=mss comment="tcp mss 1440 for mtu 1492" new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=1453-65535
add action=change-mss chain=mss comment="tcp, mss clamp-to-pmtu" new-mss=clamp-to-pmtu protocol=tcp tcp-flags=syn
add action=change-mss chain=forward comment="Globally Fix MSS for MTU/MRU 1480" new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=1441-65535
add action=change-mss chain=output new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=1441-65535
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pptp-vpn routing-mark=vpn
/ip route
add distance=1 gateway=pptp-vpn routing-mark=vpn

 

редактирай си съответните променливи

  • Thanks 1
Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.