Jump to content

Две благинки: да не ни пържи радиото поне вечерта и бан за нета на детето след лека нощ деца :)


mr_joker
 Share

Recommended Posts

Целта е да изключи радиото на рутера, да не ни облъчва поне през ноща (моя е 1W) и другото е да спре интернета на детето в 23ч. на телефона и лаптопа му, че се рови цяла нощ и ми омръзна да му се карам ;)

#Блокира достъпа до интернет на Вероника телефона и лаптопа от 23:00 до 09:00 и изключва WIFI от 01:00 до 09:00:

/ip firewall filter
add disabled=yes chain=forward src-mac-address=aa:bb:cc:dd:ee:ff action=drop comment="Block Veronika GSM"
add disabled=yes chain=forward src-mac-address=aa:bb:cc:dd:ee:ff action=drop comment="Block Veronika NB"

/system scheduler
add comment="Enable WIFI" name=schedule_enable_wifi policy=read,write,policy,test start-time=09:00:00 on-event="interface wireless set [ find default-name=wlan1 ] disabled=no"
add comment="Disable WIFI" name=schedule_disable_wifi policy=read,write,policy,test start-time=01:00:00 on-event="interface wireless set [ find default-name=wlan1 ] disabled=yes"
add comment="Block Veronika" name=schedule_block_veronika policy=read,write,policy,test start-time=23:00:00 on-event="/ip firewall filter set [ find comment~\"Block Veronika\" ] disabled=no"
add comment="UnBlock Veronika" name=schedule_unblock_veronika policy=read,write,policy,test start-time=09:00:00 on-event="/ip firewall filter set [ find comment~\"Block Veronika\" ] disabled=yes"

 

Link to comment
Share on other sites

Имаш във филтърa опция за време , така че последните 2 задачи не са необходими за блокиране на трафика!

  • Like 2
Link to comment
Share on other sites

ехаа, наистина има за време и график ... супер!!!

... е как късно, към 9:30 таман да прочета сутрешната преса в леглото, докато жената сервира закуската към 10 и нещо ;)

Link to comment
Share on other sites

малко да оправя нещата, че осъмнах без интернет :)

/ip firewall filter
add comment="Block Veronika GSM" chain=forward src-mac-address=aa:bb:cc:dd:ee:ff action=drop time=23h-9h,sun,mon,tue,wed,thu,fri,sat
add comment="Block Veronika NB" chain=forward src-mac-address=aa:bb:cc:dd:ee:ff action=drop time=23h-9h,sun,mon,tue,wed,thu,fri,sat

/system scheduler
add comment="Enable WIFI" name=schedule_enable_wifi policy=read,write,policy,test start-time=09:00:00 interval=1d on-event="interface wireless set [ find default-name=wlan1 ] disabled=no"
add comment="Disable WIFI" name=schedule_disable_wifi policy=read,write,policy,test start-time=01:00:00 interval=1d on-event="interface wireless set [ find default-name=wlan1 ] disabled=yes"

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • MiPSus
      By MiPSus
      За пореден път ми се наложи да следя устройство, което се предполага (оплакване) , че връзката до него прекъсва от време на време. Всички знаем, колко е досадно да следиш терминала с пинг докато работиш и нещо друго
       
      Та хванах се и драснах едно bash скриптче, което нарекох ping-beep
      #!/bin/bash while true do RES=`ping -c1 -W1 -q -s1400 $1 ` if [ $? -eq 1 ] then echo -n -e "007" fi echo $RES | cut -d"-" -f7 sleep 1 done Което извежда на екрана:
      User@Router:~# ./ping-beep 192.168.17.181 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev = 6.177/6.177/6.177/0.000 ms 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev = 10.098/10.098/10.098/0.000 ms 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev = 8.939/8.939/8.939/0.000 ms 1 packets transmitted, 0 received, 100% packet loss, time 0ms 1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms 1 packets transmitted, 0 received, 100% packet loss, time 0ms 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev = 6.177/6.177/6.177/0.000 ms 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev = 10.098/10.098/10.098/0.000 ms 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev = 8.939/8.939/8.939/0.000 ms Като при всеки пропуснат пинг генерира и "speaker beep" в терминал или през putty се чува сигнала за грешка.
      Така просто ми отвързва очите да върша друго докато дойде момента на прекъсването
       
      Надявам се да е полезно за всички!
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.