Jump to content
  • 0

Настройка на LoadBalansing Mikrotik RB941-2nD-TC hAP lite


Alexybg
 Share

Question

Здравейте,

нов съм с тези микротици и малко се хвърлям на дълбоко. Искам
Mikrotik RB941-2nD-TC hAP lite да го направя като LoadBalansing с failover

Eth1 - WAN1 - Over DHCP - имам пинг до GW 192.168.3.3 ( има ping до abv.bg )
Eth2 - WAN2 - Over DHCP - имам пинг до GW 192.168.4.4 ( няма ping до abv.bg )
Eth3 - LAN - IP 192.168.0.1
Eth4 - LAN

Проблема ми е, че не имам проблем с DHCP то което ми хвърля Eth3 ,Eth4
Слагам Pool , и DHCP Server na Eth3 но не ми го хвърля

[admin@MikroTik] > export
# nov/17/2016 12:56:02 by RouterOS 6.37.1
# software id = MNLD-PFQW
#
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-1C41CD wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether3 ] name="Out Interface"
set [ find default-name=ether1 ] name=WAN1
set [ find default-name=ether2 ] name=WAN2
set [ find default-name=ether4 ] disabled=yes master-port=WAN2
/ip neighbor discovery
set WAN1 discover=no
/ip pool
add name=dhcp ranges=192.168.88.1-192.168.88.255
/ip dhcp-server
add address-pool=dhcp disabled=no interface=WAN1 name=server1
/interface bridge port
add comment=defconf interface=WAN2
add comment=defconf interface=wlan1
/ip address
add address=192.168.88.1/24 interface="Out Interface" network=192.168.88.0
/ip dhcp-client
add add-default-route=no comment=defconf dhcp-options=hostname,clientid disabled=no interface=WAN1 use-peer-dns=no use-peer-ntp=no
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=WAN2 use-peer-dns=no use-peer-ntp=no
/ip dns
set allow-remote-requests=yes servers=4.4.4.4,8.8.8.8
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related" connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface=WAN1
add action=accept chain=input protocol=icmp
add action=accept chain=input connection-state=established
add action=accept chain=input connection-state=related
add action=drop chain=input in-interface=WAN1
/ip firewall mangle
add action=mark-connection chain=prerouting connection-state=new new-connection-mark=WAN1 nth=2,1 passthrough=yes src-address=192.168.88.0/24
add action=mark-connection chain=prerouting connection-state=new new-connection-mark=WAN2 nth=2,2 passthrough=yes src-address=192.168.88.0/24
add action=mark-routing chain=prerouting connection-mark=WAN1 new-routing-mark=WAN1 passthrough=yes src-address=192.168.88.0/24
add action=mark-routing chain=prerouting connection-mark=WAN2 new-routing-mark=WAN2 passthrough=yes src-address=192.168.88.0/24
/ip route
add distance=1 gateway=192.168.3.3 routing-mark=WAN1
add distance=1 gateway=192.168.4.4 routing-mark=WAN2
add distance=1 gateway=192.168.3.3
add distance=1 gateway=192.168.4.4
/system clock
set time-zone-name=Europe/Sofia
/system routerboard settings
set cpu-frequency=650MHz protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=WAN2
add interface=wlan1
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=WAN2
add interface=wlan1
[admin@MikroTik] >
[admin@MikroTik] >

 

Това ми е конфигурацията и не знам даже дали ми е правилна

 

Link to comment
Share on other sites

Recommended Posts

  • 1
  • Administrator
  • Like 1
Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 1
Преди 12 часа, Alexybg написа:

В интерес на истината, проблема си е същия дори и по схемата на този лектор PCC метод.

И проблема не е въобще в DNS са, тъй като всичко се DNS бързо. Но какво е .. това е само загадна за мен.
Ping, торенти. DNS, traceroute всичко върви. Само browsers супер slow ..

Пробвай как са нещата, като разкараш фасттракинга :

add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related disabled=yes
  • Like 1
Link to comment
Share on other sites

  • 0
  • Administrator

Прочети това и кажи ако трябва нещо да се допълни

https://virtualitsupport.wordpress.com/2016/03/20/2-wan-dynamic-dhcp-client-load-balance/

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

:) ами то скрипта като го нямам как да стане :)
Много благодаря

 

Тръгна всичко само не ми е малко ясно защо Ползва WAN1 едно като предпочитан.

По скоро работи като fail over. При възстановяване на WAN1, трафика през WAN2 спира ?

Edited by Alexybg
Link to comment
Share on other sites

  • 0
  • Administrator

Ако искаш да има обединена скорост, ще се сблъскаш с доста проблеми, и ще работи стабилно само с торенти.

  • Like 1
Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Aбсолютно съгласен с последното.Започваш да се сблъскваш с множество дребни проблеми докато го поткараш както трябва и накрая както каза това балансиране работи добре с торенти а всичко друго се получава ту по бързо ту по бавно.Проблема става и по сериозен ако двата входящи канала не са равни е тогава става наистина забавно.В 90% от случаите файловарат остава по практичното решение един доставчик основен и един второстепенен че в по особени случаи и трети мобилен модем примерно.

Link to comment
Share on other sites

  • 0

Ако може малко помощ, тъй като нещо на полеви условия работеше, но в реални условия имам проблеми.

WAN1 = DHCP - Vivacom GW 192.168.1.1
WAN2 = DHCP - SpectrumNet GW 192.168.125.1
LAN= 192.168.0.250/24
DNS съм сложил 192.168.1.1 ( на Vivacom ) и 192.168.125.1 (на Spectrum )

С включен WAN1 всичко работи. При включване физически на WAN2. Ping локално до 192.168.0.250 ( mikrotika ) изчезва. Winboxa не се разкача, но ако го разкача не мога да се вържа отново. Въпреки това го вижда.
Въобще не мога да зацепя как стана този номер ?
Идей какво съм оплескал. Прикачам и файла с текущите настройки

config.txt

Edited by Alexybg
Link to comment
Share on other sites

  • 0
  • Administrator

оправи си имената на интефейсите в скрипта

/system script

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0
  • Administrator

В EdgeRouter са от 4 до 8 реда конфигурация а тук са 20-тина. Просто трябва да седне човек и да обмисли всяка стъпка без да прави копи-пейст. Що се отнася до различния капацитет на двата канала, разбира се, че има решение и се нарича "тежест". Аз съм го писал това и гарантирам, че работи !

http://itservice-bg.net/mikrotik-load-balancing-ecmp-port-source-route-recursive-failover/

Link to comment
Share on other sites

  • 0
18 hours ago, 111111 said:

оправи си имената на интефейсите в скрипта

/system script

 Този път следвах точно описанието на
https://virtualitsupport.wordpress.com/2016/03/20/2-wan-dynamic-dhcp-client-load-balance/

за да избегна че нещо съм оплескал. Само,че не работи коректно. При изключване на WAN1 (Изключен WAN2). Нета на работните станций спира.Дотук OK. Включвам WAN1 и на нета се появява на раб. станций. Решавам да включва WAN2. Оп нета на работните станции спира.Изключвам го и тръгва.
Но Микротика винаги си има ping , до abv.bg примерно, без значение какво кога изкарам. traceroute си ги ради през различните портове в зависимост какво кога съм изкючил

Edited by Alexybg
Link to comment
Share on other sites

  • 0
  • Administrator

какво има в

/ip firewall nat

 

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

 0    chain=srcnat action=masquerade out-interface=ether1-gateway

1    chain=srcnat action=masquerade out-interface=ether2-gateway log=no log-prefix=""
 

Много интересно нещо забелязах преди малко. Снощи го зарязах да го мъча. Идвам днес и почвам пак. От работната станция найстина спира нета i ping до abv.bg ( примерно ) но само за около 1-2мин. След което нещата тръгват. На Микротика явно у трябва малко време да зацепи за какво иде реч.( първоначално явно много съм го юркал и малко Ви заблудих)
Това което забелязах, е че при включването на 2-та WANa . не се възстановява основния което да речем е WAN1. т.е. WAN1 е падал. Рутера превключва на WAN2. WAN1 се възстановява, той продължава да си стой на WAN2.

Другото което вече си е голям проблем е че при два включени и работещи WANа. Самото отваряне на интернет страници е изключително трудно. Мисли до безобразие (през това време ping и trace нямат проблем) . Издърпам ли които и да било WAN. След около мин. Всичко тръгва нормално.

1.rsc

Edited by Alexybg
Link to comment
Share on other sites

  • 0
  • Administrator

Какви са DNS-ите на машините вътре?

 

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

На машите излизат 3 DNS

192.168.0.250 - на микротика
192.168.3.3 - на WAN1 GW ( рутер на единия доставчик)
192.168.125.1 на WAN2 GW (рутер на втория доставчик)

 

[admin@MikroTik] /ip dns> print
                servers: 192.168.3.3,192.168.125.1
        dynamic-servers:
  allow-remote-requests: yes
    max-udp-packet-size: 4096
   query-server-timeout: 2s
    query-total-timeout: 10s
             cache-size: 2048KiB
          cache-max-ttl: 1w
             cache-used: 95KiB



дори и да сменя DNS в микротика на тези на
open dns

208.67.222.222,208.67.220.220

ефекта е същия, при ping от машината до някакъв сайт, гледам че си го resolva бързо

 

 

Link to comment
Share on other sites

  • 0
  • Administrator

В DHCP-server задай микротика да е DNS 

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.