Jump to content

Recommended Posts

Здравейте , 

Някой от вас дали разполагали  със смс скрипт за пращане на смс при пинг и down и up.

Пробвах няколко но не ми праща смс , а любопитното е, че при /tools sms send sms  през WinBox като си оправя кординатите получавам смс.

Пробван скрипт без резултат

 

:local result [/ping 192.168.88.1 count=3]
:global status
:if ($result = 3 && $status != true) do={
  /tool sms send message="link up" phone-number=12345
  :set status true
} else={
  :if ($result = 0 && $status != false) do={
    /tool sms send message="link down" phone-number=12345
    :set status false
  }
}

Някакви предложения?

 

Поздрави

Edited by ExIt
Link to post
Share on other sites
  • Administrator
111111
  • Like 1
Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites

Пробвах и с този вариянт но не работи.

Нямам идея защо така 

 

Този скрипт работи само когато го добавиш през терминала и ако прави проверка въобще не праща повторен смс след 10 секунди дали хоста е даун или ъп.

Някакви други идеи?

Link to post
Share on other sites
  • Administrator
111111

Сложи го като скрипт който да се изпълнява от шедулера

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites
преди 4 минути, 111111 написа:

Сложи го като скрипт който да се изпълнява от шедулера

Оу , тука вече ме прати в тъмна Индия.

Не съм много запознат със Микротик ... малко по Ламерски би ли обяснил.

 

Благодаря

Link to post
Share on other sites
  • Administrator
111111

 /system script

/system scheduler

 

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites
  • Administrator
111111

не скрипта от първия ти пост

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites

Пробвах го това да го направя през WinBox но не сработва не знам защо...

Така и беше с този скрипт за NetWatch-a , но след като го добавих през терминала всичко беше ок, получих смс , че машината е доун , но не получих , че машината е ъп.

Можеш ли да ми кажеш как да го добавя огния скрипт от терминала ? 

Link to post
Share on other sites

за работенето че работи работи обаче само с номера на мтел за съжаление иначе трябва да мине през sms gateway ако някой го интересува да драсне едно лично как точно става

Готов е колегата ако иска може и да го сподели не е тайна :)

Link to post
Share on other sites
Mupo neTkoB

що не ползвате мейл>смс . преди работеше

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to post
Share on other sites

мейл->смс работи само с карти на мтел и има лимит от 200смс-а за месец

Link to post
Share on other sites
  • Administrator
111111
Преди 1 час, wispnet написа:

мейл->смс работи само с карти на мтел и има лимит от 200смс-а за месец

10 на 24ч

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites

Лошото на този начин е , че не прави проверката както ми се иска.. 

Примерно да направи 3 пъти проверка през 3 минути и след това да изпрати смс , че няма достъп...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.