Jump to content
  • 0

Mikrotik Failover 5 WAN


Skynet2

Question

Здравеите имам Mikrotik RB1100AH  5 WAN 1 Lan PPPOE server  се е ок но имам 1 проблем как данаправам FAILOVER ако испадне пример wan 2 автоматически да префрли на wan1??

еве export:

/interface ethernet
set [ find default-name=ether1 ] name=LAN
set [ find default-name=ether2 ] name=optika
set [ find default-name=ether6 ] name=wan1
set [ find default-name=ether7 ] name=wan2
set [ find default-name=ether8 ] name=wan3
set [ find default-name=ether9 ] name=wan4
set [ find default-name=ether5 ] name=wan5



/ip pool
add name=adsl1 ranges=10.0.10.10-10.0.10.254
add name=adsl2 ranges=10.128.22.10-10.128.22.254
add name=adsl3 ranges=10.127.22.10-10.127.22.254
add name=adsl4 ranges=10.126.22.10-10.126.22.254
add name=adsl5 ranges=10.129.22.10-10.129.22.254
add name=vadsl1 ranges=10.130.22.10-10.130.22.254
add name=vadsl2 ranges=10.131.22.10-10.131.22.254
add name=vadsl3 ranges=10.132.22.10-10.132.22.254
add name=vadsl4 ranges=10.133.22.10-10.133.22.254
add name="neplateni smetki" ranges=10.135.22.10-10.135.22.254

/ip firewall mangle
add action=change-ttl chain=prerouting disabled=yes new-ttl=set:1 protocol=icmp
add action=mark-routing chain=prerouting new-routing-mark=adsl1 passthrough=no \
    src-address=10.0.10.0/24
add action=mark-routing chain=prerouting new-routing-mark=adsl4 passthrough=no \
    src-address=10.126.22.0/24
add action=mark-routing chain=prerouting new-routing-mark=adsl2 passthrough=no \
    src-address=10.128.22.0/24
add action=mark-routing chain=prerouting new-routing-mark=adsl3 passthrough=no \
    src-address=10.127.22.0/24
add action=mark-routing chain=prerouting new-routing-mark=adsl5 passthrough=no \
    src-address=10.129.22.0/24
add action=mark-routing chain=prerouting new-routing-mark=vadsl1 passthrough=no \
    src-address=10.130.22.0/24
add action=mark-routing chain=prerouting new-routing-mark=vadsl2 passthrough=no \
    src-address=10.131.22.0/24
add action=mark-routing chain=prerouting new-routing-mark=vadsl3 passthrough=no \
    src-address=10.132.22.0/24
add action=mark-routing chain=prerouting new-routing-mark=vadsl4 passthrough=no \
    src-address=10.133.22.0/24

/ip firewall nat
add action=masquerade chain=srcnat disabled=yes src-address=192.168.0.0/24 to-addresses=0.0.0.0
add action=masquerade chain=srcnat src-address=10.0.10.0/24 to-addresses=0.0.0.0
add action=masquerade chain=srcnat  src-address=10.128.22.0/24 to-addresses=0.0.0.0
add action=masquerade chain=srcnat src-address=10.127.22.0/24 to-addresses=\
    0.0.0.0
add action=masquerade chain=srcnat src-address=10.126.22.0/24 to-addresses=\
    0.0.0.0
add action=masquerade chain=srcnat src-address=10.129.22.0/24 to-addresses=\
    0.0.0.0
add action=masquerade chain=srcnat src-address=10.130.22.0/24 to-addresses=\
    0.0.0.0
add action=masquerade chain=srcnat src-address=10.131.22.0/24 to-addresses=\
    0.0.0.0
add action=masquerade chain=srcnat src-address=10.132.22.0/24 to-addresses=\
    0.0.0.0
add action=masquerade chain=srcnat src-address=10.133.22.0/24 to-addresses=\
    0.0.0.0


/ip address
add address=10.125.90.82/24 interface=wan5 network=10.125.90.0
add address=10.125.20.18/24 interface=wan1 network=10.125.20.0
add address=10.11.11.2/24 interface=vlan1 network=10.11.11.0
add address=10.100.0.1/24 interface=LAN network=10.100.0.0
add address=10.125.20.89/24 interface=wan4 network=10.125.20.0
add address=10.125.30.24/24 interface=wan3 network=10.125.30.0
add address=10.125.70.54/24 interface=wan2 network=10.125.70.0
add address=192.168.100.2/24 interface=optika network=192.168.100.0



/ip route
add distance=1 gateway=10.125.20.1 routing-mark=adsl1
add distance=1 gateway=10.125.20.1 routing-mark=adsl4
add distance=1 gateway=10.125.70.1 routing-mark=adsl2
add distance=1 gateway=10.125.30.1 routing-mark=adsl3
add distance=1 gateway=10.125.90.1 routing-mark=adsl5
add distance=2 gateway=192.168.100.1

ppp profile
set *0 dns-server=8.8.8.8 local-address=10.0.10.2 remote-address=adsl1 use-compression=no use-encryption=no
add dns-server=8.8.8.8 local-address=10.0.10.2 name="adsl1  8500/1500" rate-limit=1500000/7750000 remote-address=adsl1 use-encryption=no
add change-tcp-mss=no dns-server=8.8.8.8 local-address=10.128.22.2 name="adsl2 7500/1000" rate-limit=1500000/7750000 remote-address=adsl2 use-encryption=no
add dns-server=8.8.8.8 local-address=10.127.22.2 name="adsl3 7500/1000" rate-limit=1500000/7750000 remote-address=adsl3 use-encryption=no
add change-tcp-mss=yes dns-server=8.8.8.8 local-address=10.126.22.2 name="adsl4 8500/1500" rate-limit=1500000/7750000 remote-address=adsl4 use-encryption=no
add dns-server=8.8.8.8 local-address=10.128.22.2 name="adsl2 2000/512" rate-limit=100000/1950000 remote-address=adsl2 use-encryption=no
add dns-server=8.8.8.8 local-address=10.130.22.2 name="wadsl1 8900/1500" rate-limit=1502000/6650000 remote-address=vadsl1 use-encryption=no
add dns-server=8.8.8.8 local-address=10.131.22.2 name="vadsl2 8700/1512" rate-limit=1512000/8700000 remote-address=vadsl2 use-encryption=no
add dns-server=8.8.8.8 local-address=10.129.22.2 name="namalena brzina 700/512" rate-limit=120000/516000 remote-address=adsl5 use-encryption=no
add dns-server=8.8.8.8 local-address=10.130.22.2 name="vadsl 1  4200/1000" rate-limit=1000000/4250000 remote-address=vadsl1 use-encryption=no
add dns-server=8.8.8.8 local-address=10.126.22.2 name="za firmi" rate-limit=4512000/6000000 remote-address=adsl4 use-encryption=no
add local-address=10.139.22.2 name="neplateni smetki" rate-limit=20/60 remote-address="neplateni smetki" use-encryption=no
add dns-server=8.8.8.8,62.162.32.5 local-address=10.128.22.2 name="adsl2 5000/1500" rate-limit=1500000/5900000 remote-address=adsl2 use-encryption=no
add dns-server=8.8.8.8 local-address=10.127.22.2 name="adsl3 8000/1000" rate-limit=1500000/7700000 remote-address=adsl3 use-encryption=no
add dns-server=8.8.8.8,80.77.144.10 local-address=10.130.22.2 name="na 200 denari" rate-limit=512000/4800000 remote-address=adsl3
add dns-server=8.8.8.8 local-address=10.129.22.2 name="adsl5 8500/1500" rate-limit=1500000/7750000 remote-address=adsl5 use-encryption=no
add dns-server=8.8.8.8 local-address=10.129.22.2 name="adsl5 9000/1500" rate-limit=1500000/10500000 remote-address=adsl5 use-encryption=no
set *FFFFFFFE use-encryption=no

/interface pptp-server server
set max-mru=1460 max-mtu=1460

 

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
JohnTRIVOLTA

На пътищата си сложи и chack gateway - ping  за всеки gateway , тоест ако няма пинг пътя става неактивен ! А иначе с distance може да зададеш приоритет /предпочитание/ колкото е по-малка цифрата /числото/ толкова по-голям приоритет ще има пътя !

Edited by JohnTRIVOLTA
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.