Jump to content
  • 0

Load balancing с два интернет доставчик


NoLimit

Question

Пробвал ли е някой load balancing на два интернет доставчика?

Аз ползвам RB2011UAS-RM. Имам един стар рутер с два WAN порта и работи перфектно без лагва, ми вършеше много добра работа. Иска да ползвам RouterBoard, но не намирам нищо....Скрипт от mum.mikrotik.com и има много различни руски форум все пак също не ми върши работа, в момента върви е стабилно, но много лагва, входяш интернет доставчик ISP 1 - 100мбит и ISP 2 - 60мбит, тегли торент 12-14MB/s , изходяш с три компютър всички РС-то повече ползвам онлайн игра и видео конференция, някой път работи само 1 компютър пак същата работа лагва.Някой може ли помогне.

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
  • Administrator

Има си принцип да действие което изисква определени познания,

без тях доста мъчно става.

Има няколк теми които биха ти помогнали да се ориентираш 

Ползвай търсачката.

Най-добре се насочи към истинско рутинг решение като BGP

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites
  • 0

NoLimit дай го малко по технически, хем върви стабилно хем лагва, стар рутер  - нов рутер, нищо не разбрахме.

Предлагам ти първо да прочетеш това: http://itservice-bg.net/?p=3164 но внимателно. 

Link to post
Share on other sites
  • 0

Има си принцип да действие което изисква определени познания,

без тях доста мъчно става.

Има няколк теми които биха ти помогнали да се ориентираш 

Ползвай търсачката.

Най-добре се насочи към истинско рутинг решение като BGP

Благодаря ти, ще проверка търсачка за BGP.

 

NoLimit дай го малко по технически, хем върви стабилно хем лагва, стар рутер  - нов рутер, нищо не разбрахме.

Предлагам ти първо да прочетеш това: http://itservice-bg.net/?p=3164 но внимателно. 

В момента нямам стар рутер "Dual WAN Gigabit Load Balance Broadband Router, минала година продадох и взе Микротик, ама не върши работа :)

Ето моя настройка на рутер:

[admin@MikroTik] > /export
# jun/23/2015 02:22:27 by RouterOS 6.29.1
# software id = ARGQ-LRS5
#
/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether1 ] mac-address=00:03:47:3B:27:25 name=ISP_ONE
set [ find default-name=ether3 ] name=ISP_THREE
set [ find default-name=ether2 ] disabled=yes mac-address=00:08:CC:FF:BD:F3 \
    name=ISP_TWO
set [ find default-name=ether4 ] name=LAN_OUT
set [ find default-name=ether5 ] master-port=LAN_OUT
/ip pool
add name=dhcp_pool1 ranges=192.168.80.2-192.168.80.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=LAN_OUT lease-time=3d name=\
    dhcp1
/metarouter
add disabled=yes memory-size=32MiB name=mr2
/port
set 0 name=serial0
set 1 baud-rate=9600 data-bits=8 flow-control=none name=usb2 parity=none \
    stop-bits=1
/interface ppp-client
add apn=internet name=ppp-out1 port=usb2
/ppp profile
set [ find name=default ] name=default
set [ find name=default-encryption ] dns-server=8.8.8.8,4.2.2.2 local-address=\
    dhcp_pool1 name=default-encryption remote-address=0.0.0.0
/system logging action
add email-to=primer@abv.bg name=action1 target=email
/tool user-manager customer
set admin access=\
    own-routers,own-users,own-profiles,own-limits,config-payment-gw
/interface pptp-server server
set enabled=yes max-mru=1460 max-mtu=1460
/ip address
add address=192.168.80.1/24 interface=LAN_OUT network=192.168.80.0
add address=192.168.2.1/24 interface=bridge1 network=192.168.2.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=ISP_TWO
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=ISP_ONE
/ip dhcp-server lease
add address=192.168.80.4 client-id=1:0:3:47:3b:27:25 mac-address=\
    00:03:47:3B:27:25 server=dhcp1
add address=192.168.80.251 always-broadcast=yes client-id=1:d4:ca:00:fc:70:bb \
    mac-address=D4:CA:6D:FC:70:CE server=dhcp1
/ip dhcp-server network
add address=192.168.80.0/24 dns-server=\
    46.47.72.9,46.40.72.13,95.87.48.14,8.8.8.8 gateway=192.168.80.1
/ip dns
set allow-remote-requests=yes cache-size=25000KiB max-udp-packet-size=512 \
    servers=8.8.8.8,8.8.4.4,46.40.72.9,46.40.72.13,95.87.48.14
/ip firewall filter
add action=reject chain=forward comment="za blokirane na url adres" content=\
    www.abv.bg disabled=yes protocol=tcp reject-with=tcp-reset
add action=drop chain=input comment=\
    "Make sure that your proxy is NOT a Open Proxy" disabled=yes dst-port=8080 \
    in-interface=ISP_ONE protocol=tcp
add action=drop chain=forward dst-address=192.168.1.57
add action=drop chain=forward dst-address=192.168.1.57
add action=drop chain=forward dst-address=46.47.80.222
add action=drop chain=forward dst-address=46.47.80.222
add action=drop chain=forward dst-address=46.47.80.222
add action=drop chain=forward dst-address=46.47.80.222
add action=drop chain=forward dst-address=46.47.80.222
add chain=input comment="vijda ping " disabled=yes in-interface=ISP_ONE
/ip firewall mangle
add action=mark-connection chain=input in-interface=ISP_ONE \
    new-connection-mark=ISP_ONE_conn
add action=mark-connection chain=input in-interface=ISP_TWO \
    new-connection-mark=ISP_TWO_conn
add action=mark-routing chain=output connection-mark=ISP_ONE_conn \
    new-routing-mark=to_ISP_ONE
add action=mark-routing chain=output connection-mark=ISP_TWO_conn \
    new-routing-mark=to_ISP_TWO
add chain=prerouting dst-address=46.47.80.0/24 in-interface=LAN_OUT
add chain=prerouting dst-address=95.87.62.0/24 in-interface=LAN_OUT
add action=mark-connection chain=prerouting dst-address-type=!local \
    in-interface=LAN_OUT new-connection-mark=ISP_ONE_conn \
    per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local \
    in-interface=LAN_OUT new-connection-mark=ISP_TWO_conn \
    per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-connection chain=prerouting dst-address-type=!local \
    in-interface=LAN_OUT new-connection-mark=ISP_TWO_conn \
    per-connection-classifier=both-addresses-and-ports:2/2
add action=mark-routing chain=prerouting connection-mark=ISP_ONE_conn \
    in-interface=LAN_OUT new-routing-mark=to_ISP_ONE
add action=mark-routing chain=prerouting connection-mark=ISP_TWO_conn \
    in-interface=LAN_OUT new-routing-mark=to_ISP_TWO
add action=mark-routing chain=prerouting dst-port=80 new-routing-mark=HTTP \
    passthrough=no protocol=tcp
add action=mark-routing chain=prerouting dst-port=443 new-routing-mark=SSL \
    passthrough=no protocol=tcp
add action=mark-routing chain=prerouting dst-port=22 new-routing-mark=SSH \
    passthrough=no protocol=tcp
add action=mark-routing chain=prerouting dst-port=25 new-routing-mark=SMTP \
    passthrough=no protocol=tcp
add action=mark-routing chain=prerouting dst-port=110 new-routing-mark=POP3 \
    passthrough=no protocol=tcp
add action=mark-routing chain=prerouting dst-port=143 new-routing-mark=IMAP \
    passthrough=no protocol=tcp
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ISP_ONE
add action=masquerade chain=srcnat out-interface=ISP_TWO
add action=redirect chain=dstnat comment="Now, Make it Transparent" disabled=\
    yes dst-port=80 protocol=tcp to-ports=8080
/ip proxy
set cache-path=web-proxy1 max-cache-size=none parent-proxy=0.0.0.0 src-address=\
    0.0.0.0
/ip route
add check-gateway=ping distance=1 gateway=46.47.80.1 routing-mark=to_ISP_ONE
add check-gateway=ping distance=1 gateway=95.87.62.1 routing-mark=to_ISP_TWO
add distance=1 gateway=46.47.80.1 routing-mark=HTTP scope=255
add distance=1 gateway=46.47.80.1 routing-mark=SSL scope=255
add distance=1 gateway=46.47.80.1 routing-mark=SSH scope=255
add distance=1 gateway=46.47.80.1 routing-mark=SMTP scope=255
add distance=1 gateway=46.47.80.1 routing-mark=POP3 scope=255
add distance=1 gateway=46.47.80.1 routing-mark=IMAP scope=255
add check-gateway=ping distance=1 gateway=46.47.80.1
add check-gateway=ping distance=1 gateway=95.87.62.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www port=81
set ssh disabled=yes
/metarouter interface
add static-interface=LAN_OUT virtual-machine=mr2 vm-mac-address=\
    02:89:FB:19:64:1E
/ppp secret
add local-address=192.168.80.1 name=alabala password=123456 profile=\
    default-encryption remote-address=192.168.80.105
/snmp
set contact="NoLimit" enabled=yes location=XBG trap-version=2
/system clock
set time-zone-autodetect=no time-zone-name=Europe/Sofia
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set ppp-out1 disabled=yes display-time=5s
set bridge1 disabled=yes display-time=5s
set sfp1 disabled=yes display-time=5s
set ISP_ONE disabled=yes display-time=5s
set ISP_TWO disabled=yes display-time=5s
set ISP_THREE disabled=yes display-time=5s
set LAN_OUT disabled=yes display-time=5s
set ether5 disabled=yes display-time=5s
set ether6 disabled=yes display-time=5s
set ether7 disabled=yes display-time=5s
set ether8 disabled=yes display-time=5s
set ether9 disabled=yes display-time=5s
set ether10 disabled=yes display-time=5s
/system ntp client
set enabled=yes primary-ntp=212.70.148.19 secondary-ntp=79.98.105.18
/system script
add name=reboot policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive source=\
    " /system  reboot"
/tool graphing interface
add
/tool graphing queue
add
/tool graphing resource
add
/tool netwatch
add down-script="/sys script run down" host=8.8.8.8 interval=5m up-script=\
    "/sys script run up"
/tool romon port
add disabled=no
/tool sms
set port=usb2 secret=123456

В момента не ползвам Hotspot (User Manager) и Metarouter (OpenWRT)

Link to post
Share on other sites
  • 0

Има си принцип да действие което изисква определени познания,

без тях доста мъчно става.

Има няколк теми които биха ти помогнали да се ориентираш 

Ползвай търсачката.

Най-добре се насочи към истинско рутинг решение като BGP

Още немога намеря BGP (образец настройка за Load Balancing)в гугъл и ютуб.Можеш ли ми дадеш линк или пише тук за готова конфигурация?

слагай един PFsense и не му мисли колега :)

Преди така беше искам това Pfsence ама неискам излизам голяма консумация за тока и грозно голямо кутия CASE, микротик по малка консумация примерно 15W и удобно сложи комуникация шкаф + усб 3Г изпращам СМС до рестарт.Pfsence ако няма нет как рестартитр NIC?

Link to post
Share on other sites
  • 0
NetworkPro

Трафика е много за RB2011.

Ако ще ползваш QoS - смени RB2011 със x86 itx / AMD APU платформа + RouterOS x86.

Ако няма да ползваш QoS - включи fast-path и fast-track за да спре да "лагва" и ползвай какъвто и да е RB който поддържа fastpath и fasttrack.

Можеш да гледаш от кое лагва от менюто Tools->Profile, както и да пингваш със бърз пинг.

Edited by NetworkPro
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.