Jump to content

Cisco1811


Kircho
 Share

Recommended Posts

Здравейте,

имам рутер Cisco1811,но нещо не мога да си настроя DHCP-то.

Значи рутера има 2 FastEthernet L3 порта и 8 L2 Switch порта.Малка подробност,е че единият L3(FastEthernet0)порт не работи :).

Въпроса ми е как да настроя рутера така,че да ми раздава ИП-та през Switch портовете.Тоест искам да сложа на FastEthernet L3 кабела по който ми идва интернета,а на L2 портовете да закача users.

Ще съм много благодарен ако някой удари едно рамо.

When you dream,there are no rulz...

Link to comment
Share on other sites

Май трябваше първо да спомена,че английският ми е лош  :(

When you dream,there are no rulz...

Link to comment
Share on other sites

Май трябваше първо да спомена,че английският ми е лош  :(

Накратко:

Имаме мрежа с адресно пространство 192.168.10.0/24

ИП адреса на гейта за тази мрежа е 192.168.10.1

ДНС сървърите ще са  4.4.4.1 и  4.4.4.2

Oсновните конанди са

в конфигурационен режим:

Router(config)#service dhcp  (за всеки случай, обикновенно по подразбиране е включен)

Router(config)#ip dhcp pool LAN (LAN - кръщаваш си pool-a по твое желание, в примера е LAN)

Router(dhcp-config)#network 192.168.10.0 255.255.255.0

Router(dhcp-config)#default-router 192.168.10.1

Router(dhcp-config)#dns-server 4.4.4.1 4.4.4.2

Router(dhcp-config)#exit

Router(config)#ip dhcp excluded-address 192.168.10.1 (тук описваш кои ип адреси не желаеш DHCP да раздава, примерно твоя гейт)

Това е.

Може да наблюдаваш DHCP-то с:

Router#show ip dhcp server statistics

Router#show ip dhcp binding

Link to comment
Share on other sites

slevin Благодаря ти много за начина по който ми ги обясни нещата  ;)

Направих ги нещата така както ми обясни и все още рутера не раздава по DHCP.

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.10.1

!

ip dhcp pool LAN

  network 192.168.10.0 255.255.255.0

  default-router 192.168.10.1

  dns-server 4.4.4.1 4.4.4.2

През нито един порт не ми раздава.

Каква може да е причината?  :D

When you dream,there are no rulz...

Link to comment
Share on other sites

slevin Благодаря ти много за начина по който ми ги обясни нещата  ;)

Направих ги нещата така както ми обясни и все още рутера не раздава по DHCP.

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.10.1

!

ip dhcp pool LAN

  network 192.168.10.0 255.255.255.0

  default-router 192.168.10.1

  dns-server 4.4.4.1 4.4.4.2

През нито един порт не ми раздава.

Каква може да е причината?  :D

Добре де, ти дословно ли преписа и въведе командите, защото като гледам конфирурацията, май точно това си направил.

Това горе бе само пример. Замести IP адресите в примера, с тези които са конкретно за твоя случай.

Я пусни изхода от командата

Router#show ip interface brief

Link to comment
Share on other sites

При мен работи така на 871

clock timezone eet 2

clock summer-time eet recurring

ip subnet-zero

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.1

!

ip dhcp pool DHCP

  network 192.168.0.0 255.255.255.0

  default-router 192.168.0.1

  dns-server 1.1.1.1

  lease 0 1

--------

!

interface Vlan1

description LAN

ip address 1.1.1.1 255.255.255.252

ip address 192.168.0.1 255.255.255.0 secondary

 ip nat inside

ip virtual-reassembly

!

Radio Transmision Systems

www.rts-bg.com / ispot.bg

Link to comment
Share on other sites

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Cisco1811

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.10.1

!

ip dhcp pool LAN

  network 192.168.10.0 255.255.255.0

  default-router 192.168.10.1

  dns-server 4.4.4.1 4.4.4.2

!

no ip ips deny-action ips-interface

!

interface FastEthernet0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1

description Fast 1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface FastEthernet9

!

interface Vlan1

no ip address

!

interface Async1

no ip address

!

ip classless

!

no ip http server

no ip http secure-server

!

end

Да преписах командите дословно,защото пробвах доста пати и нищо не се получаваше.

Cisco1811#sh ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

Async1                     unassigned      YES NVRAM  down                  down

FastEthernet0              unassigned      YES NVRAM  administratively down down

FastEthernet1              unassigned   YES NVRAM  up                    up

FastEthernet2              unassigned      YES unset  up                    down

FastEthernet3              unassigned      YES unset  up                    down

FastEthernet4              unassigned      YES unset  up                    down

FastEthernet5              unassigned      YES unset  up                    down

FastEthernet6              unassigned      YES unset  up                    down

FastEthernet7              unassigned      YES unset  up                    down

FastEthernet8              unassigned      YES unset  up                    down

FastEthernet9              unassigned      YES unset  up                  up

Vlan1                      unassigned      YES NVRAM  up                    down

When you dream,there are no rulz...

Link to comment
Share on other sites

Освен че нямаш IP адреси зададени имаш един останал работещ порт, т.е. трябва твоите потребители да са част от мрежата на доставчика ти, да са обединени на Layer2, въпреки това обеднияване на L2 и излизането на рутера с един IP адрес, евентуално те могат да имат като Gateway твоя рутер а той на своя страна да е NAT за тях, т.нар. Router On A Stick демек - рутер с един мрежов итнерфейс където интернета влзиа от там и излзиа пак от там към потребителите закачени сис суич на мрежата на доставчика. Кофти практика като цяло се смъква L2 перформънса... и нямаш никакво секюрити.

Тоя рутер отде го изкопа? Скапания порт на модул ли е? Вземи си нов секънд хенд от ибей, или направо MikroTik ;)

Link to comment
Share on other sites

Малка подробност,е че единият L3(FastEthernet0)порт не работи :).

Вероято няма проблем с порта, защото:

Cisco1811#sh ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

Async1                     unassigned      YES NVRAM  down                  down

FastEthernet0              unassigned      YES NVRAM  administratively down down

И в конфига се вижда:

!

interface FastEthernet0

no ip address

shutdown

duplex auto

speed auto

!

Kircho, нещата които трябва да свършиш са няколко:

1. Да назначиш IP адреси на интерфейсите

2. Да "вдигнеш" този интерфейс

Cisco1811(config)#interface fa0

Cisco1811(config-if)#no shutdown

3. Да настройш рутера да работи в NAT режиш(предполагам де)

4. Да настройш DHCP-то за конкретната конфигурация от IP адресно пространство.

Ако мислиш че може да направиш тези неща тогава действай, ако ли не, съвета ми е да

намериш човек от твоя регион и срещу скромно възнаграждение, ще свършите цялата работа, защото през форума едва ли ще стане

Link to comment
Share on other sites

Тоя рутер отде го изкопа? Скапания порт на модул ли е? Вземи си нов секънд хенд от ибей, или направо MikroTik ;)

Рутера го изкопах от едно училище.Преди училищата имаха мрежи администрирани от министерството и всички имаха техника предоставена им от държавата(сега вече не е така за жалост).Незнам дали във всички училища,но тук в нашия град всички имаха Cisco 1811.

Изгорялия порт не е на модул.

За друг няма финансови възможности :)

FastEthernet0unassignedYES NVRAMadministratively down down

Порта аз го спрях нарочно.Естественно преди това неколкократно го изпробвах.

В момента имам някакъв напредък и накарах рутера да ми раздава ИП-та от вградения суич модул.Явно нещата вече опират до NAT.Ще се радвам ако някой намери време да обясни.

When you dream,there are no rulz...

Link to comment
Share on other sites

Явно нещата вече опират до NAT. Ще се радвам ако някой намери време да обясни.

В общия случай трябва да стане така:

На вътрешния интерфейс трябва да конфигурираш:

Router(config-if)#ip nat inside

на външния интерфейс,

Router(config-if)#ip nat outside

Тук идва и проблема, как ще подкараш NAT след като FastEthernet0 е дефектен.

Да речем, че преодолееш този проблем, продължаваш с

аксес листа ( при теб замени с твойте адреси на вътрешната ти мрежа)

access-list 1 permit 192.168.10.0 0.255.255.255

С командата

Router(config)# ip nat inside source list 1 interface "външния интерфейс" overload

ще стартираш транслирането на вътрешните IP адреси през външния ти интерфейс с неговия IP адрес

Между другото

Router#show controllers

може да даде още полезна информация

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.