Jump to content
  • 0

Малък Проблем


Linux
 Share

Question

Здравейте имам пуснат цс сървър зад микротик картинката е следната

 

RouterBoard -а получава статик ип чрез dhcp client

Имам втора вътрешна мрежа която е 20.20.20.1/24

 

На рутерборда съм задал:

add action=nat
... dst-address=ISP IP to-dst-address=20.20.20.20 Четох че така се прави DMZ

 

проблема е следния че когато клиент влезе в CS Сървъра не влиза с своето IP а влиза с ип - 20.20.20.1

 

някакви идеи на какво се дължи 

 

 
Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

прочети по темите за нат - маскарадинг и темата за пренасочване на портове

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0
  • Administrator

20,20,20,20 не е свободна мрежа

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Все тая е сложих 192.168.5.5 на машината .1 както следва на изхода на микротика и ната ми е направен и порт forwading-а ми е направен влезе ли клиент влиза с ип-то на GW - 192.168.1.1 :) някви други идеи защото до тук резултата е нулев :)

Link to comment
Share on other sites

  • 0

Какво прочете за порт пренасочване

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

Прочел съм как да го направя като цяло направих и маскарадинг правил съм го и преди и не е имало проблем сега се дължи на нещо друго но не мога точно да разбера на какво

Link to comment
Share on other sites

  • 0

първо правиш нат

/ip firewall nat
add action=masquerade chain=srcnat comment=Masquerade out-interface=ВЪНШНИЯ_ТИ_ИНТЕРФЕЙС

после пренасочваш портове които ти трябват

add action=dst-nat chain=dstnat comment="RDP Port Forwarding " dst-port=3389 
    in-interface=Bulsat protocol=tcp to-addresses=172.16.210.100 to-ports=
    3389

ако искаш всички портове четеш тук

http://wiki.mikrotik.com/wiki/How_to_link_Public_addresses_to_Local_ones

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

Тва е идеята че съм го направил :) и по този начин ефекта е същия и ната и пренасочването :) но не съм сигурен на VHOD на интерфейса кво трябваше да е на ARP :)

Link to comment
Share on other sites

  • 0

Да нямаш Masquerade на същото устройство за NAT виртуалната мрежа, на който не си задал интерфейса на работа ?

Link to comment
Share on other sites

  • 0

Нем не е това проверих и аз че не помних кво съм правил ама нямам не е и това

Link to comment
Share on other sites

  • 0

За да го прави това трябва да има някакъв src nat.

Клиентът ти идва във вътрешната мрежа с IP адреса на шлюза достъп ?

--

За да ти работи коректно пренасочването трябва да изпълниш:

/ip firewall nat add chain=dstnat protocol=udp dst-port=27015 action=dst-nat to-addresses=<Вътрешния адрес>
/ip firewall nat add chain=dstnat protocol=tcp dst-port=27015 action=dst-nat to-addresses=<Вътрешния адрес>

Тези 2 правила трябва да ти попълват правил NAT таблицата. Също така трябва да ти е пуснат connection tracking на устройството.

--

За Source NAT-a трябва да направиш:

/ip firewall nat add chain=srcnat src-address=<Вътрешна мрежа> out-interface=<Интерфейс към ISP> action=masquerade
Edited by tsvgos
Link to comment
Share on other sites

  • 0
  • Administrator

Пусни един EXPORT

/ip firewall ex

за да се ориентираме какво си натворил

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.