Jump to content
  • 0

Може ли микротик CCR1016 да замени 3 рутера ?


Vitor
 Share

Question

Конфигурацията до сега беше направена така: 3 те рутера към една вътрешна мрежа 192.168.1.0 с 3 гейтуея 192.168.1.252, 192.168.1.253, 192.168.1.254.

DHCP е включено само на 3тия рутер и раздава адреси за мобилни устройства от 192.168.1.170 до 192.168.1.200.

Идеята е CCR1016 да замени 3те рутера които започнаха да забиват често от както интернет доставчиците минаха на pppoe протокол.

Възможно ли е да се направи такава конфигурация на микротика ? Търсих по нета за подобна конфигурация не намирам нищо само варянти на PCC loadbalance които в случая не стават заради проблемите с port forward и https.

Link to comment
Share on other sites

Recommended Posts

  • 0

как и трите рутера са гейтуей на всички устройства

според мен може да се сложи CCR 

какъв трафик и какви пакети/сек. минават в момента

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

как и трите рутера са гейтуей на всички устройства

според мен може да се сложи CCR 

какъв трафик и какви пакети/сек. минават в момента

Компютрите които трябва да имат постоянен нет са с 3те гейтуея. Другите към които има отворени портове са само с по един гейтуей. Мрежата е направена така защото беше надграждана постепенно а компютрите трябваше да се виждат по между си във вътрешната мрежа.

Нямам съмнения че като хардуеър CCR ще може да замени трите TP-link въпроса ми беше по скоро дали софтуеара позволява рутиране на трите доставчика към една вътрешна мрежа без pcc loadbalance. 

Начинаещ съм в ROS затова пиша в темата за начинаещи. 

Прочетох темата за Policy Routing до колкото разбрах там трябва да се опишат firewall mangle за тези ИП та които трябва да ползват определен доставчик. Как обаче мога от един компютър да си избирам от кой доставчик да е нета без да влизам и да променям правилата в рутера. До сега беше лесно само сменях геитуея.

Link to comment
Share on other sites

  • 0
  • Administrator

може кеф ти по мрежа примерно 

 

вариант 1

192,168,1,х към доставчик 1
192,168,2,х към доставчик 2

и т.н.

 

вариант 2

според описание в рутера
клиент 1 през доставчик 1
и т.н.
 

Вариант 3
по геит както си дал пример 
192.168.1.252, 192.168.1.253, 192.168.1.254

 

има и други варянти
кеф РРРоЕ РРТР и т.н.

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Варянт 2 го видях в линка за Policy Routing.

Как трябва да изглеждат правилата за варянт 3 ? Ако може пример.

Благодаря за отговорите.

Link to comment
Share on other sites

  • 0
  • Administrator

задаваш трите адреса на лан интерфейса
и в маскарадинг правилата определяш от и към къде да се нат-ва

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0
  • Administrator

Хм, от една страна не разбирам защо трябва да си сменя клиента гейта, и как пък ще е по лесно от рутера да се прави това :) ?

От друга тъй като рутера ще е един се предполага, че на трите гейта на доставчиците може да се пусне check-gateway=ping и distance=2 на друг доставчик за да играе в някаква степен ролята на failover защото ако падне гейта в main таблицата, пада dns и дори другите два доставчика да имат нет клиентите няма да имат защото няма dns.

 

Сега, като гледам искаш най простия вариант, макар, че аз не бих го направил така (бих го усложнил до макс :D ) мисля, че това ще го разбереш:

 

ISP Gates:             LAN netowrks:
-------------------------------------------------
ISP1=10.10.1.1     LAN=92.168.1.1/24
ISP2=10.10.2.1     LAN=92.168.2.1/24
ISP3=10.10.3.1     LAN=92.168.3.1/24
 
/ip address
add address=192.168.1.1/24 interface=ether2
add address=192.168.2.1/24 interface=ether2
add address=192.168.3.1/24 interface=ether2

/ip route
add dst-address=0.0.0.0/0 gateway=10.10.1.1 check-gateway=ping
/ip route
add dst-address=0.0.0.0/0 gateway=10.10.2.1 distance=2

/ip firewall mangle
add chain=prerouting action=mark-routing new-routing-mark=inet2 src-address=192.168.2.0/24
/ip route
add dst-address=0.0.0.0/0 gateway=10.10.2.1 scope=255 target-scope=10 routing-mark=inet2

/ip firewall mangle
add chain=prerouting action=mark-routing new-routing-mark=inet3 src-address=192.168.3.0/24
/ip route
add dst-address=0.0.0.0/0 gateway=10.10.3.1 scope=255 target-scope=10 routing-mark=inet3

Няма да можеш са сменяш само гейта на клиента но ще можеш да му смениш ип адреса например 192.168.1.2 от единия доставчик на 192.168.2.2 на другия. Може и в една /24 мрежа да са но трябва да се орежат маските ) например на 64 хоста с маска /26 или 255.255.255.192. Така от 1 до 64 ще е към единия доставчик а от 66 до 128 на другия и т. н. но не мисля, че ще ти е нужно защото това са частни ип адреси.


Има и вариант в който може да запазиш цялата 192.168.1.0/24 без да създаваш 192.168.2.0/24 и 192.168.3.0/24 но трябва да опишеш ип адресите в адрес листа:

ip firewall address-list add list=ISP2 address=192.168.1.3
ip firewall address-list add list=ISP2 address=192.168.1.4
ip firewall address-list add list=ISP3 address=192.168.1.5
ip firewall address-list add list=ISP3 address=192.168.1.6

/ip firewall mangle
add chain=prerouting action=mark-routing new-routing-mark=inet2 src-address-list=ISP2
/ip route
add dst-address=0.0.0.0/0 gateway=10.10.2.1 scope=255 target-scope=10 routing-mark=inet2

/ip firewall manglе
add chain=prerouting action=mark-routing new-routing-mark=inet3 src-address-list=ISP3
/ip route
add dst-address=0.0.0.0/0 gateway=10.10.3.1 scope=255 target-scope=10 routing-mark=inet3
 
Така 192.168.1.2 няма да го иписваме и той ще е рутнат към първия доставчик по подразбиране.
192.168.1.3 и 4 към втория
и 192.168.5 и 6 към третия
Можеш да ги сменяш за секунди през Webfig с мишката :)
Edited by samyil
Link to comment
Share on other sites

  • 0

Какво пречи да се ползва PCC баланс. Ползвам такова нещо с 2 и с 3 доставчика и "компютрите" които трябва да имат интернет си имат интернет без дори да забележат. прехвърлянето на портове не виждам да е проблем също.

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0
  • Administrator

Човека е решил че ако е сложно е интересно

най лесно е с впн /рртр/ правиш си три постановки 

и с един цък си готов винаги може да си инсталираш и 

netsetman и пак да си сменяш настройките с един клик

но мъката и леснотат ане решават проблема ако падне доставчика така че един 

failover няма да е грам излишен

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Не съм интернет доставчик за да седя цял ден пред рутера и да го пренастроивам но като има проблем аз го отнасям.

Става въпрос за жилищна сграда с 5 апартаманта и един офис.Плащаме си на три интернет доставчика на максимални домашни тарифи и си споделяме нета.На телевизора използвам HTPC с XBMC ако даден филм не ми тръгва или накъсва сменям гейтуея (доставчика) и нещата се оправят.Същото същото съм научил и съседите кото определено не са ИТ специялисти и трудно възприемат промените така че колкото по малко промени по добре!. Във офиса съм им сложил и 3те гейта и гугълските DNS.Не знам дали windows-а прави failover но до сега не са се оплаквали да им е спирал нета.Нямам нищо против PCC loadbalance. Пробвах един варянт http://aacable.wordpress.com/2011/06/04/mikrotik-4-wan-load-balance-pcc-complete-script-by-zaib/ от някъкъв Пакистански гуру но работеше много нестабилно на моменти сумира скоростите в друг момент въобще няма нет не знам може и да има някаква грешка човека, А за пренасочването на пртове на доста места прочетох че е проблемно при PCC.

Link to comment
Share on other sites

  • 0

http://wiki.mikrotik.com/wiki/Manual:PCC

Ето го примера, пренасочването не е ниекакъв проблем

Дори ако си сигурен че даден доставчик е по-добър за видео стрииминг можиш хбмц-то да го прекараш през него, или само определен сайт

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

Ако ще купуваш 1016 по-добре пусни още три абонамента и всеки ще си има достатъчно нет. Ама така ти няма да си най-важния в блока :)

Link to comment
Share on other sites

  • 0

CCR1016 вече е купен и от седмица си играя с него, да не мислите че си правя сухи тренировки.Не е въпроса в още три абонамента и въобще не държа да съм най важния.Рутерите все Китайски пръчки така или иначе си ги сменяме на две години и реших този път да минеме на един рутер от висок клас който няма да се налага да рестартирам по няколко пъти на ден и след две години пак да го сменяме защото вече ни е слаб.

След първите не до там успешни опити бях започнал да се съмнявам че ще може да работи както 3-те рутера за това и пуснах така темата в форума.

Link to comment
Share on other sites

  • 0

Купили сте "калашников" да трепате "мишки". Всеки микротик от последната година ще може да се справи със задачата прекрасно >:D


Мисля че така и така си се охарчли, остава да почерпиш някой специалист от форума да ти го сетне някоя вечер и .. будет шастие.

  • Like 1

... и яз можем, и тате може, ма козата си сака пръч!

Link to comment
Share on other sites

  • 0

А някой успявал ли е на един роутер да ползва няколко ADSL на vicacom

 

t.e.

 

 

router  ----> adsl1

           ----> adsl2

           ----> adsl3

           ----> adsl4

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.