Jump to content
  • 0

Port Forward ftp проблем


tension
 Share

Question

Здравейте

от доста време не съм писал но ето ме отново тук имам следният проблем през това правило се логвам с FileZilata и след това ми дава следната грешка:

 

Error: The data connection could not be established: ECONNREFUSED - Connection refused by server

 

;;; FTP
     chain=dstnat action=netmap to-addresses=192.168.6.51 to-ports=21 
     protocol=tcp dst-address=xxx.xxx.xxx.xxx dst-port=990 
тази конфигурация за FTP'то до днес работеше със старият TP-LINK но днес го подмених с Микротик всичко останало работи само въпросият сервиз не работи.
Поздрави Стефан.
Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Блгадря за отговорът най-вероятно говориш за този NAT просто смених външното IP с xx.xx.xxx.xx иначе реално има адрес който е външният. 

111111 може да затвориш темата проблемът е решен ето ги ключовите натове

add action=dst-nat chain=dstnat comment=FTP dst-address=116.16.21.129 dst-port=
    990 protocol=tcp to-addresses=192.168.6.51 to-ports=990
add action=dst-nat chain=dstnat comment=FTP-Passive-PortRange dst-address=
    116.16.21.129 dst-port=10000-10100 protocol=tcp to-addresses=192.168.6.51 
    to-ports=10000-10100

нещата се оправиха и след лек тунинг на FTP сървъра ForceIP и PassivePortRange.

Благодаря за търпението поздрави Стефан.

Edited by tension
Link to comment
Share on other sites

  • 0
  • Administrator

спри локалното фтп на микротик-а

/ip services

правилото ти нещо не е читаво
пробвай с това

/ip firewall filter
add chain=forward dst-to-address="192.168.25.50" protocol=tcp dst-port=21 action=accept comment="Allow FTP Control Port"
add chain=forward dst-to-address="192.168.25.50" protocol=tcp dst-port=20 action=accept comment="Allow FTP Transfer Port"
add chain=forward dst-to-address="192.168.25.50" protocol=tcp dst-port=10000-10019 action=accept comment="Allow limited Passive FTP port range"

промени си ип адреса този е за примерно локално ип

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Здравей

благодаря за отговора опитах но рефюзва още на входа с тези правила. Правилото което съм постнал логава се и все едно неможе да върне обратна връзка за листа със фаиловете и директроите вътре. Някакви предложения.

Поздрави Стефан

Link to comment
Share on other sites

  • 0

Я пусни един EXPORT na firewall-a да видим какво си направил, задължително спри ФТП-то на микротика или смени порта. може да смениш и порта на ФТП сървъра

Link to comment
Share on other sites

  • 0

Здравйе

ето ната ми всичко останли сервизи работят само FTP'то прави проблем да добавя, че xxx.xxx.xxx.xxx ми е външното IP да не стане объркване.

 
0   ;;; FTP
     chain=dstnat action=dst-nat to-addresses=192.168.6.51 to-ports=21 protocol=tcp 
     dst-address=xxx.xxx.xxx.xxx dst-address-type="" dst-port=990 


 1   ;;; MASSC
     chain=srcnat action=masquerade out-interface=ether1 


 2   ;;; SMTP
     chain=dstnat action=dst-nat to-addresses=192.168.6.51 to-ports=25 protocol=tcp 
     dst-address=xxx.xxx.xxx.xxx dst-port=25 


 3   ;;; DNS
     chain=dstnat action=dst-nat to-addresses=192.168.6.51 to-ports=53 protocol=tcp 
     dst-address=xxx.xxx.xxx.xxx dst-port=53 


 4   ;;; IMAPS
     chain=dstnat action=dst-nat to-addresses=192.168.6.51 to-ports=993 protocol=tcp 
     dst-address=xxx.xxx.xxx.xxx dst-port=993 


 5   ;;; HTTP
     chain=dstnat action=dst-nat to-addresses=192.168.6.51 to-ports=80 protocol=tcp 
     dst-address=xxx.xxx.xxx.xxx dst-port=80 


 6   ;;; IMAP
     chain=dstnat action=dst-nat to-addresses=192.168.6.51 to-ports=143 protocol=tcp 
     dst-address=xxx.xxx.xxx.xxx dst-port=143 


 7   ;;; HTTPS
     chain=dstnat action=dst-nat to-addresses=192.168.6.51 to-ports=443 protocol=tcp 
     dst-address=xxx.xxx.xxx.xxx dst-port=443 


 8   ;;; SMTPS
     chain=dstnat action=dst-nat to-addresses=192.168.6.51 to-ports=465 protocol=tcp 
     dst-address=xxx.xxx.xxx.xxx dst-port=465 


 9   ;;; OPENVPN
     chain=dstnat action=dst-nat to-addresses=192.168.6.51 to-ports=1194 protocol=tcp 
     dst-address=xxx.xxx.xxx.xxx dst-port=1194 


10   ;;; RemoteDesktop
     chain=dstnat action=dst-nat to-addresses=192.168.6.222 to-ports=3389 protocol=tcp 
     dst-address=xxx.xxx.xxx.xxx dst-port=3389 


11   ;;; HTTPS-Masc
     chain=srcnat action=masquerade protocol=tcp src-address=192.168.6.0/24 
     dst-address=192.168.6.51 out-interface=ether2 dst-port=443 
     12 X ;;; FTP-Masc
     chain=dstnat action=dst-nat to-addresses=xxx.xxx.xxx.xxx to-ports=990 protocol=tcp 
     src-address=192.168.6.0/24 dst-address=192.168.6.51 dst-port=21 


13   ;;; SMTPS-Masc
     chain=srcnat action=masquerade protocol=tcp src-address=192.168.6.0/24 
     dst-address=192.168.6.51 out-interface=ether2 dst-port=465 


14   ;;; SMTP-Masc
     chain=srcnat action=masquerade protocol=tcp src-address=192.168.6.0/24 
     dst-address=192.168.6.51 out-interface=ether2 dst-port=25 


15   ;;; IMAPS-Masc
     chain=srcnat action=masquerade protocol=tcp src-address=192.168.6.0/24 
     dst-address=192.168.6.51 out-interface=ether2 dst-port=993
Edited by 111111
Link to comment
Share on other sites

  • 0

Забрани всички, и  пусни само 11111 каквото ти е написал като правила той ги е писал с ИП 50 а виждам че твоито е 51 така разгледай ги трябва да работи и почети малко http://wiki.mikrotik.com/wiki/Forwarding_a_port_to_an_internal_IP 

Edited by Momo
Link to comment
Share on other sites

  • 0
  • Administrator

първо една критика когато даваш правила ползвай командата "export" a не командата "print"

и резултата може да оградиш като код с бутончето <>

 

сега може да споделиш какво показва 

 /ip service export

това в случая е фундаментално понеже локалния на рутера ФТП сървър отговаря на заявките ти

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Здравйте

относно сервизите за които ме питате не са пуснати.

set telnet disabled=yes
set ftp disabled=yes port=2121
set www disabled=yes
set ssh disabled=yes

Имам пунсати различни портове заради майл съръвъра който седи зад микротика моят проблем явно е в pureFTPD сървъра в пасивният режим връзвам се към FTP'то през команден ред на порт 990 мога да ходя нагоре надоле по различните папки но немога да листна файловете вътре ето грешката от един онлайн тест 

Status: Resolving address of xxx.xxx.xx.xx
Status: Connecting to xxx.xx.xxx.xx
Status: Connected, waiting for welcome message
Reply: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Reply: 220-You are user number 2 of 50 allowed.
Reply: 220-Local time is now 16:59. Server port: 990.
Reply: 220-This is a private system - No anonymous login
Reply: 220-IPv6 connections are also welcome on this server.
Reply: 220 You will be disconnected after 15 minutes of inactivity.
Command: CLNT http://ftptest.net on behalf of xxx.xxx.xx.xxx
Reply: 530 You aren't logged in
Command: USER defaultstefan
Reply: 331 User defaultstefan OK. Password required
Command: PASS **********
Reply: 230 OK. Current restricted directory is /
Command: SYST
Reply: 215 UNIX Type: L8
Command: FEAT
Reply: 211-Extensions supported:
Reply: EPRT
Reply: IDLE
Reply: MDTM
Reply: SIZE
Reply: MFMT
Reply: REST STREAM
Reply: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Reply: MLSD
Reply: AUTH TLS
Reply: PBSZ
Reply: PROT
Reply: UTF8
Reply: ESTA
Reply: PASV
Reply: EPSV
Error: Carriage return without line feed received

111111 взимам си веднага бележка.

Поздрави Стефан

Link to comment
Share on other sites

  • 0
  • Administrator

 dst-address=xxx.xxx.xxx.xxx го задай да ти е външения интерфейс

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.