Jump to content
Sign in to follow this  
Велин

WS2960-8G и мултикаст проблем

Recommended Posts

Велин

схемата е следната входящ мултикаст през един лан 1гб и три устройства клиенти като две са със 100мбит лан а едно е с гигабит, проблема за мен е че при пускане на повече от 100мбит мултикаст 100мбит устройства започват да цепят а това с гигабита няма проблем, като според циско нетуорк асистанса (в порт мониторинга)не влизат повече от 55мбит в устройство със 100мбит лан , иначе е активиран IGMP snooping на vlan1 други vlan-и не ползвам в момента и няма нищо др вкл. в циското , също така сетнах и статични 100мбит портовете на циското за 100мбит-овите интерфейси, сложих и други правила за евентуален мултикаст флууд, утре ще пейстна какви са точно правилата може нещо да съм объркал... ако някой си е играл да хвърли едно рамо.

post-14-0-38160000-1352930879_thumb.png

Share this post


Link to post
Share on other sites
alalfa

От моите опити с мултикаст сам разбрал едно.При пускане на мултикаст на 100 мегабитов порт (макар и 50 мегабита) порта се ошашква и не работи коректно.Верно не е било cisco ,но ........ 8) .

P.S.

На приемниците от QPSK to IP винаги слагат гигабитов порт ,макар и само за един транспондер.

Edited by alalfa

Share this post


Link to post
Share on other sites
hgd

Предполагам имаш пуснат querier в порта/VLAN-а, през който са ти телевизиите ( sh ip igmp snooping mrouter )?

имаш ли joint-ове? ( sh ip igmp snooping groups )

Ако и двете ти са ок, но все още има проблем - препоръчва се използване на MVR.

Share this post


Link to post
Share on other sites
Велин

ето какъв е конфа

дали ще има ефект ако се сложи някакво правило което допълнително да ограничи определени потоци към определени портове , въпреки че на IGMP това му е работата

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service sequence-numbers

!

hostname Multicast

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

system mtu routing 1500

authentication mac-move permit

ip subnet-zero

!

!

ip igmp snooping vlan 1 static 239.255.хх.х1 interface Gi0/1

ip igmp snooping vlan 1 static 239.255.хх.х2 interface Gi0/1

ip igmp snooping vlan 1 static 239.255.хх.х3 interface Gi0/1

ip igmp snooping vlan 1 static 239.255.хх.х4 interface Gi0/1

ip igmp snooping vlan 1 static 239.255.хх.х5 interface Gi0/1

ip igmp snooping vlan 1 static 239.255.хх.х6 interface Gi0/1

ip igmp snooping vlan 1 static 239.255.хх.х7 interface Gi0/1

!

!

!

!

!

spanning-tree mode pvst

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

no spanning-tree vlan 1

!

vlan internal allocation policy ascending

!

!

!

interface GigabitEthernet0/1

no ip igmp snooping tcn flood

!

interface GigabitEthernet0/2

speed 100

no ip igmp snooping tcn flood

!

interface GigabitEthernet0/3

no ip igmp snooping tcn flood

!

interface GigabitEthernet0/4

speed 100

no ip igmp snooping tcn flood

!

interface GigabitEthernet0/5

no ip igmp snooping tcn flood

!

interface GigabitEthernet0/6

no ip igmp snooping tcn flood

!

interface GigabitEthernet0/7

no ip igmp snooping tcn flood

!

interface GigabitEthernet0/8

no ip igmp snooping tcn flood

!

interface Vlan1

ip address 192.168.9.101 255.255.255.0

no ip route-cache

!

interface Vlan2

ip address 192.168.11.101 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.9.1

ip http server

ip sla enable reaction-alerts

!

line con 0

line vty 0 4

password

login

line vty 5 15

password

login

!

end

Share this post


Link to post
Share on other sites
hgd

дали ще има ефект ако се сложи някакво правило което допълнително да ограничи определени потоци към определени портове

Колега, ефекта най-много да е начупени мултикасти.

За да може някой да ти помогне, дай информацията за mrouter и groups, които ти исках в предния пост (няма значение дали ще цензорираш адресите/групите, стига да не изтриеш редовете :) )

Share this post


Link to post
Share on other sites
Велин

няма изтрити редове само пасс е махнат и муликаст адресите са унифицирани, както съм писал това е целия конфиг на суича.

Share this post


Link to post
Share on other sites
hgd

Извинявай, не си ме разбрал. Конфига е горе-долу ок.

Предполагам, че статичните joint-ове на порт 1 са ти нужни.

Според мен проблема е отсъствието на querier и съответно от там не ти ти сработва.

Затова и питам за резултата от командите:

show ip igmp snooping mrouter

show ip igmp snooping groups

Share this post


Link to post
Share on other sites
Велин

Ти извинявй :) аз не съм особенно в час с тая материя ето резултатите , като на 5-ти порт ми е лаптопа в момента

Multicast#show ip igmp snooping mrouter

Vlan ports

---- -----

1 Gi0/1(dynamic)

Multicast#show ip igmp snooping gr

Multicast#show ip igmp snooping groups

Vlan Group Type Version Port List

-----------------------------------------------------------------------

1 239.255.122.58 user v2 Gi0/1, Gi0/3

1 239.255.122.59 user v2 Gi0/1, Gi0/3

1 239.255.122.62 user v2 Gi0/1, Gi0/3

1 239.255.122.63 user v2 Gi0/1, Gi0/3

1 239.255.122.74 user v2 Gi0/1, Gi0/3

1 239.255.246.250 user v2 Gi0/1, Gi0/2

1 239.255.246.251 user Gi0/1

1 239.255.255.250 igmp v2 Gi0/1, Gi0/5

Share this post


Link to post
Share on other sites
hgd

Така, по информацията ти съдя за следното:

- От порт 1 ти идват мултикастите (от там идва и информация за querier)

Съответно не ти е нужно статично joint-ване за тези портове - ти така връщаш на порта същите мултикасти. т.е.

no ip igmp snooping vlan 1 static 239.255.хх.х1 interface Gi0/1 и т.н.

На порт 2 и 3 имаш нещо, което иска мултикасти. Ако задължително са нужни там, то мойеш статично да ги joint-неш. Ако не - оставяш ги така.

На порт 5 имаш PC (с Windows). :)

Edited by hgd

Share this post


Link to post
Share on other sites
Велин

хм еми един колега каза че с това правило му са се оправили нещата а при мен не ..

ip igmp snooping vlan 1 static 239.255.хх.х1 interface Gi0/1 и т.н.

а иначе схемата е точно така(както съм писал и в първия пост), трафика ми идва от порт 1 , като 2 и 3 си заявяват различен мултикаст (това са модулатори няма нищо общо с др. вид мрежа), като примерно порт 2 се връзва на гигабит а 3 на 100мбит (през него вървят 50мбит) , и ако по порт 2 -гигабитовия се заяви допълнителен трафик чийто общ капацитет минава 100мбит , и се затлачва някак си 3-ти порт който е 100мбит. програмите насичат. Кажи как да джойна мултикастите статично към порт 2 и 3.

Share this post


Link to post
Share on other sites
hgd

Точно както е направено в момента за порт 1, например

ip igmp snooping vlan 1 static 239.11.11.11 interface Gi0/2

ip igmp snooping vlan 1 static 239.11.11.12 interface Gi0/2

ip igmp snooping vlan 1 static 239.11.11.11 interface Gi0/3

Правиш по един запис за всеки мултикаст и го привързваш да излиза на данен порт.

ако все още не се вържи добре - monitor на проблемния порт и вадиш трафика към PC с Wireshark и виждаш какво бърка.

Share this post


Link to post
Share on other sites
Велин

и това не помага ... по неразбираеми причини ефекта си го има, към 100мбит портове трафика си е около 50 мбит и програмите цепят , а тези които са около 22 мбит и са към гигабитовия порт си работят, не знам дали е важно но всичкия тоя мултикаст минава през линк с микротик , средния пинг е около 6 мс и не гиби нито един пакет ..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.