Jump to content

Cisco port NAT + source IP NAT, same interface (on a stick)


NetworkPro

Recommended Posts

Здравейте,

Трябва ми да отворя TCP конекция към WAN IP-то на Cisco рутера (напр. 1811)

Тази конекция да се NAT-не обратно към към Интернет излизайки от същия порт на която е дошла

Освен това Source адреса също да се NAT така че да се "spoof"-не все едно идва от Cisco рутера.

С RouterOS се прави лесно с две правила

/ip firwall nat

add chain=dstnat action=dst-nat in-interface=WAN src-address=222.222.222.221 protocol=tcp dst-port=5001 to-addresses=222.222.222.222 to-ports=5001

/ip firewall nat

add chain=srcnat action=src-nat protocol=tcp dst-address=222.222.222.222 dst-port=5001 to-addresses=<WAN адреса на рутера>

Също въпроса важи и за Linux, JunOS, Vyatta и друго каквото знаете че се ползва по света, но главно за Cisco най-напред.

Благодаря.

Link to comment
Share on other sites

  • 2 weeks later...

Здравейте,

Ако правилно съм разбрал - трябва да нещо подобно като схемата по- долу - така ли е ?

Ако е така пробвай с:

Cisco2600(config)#ip nat inside source static tcp 10.1.1.2 5001 1.1.1.1 5001

Примерно:

LAN - 10.1.1.0/24

WAN - 1.1.1.1

компютър----------------------------------cisco--------------интернет

10.1.1.2/24 | |

10.1.1.1/24 1.1.1.1

Link to comment
Share on other sites

  • Administrator

Целта е да влезне на рутера преди сиското, от който рутер идва интернета,

като залагам че това е бтк бридж ;) и ррроа-то е закачено на сиското.

Т.е. трябва от публичното ип на ррроа-то на интерфейс Х,

входящата заявката да се праща на частното ип на интерфейса като изходяща заявка

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.