Jump to content

бридж - лан и wireless - произволна загуба на линк


koko
 Share

Recommended Posts

От един месец имам огромен проблем, линка между 2 машини започна да се губи. Линка не се разпада, нивото и качеството на сигнала са добри но трафика изчезва от време на време за по 3-4 минути и после се появява и всичко е както трябва. Понякога става 1-2 пъти в час , по няколко пъти с дни не става. В бриджа очаства лан карта и 2 безжични карти ЦМ9, трафика спира само към едната безжична карта.

Останових че в момента в който забраня лан картата в бриджа трафика тръгва, но ако отново я разреша, ако не са минали 3-4те минути трафика спира отново.

Микротика е 2.9.7, отсрешната машина не спира защото съм седял при нея да чакам да стане проблема. В лога нищо не се записва като проблем.

Изтрих бриджа и наново го създадох но проблема не се реши, днес сменихме машината към която нещата спират но проблема остава.

Картите са в режим bridge, na wds mode: dynamic i na default bridge името на бриджа в който е лана( безжичните карти си довабят вдс интерфейса динамично след като остановят връзка)

Опитах пинг по мак адрес в момента на проблема но няма.

Спирах целия firewall i всички възмойни правила но ефект няма.

Машината получава интернет по 3-та безжична карта.

На лана има закъчени 3 пц-та който негенерират почти никакъв трафик (в пиковете 1мбит)

Не се сещам какво друго да опиша, цялата постановка е работила повече от 6 м. без да спре и за минутка.

Ако някой има идея какво да опитам или ако трябва друга информация.

Предварително благодаря

Link to comment
Share on other sites

  • Owner

Ъпгрейдвай. Навремето имах същия проблем. На първо време опитай с periodic calibration=enable , понякога помага

Link to comment
Share on other sites

Само на картата с проблема ли, беше на default, цъкнах го ще видим до утре дали е прекъсвало.

Link to comment
Share on other sites

  • Owner

2.9.7 го прави тоя проблем. А най-гадното, е че го прави на произволни интервали.

Пусни wireless debug в лог-а . Там показваше едни интересни редове. Мисля беше :

data from мак еди кой си unknown

Link to comment
Share on other sites

С periodic calibration=enable нищо не се промени.

Направих вдс-те статични  по този пример http://wiki.mikrotik.com/wiki/Wireless_repeater само дето май е объркано че навсякъде е ap-bridge a при мен клиенткото е station-wds. Обаче когато една от машините вързани на station-wds се рестартира спира трафика и към другата.

Някакви идея?

Link to comment
Share on other sites

  • Owner

Ъпгрейд , най малко до x.27 . При мен се оправи едва след ъпгрейда.

Аз дори съм по консервативен от Mile, не ползвам никакви wds-и , само ap и client.

Временно бях написал един скрипт, който пингваше другия микротик и като загубеше пинга, правеше disable и enable на картата. При мен се оправяше веднага при тая операция.

p.s.

Всъщност сега се сетих. Имам още един подобен проблем . Същата постановка, но с 3 безжични карти. Едната ( на която идва нет-а) е клиент, другите две са ap-bidge в бридж с лан карта.

В момента в които едната безжична карта опстане без закачени клиенти към нея се бъгва целия бридж (МТ) , спира трафика, не може да се логне по ип (само по мак) в него. Засега съм го оставил така, защотот винаги има закачени клиенти към проблемната карта. Проблема се появи след доста манипулации по бриджа - добавяне и махане на интерфейси. Също така, като се прави бридж, препоръчително е първия добавен интерфейс да е лан-а, и да не се маха след това.

Забелязал съм, че бриджове и wds-i при по старите версии не винаги работят коректно. Понякога правят големи мизерии.

Link to comment
Share on other sites

версията е x.27, объркъл съм, лошото е че вече загубих връзка към една от отделечените точки. ще трябва утре да се катеря до там.

Има пинг по мак но нито по мак мога да вляза нито по ип в телнет.

А варянта ап-клиент май става само на версия 3+

Link to comment
Share on other sites

  • Owner

ap -> client става при всяка версия - избягваш бриджовете и wds-ите, но пък се усложнява от към ип адреси и рутиране. Накрая,  пускаш един EoIP тунел.

Провай с чисто нова инсталация и ново конфигуриране , може да се е бъгнал бриджа и ако възстановиш старата конфигурация при нов МТ , пак ще го има проблема.

Link to comment
Share on other sites

Да с еоип съм правил на места и наистина не съм ги пипал никога.

Проблема го открих един NS5 . Той е закачен на крайната машина в режим station-wds заедно с още няколко НС5.Микротика е настроен на ап-бридж вдс-моде: статик. В момента в който добавя неговия статичен вдс в бриджа на микротика проблемите почват даже по често от колкото преди.

Упдейтнат е последният фърмлеър. Проблема започна след като по нова година много кратно спира тока през няколко секудни. Тогава убдейтнах  фърмлеъра и нещата се закрепиха ни пак от време на време пинга изчезваше з апо няколко секунди. Но от 1 седмица е ад, почти постоянно за по няколко минути през няколко минути.

Ако имате идя моля помагайте, вече се изчерпах, а НС5-цата е доста далечна и трудно достъпна, ако може дистанционно да я подкарам някак си.

Link to comment
Share on other sites

Проблема се оказа бъгнал се switch след НС5-цата.

Сменихме го и всичко с вдс-ите и загубите изчезна , вече 6 часа е уп.

Не съм очаквал че switch може да бълва нещо което да запушва микротика.

Link to comment
Share on other sites

  • Administrator

Проблема се оказа бъгнал се switch след НС5-цата.

Сменихме го и всичко с вдс-ите и загубите изчезна , вече 6 часа е уп.

Не съм очаквал че switch може да бълва нещо което да запушва микротика.

оо нищо необичайно :) лууп-не някой порт и си готов , особенно ако пък има и такива които си светят дори и с изкл кабел :)

Не отговарям на постове написани с шльокавица!

Link to comment
Share on other sites

И аз имам сходен проблем. Едно село с около 20 абоната мрежа с 7 суича. От време на време си спира трафика, не се разкача, и после пак  си тръгва. От доста време се съмнявам че може да е кофти суич. Но последно като го направи пуснах картата на чист 5 гхз. и от тогава не го е правил този проблем. Ама все още ми се струва че има някъв суич...  Ще поизчакам да зачести ...

Wireless is more temperamental & variable than a woman’s mood! ;)
"no matter how hard you try, you just can NOT please everyone"

"където глупостта е образец-там разума е безумие.."Гьоте

Link to comment
Share on other sites

  • Administrator

И аз имам сходен проблем. Едно село с около 20 абоната мрежа с 7 суича. От време на време си спира трафика, не се разкача, и после пак  си тръгва. От доста време се съмнявам че може да е кофти суич. Но последно като го направи пуснах картата на чист 5 гхз. и от тогава не го е правил този проблем. Ама все още ми се струва че има някъв суич...  Ще поизчакам да зачести ...

ако имаш примерно някво старо циско го сложи в мрежата и ако запуши порта работата е ясна :) , ако също имаш пусната статистика с пингове до абонатите (смокепинг примерно) и ако си сигурен че няма претоварване а има загуби :) това също е признак.

Не отговарям на постове написани с шльокавица!

Link to comment
Share on other sites

ако имаш примерно някво старо циско го сложи в мрежата и ако запуши порта работата е ясна :) , ако също имаш пусната статистика с пингове до абонатите (смокепинг примерно) и ако си сигурен че няма претоварване а има загуби :) това също е признак.

Пуснал съм какти то да го следи МТ, за съжаление няма циско :)

Wireless is more temperamental & variable than a woman’s mood! ;)
"no matter how hard you try, you just can NOT please everyone"

"където глупостта е образец-там разума е безумие.."Гьоте

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.