Jump to content
  • 0

Проблем с VPN


bakalla

Question

Здравейте!

Опитвам се с микротик(RB751U v5.6) да се присъединя чрез PPTP към друг отдалечен микротик(RB750GL) (10.20.20.1) за да мога да достъпвам компютрите които са зад него

Това са ми настройките:


[admin@MikroTik] /interface> print

Flags: D - dynamic, X - disabled, R - running, S - slave

#	 NAME							 TYPE			   MTU L2MTU  MAX-L2MTU

0  R  IC							   pptp-out		  1460

1	 pptp-in1						 pptp-in		

2  R  ESCOM							pppoe-out		 1480

3  R  WAN							  ether			 1500  1600

4	 ether2						   ether			 1500  1598	   2030

5	 ether3						   ether			 1500  1598	   2030

6  R  ether4						   ether			 1500  1598	   2030

7  R  LAN_master					   ether			 1500  1598	   2030

8	 wlan2							wlan			  1500  2290

9  R  bridge_wlan					  bridge			1500  1598


[admin@MikroTik] /interface pptp-client> print

Flags: X - disabled, R - running

0  R name="IC" max-mtu=1460 max-mru=1460 mrru=disabled connect-to=**.**.**.** user="***" password="***"

	  profile=default-encryption add-default-route=no dial-on-demand=no allow=mschap2


[admin@MikroTik] /interface pppoe-client> print

Flags: X - disabled, R - running

0  R name="ESCOM" max-mtu=1480 max-mru=1480 mrru=disabled interface=WAN user="**" password="**"

	  profile=default service-name="" ac-name="" add-default-route=no dial-on-demand=no use-peer-dns=no

	  allow=pap,chap,mschap1,mschap2


[admin@MikroTik] /ip firewall filter> print

Flags: X - disabled, I - invalid, D - dynamic

0   chain=output action=accept connection-state=new protocol=tcp dst-port=1723

1   chain=output action=accept protocol=gre

2   chain=output action=accept protocol=udp dst-port=1723

3   chain=input action=accept protocol=tcp src-address-list=local

	 dst-port=8291


[admin@MikroTik] /ip firewall nat> print

Flags: X - disabled, I - invalid, D - dynamic

0   chain=srcnat action=masquerade out-interface=IC

1   chain=srcnat action=masquerade out-interface=ESCOM


[admin@MikroTik] /ip route> print

Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,

B - blackhole, U - unreachable, P - prohibit

#	  DST-ADDRESS		PREF-SRC		GATEWAY			DISTANCE

0 A S  0.0.0.0/0						  ESCOM					 1

1 ADC  10.10.10.0/24	  10.10.10.100	bridge_wlan			   0

2 A S  10.20.20.0/24					  IC						1

3 ADC  10.20.20.1/32	  10.20.20.99	 IC						0

4 ADC  213.16.*.*/32	  213.16.*.*	  ESCOM					 0

Имам пинг към всички компютри от далечната мрежа. Мога да влизам и с Remote Administrator на всички, но проблема е че има 2 сървъра с камери до които също има пинг но не мога да се свържа с видео-сървъра

Не мога също да се свържа и с отдалечения микротик с Windbox. Първо минавa "Logging in ...." и след това заспива на "Retreiving preferences from ...."

Когато се свържа директно от лаптопа с PPTP всичко си работи

Моля да ми подскажете какво липсва в настройките за да се получава този проблем

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

  • 0
  • Administrator

Какви адреси получаваш?

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Какви адреси получаваш?


[admin@MikroTik] /ip address> print

Flags: X - disabled, I - invalid, D - dynamic

#   ADDRESS			NETWORK		 INTERFACE																

0   10.10.10.100/24	10.10.10.0	  LAN_master																									

2 D 213.16.*.*/32	  213.16.*.*	  ESCOM																	

3 D 10.20.20.99/32	 10.20.20.1	  IC

Link to comment
Share on other sites

  • 0
  • Administrator

по скоро от сървъра трябваше да дадеш тази информация

виж в /ip neighbor дали ip-то е това което очакваш

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

по скоро от сървъра трябваше да дадеш тази информация

виж в /ip neighbor дали ip-то е това което очакваш

/ip neighbor и на двете места е празно

адресите на сървъра са


[admin@MikroTik] /ip address> print

Flags: X - disabled, I - invalid, D - dynamic

#   ADDRESS			NETWORK		 INTERFACE							  

0   10.20.20.1/24	  10.20.20.0	  LAN-MASTER							  

1   88.203.**.**/24	88.203.**.**	WAN														  

2 D 10.20.20.1/32	  10.20.20.99	 <pptp-SW-Sm-1>

Link to comment
Share on other sites

  • 0


3   chain=input action=accept protocol=tcp src-address-list=local

	 dst-port=8291

*

*

Не мога също да се свържа и с отдалечения микротик с Windbox. Първо минавa "Logging in ...." и след това заспива на "Retreiving preferences from ...."

Когато се свържа директно от лаптопа с PPTP всичко си работи

*

Дропиш всички освен локал и очкаваш от вън да се вържеш към порт 8291??

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

Дропиш всички освен локал и очкаваш от вън да се вържеш към порт 8291??

Това е на клиентския микротик.

Спрях го но без резултат

Link to comment
Share on other sites

  • 0

ако искаш пиши на лични някакви данни и да вляза да го погледна

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

На 750GL не си писал какви филтри имаш.

Защо нат-ваш адресите през pptp-то ? и след тия правила в filter имаш ли DROP ?

Edited by pavlan
Link to comment
Share on other sites

  • 0

На 750GL не си писал какви филтри имаш.

Защо нат-ваш адресите през pptp-то ? и след тия правила в filter имаш ли DROP ?

На 750GL(сървъра) няма правила в filter

За натването мисля че така ще достъпвам компютрите зад сървъра.И без него пак не става.

а на клиентския няма drop накрая

Link to comment
Share on other sites

  • 0

На 750GL(сървъра) няма правила в filter

За натването мисля че така ще достъпвам компютрите зад сървъра.И без него пак не става.

а на клиентския няма drop накрая

Пробвай да рутираш двете частни мрежи през тунела със съответните правила на сървъра и клиента.

Като гледам на клиента има път към 10.20.20.0/24.

А тия правила в filter така са безсмислени , особено това за udp на 1723 port.

Link to comment
Share on other sites

  • 0

днес го гледах. сложили сме рутинг правила на двете частни мрежи в различните рутери. няма никакви правила във филтъра. тунела се вдига, пинга си върви от компютър в единия офис до компютри в другия, пинга си върви и до въпросния DVR който обаче не пуска картина през VPN-a. windows shanring работи на компютри в различните офиси т.е. не само пинга върви...

общо взето не можах да го преборя. интерното е че като се върже с vpn към рутера който е в офиса с ДВР-а и работи, като е през двата микротика и неще

все си мисля че въпросния ДВР има някакъв вид firewall ама колегата каза че няма... не знам няма логика в цялата ситуация

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

Всичко изглежда добре настроено и на двата микротика но картина няма.Firewall на DVR няма.

Преди всичко си вървеше когато бях с АДСЛ и Микротик 3.22 качен на PC

От както смених интернет-доставчика и микротика с RB751U - v.5.6 стана проблема

Настройките са 1:1 със старите с лека корекция по интерфейсите заради 5-те порта

Link to comment
Share on other sites

  • 0

Всичко изглежда добре настроено и на двата микротика но картина няма.Firewall на DVR няма.

Преди всичко си вървеше когато бях с АДСЛ и Микротик 3.22 качен на PC

От както смених интернет-доставчика и микротика с RB751U - v.5.6 стана проблема

Настройките са 1:1 със старите с лека корекция по интерфейсите заради 5-те порта

Виж Torch и Packet sniffer какво ще кажат. :))

Проблема може и да е с някое MTU.

  • Like 1
Link to comment
Share on other sites

  • 0

Виж Torch и Packet sniffer какво ще кажат. :)) Проблема може и да е с някое MTU.

Наистина се оказа от MTU. Смених Max MTU на PPTP-конекцията на 1400 и тръгнаха нещата.

Много благодаря за съвета!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.