Jump to content
  • 0

tftp-server-name в dhcp-server за CISCO VoIP телефон


cdman

Question

Някой добавял ли е tftp-server-name опция към DHCP сървър-а на Микротик - от няколко часа се опитвам да я добавя и нещо не ми се удава. Имам отделно TFTP сървър който е тестван и работи на 10.1.1.20 , но телефона си получава 10.1.1.1 и отказва да зарежда каквото и да е :) , модела на cisco-то е CP-7961G но не мисля че има значение де.

конфигурацията ми изглежда така:



/ip dhcp-server

add address-pool=dhcp_pool1 authoritative=after-2sec-delay bootp-support=static disabled=no interface=bridge1 lease-time=3d name=dhcp1

add address-pool=hs-pool-4 authoritative=after-2sec-delay bootp-support=static disabled=no interface=eth4-zhechko lease-time=1h name=dhcp2

/ip dhcp-server option

add code=150 name=tftp-server-name value=10.1.1.20

/ip dhcp-server config

set store-leases-disk=5m

/ip dhcp-server lease

add address=10.1.1.203 always-broadcast=yes client-id=1:0:18:ba:c8:c8:89 comment=CP-7961G disabled=no mac-address=00:18:BA:C8:C8:89 server=dhcp1

/ip dhcp-server network

add address=10.1.1.0/24 dhcp-option="" dns-server="" gateway=10.2.2.1 ntp-server=10.1.1.20 wins-server=""

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
danielskiii

при мен за tftpd е такъв конфиг-а add address=192.168.2.0/24 boot-file-name=ardbp32.bin dhcp-option=""

dns-server=192.168.2.254,8.8.8.8 gateway=192.168.2.254 next-server=

192.168.2.133 ntp-server="" wins-server=""

Link to post
Share on other sites
  • 0

В конфигурацията ти липсва опцията next-server= не съм го правил под МикроТик, но с нея се задава адреса на TFTP сървъра

Link to post
Share on other sites
  • 0


/ip dhcp-server network print detail

0 address=10.0.0.0/24 gateway=10.0.0.1 dns-server=10.0.0.1

   ntp-server=212.70.148.11 dhcp-option=TFTP


/ip dhcp-server option print		

# NAME								CODE VALUE							  

0 TFTP								66   10.0.0.11

11-ката е тфтп сървъра

Edited by Boyan

Разочарованието от лошото качество, остава дълго след удоволствието от ниската цена..

Link to post
Share on other sites
  • 0

Така.. двете опции, които трябва задължително да имаш в конфигурацията на DHCP сървъра и които определя параметрите на boot-tftp са

boot-file-name (text) - Boot file name

next-server (IP address) - IP address of next server to use in bootstrap

Без да ги имаш и двете и без да са правилно указани, никога няма да бутнеш от мрежата.

  • Like 1
Link to post
Share on other sites
  • 0

Аз пък се мъчих на DD-WRT и нищо не стана.

Забелязах обаче нещо полезно, когато телефона си е взел от DHCP сървъра настройките за TFTP, премествайки го на друг DHCP сървър на който не му подава опция за TFTP (150), той си помни TFTP адреса от стария.

Пробвай дали ще проработи и при теб.

Link to post
Share on other sites
  • 0

След 3 дни неравностойна борба успях да го пусна тоя телефон :) , първо се оказа че според фърмуера - опцията за тфтп е различна. АКо е SCCP предпочита да е опция 150 , ако е SIP - предпочита да е опция 66 - но най лесно се оказа TFTP сървъра направо на ръка да се укаже в настройките на телефона :) - има такава опция макар и скрита във сетингс.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.