Jump to content

bondin-гa не работел добре !


Велин
 Share

Recommended Posts

  • Administrator

http://kirkpbm.wordpress.com/2008/08/10/mikrotik-load-balancing-over-multiple-interfaces/

http://kirkpbm.wordpress.com/2008/08/24/mikrotik-load-balancing-over-multiple-interfaces-part-2/

в момента съм на тази вълна и се ровя по този въпрос, много хора пишат че линковете с бондинг на две wifi платки се държат по - зле отколкото ако е само една, тествал съм една такава установка с по 2 карти и аликс , резултата на удп теста беше наистина добър но на тцп никак, и както чета и във форума почти всеки се оплаква , някой смятат, че това може да е ефект ако няма 100% качество на връзката  

друг начин за лоад балансинг

Не отговарям на постове написани с шльокавица!

Link to comment
Share on other sites

До 20 дни ще имам линия с bounding и ще дам резултати.

Относно load-balansing-a микротик се справя отлично.

Ето един пример:

2 линий по 5 Mbit от един и същи доставчик, с лоад балансинга получавам 2 x line.

Линийте са малки 5Mbit но това е без значение ако бяха по 40 щеше да е 2 x 40 = 80. Просто това е едно реално изпълнение което съм взел за онагледяване.

Направен е така:

/ip firewall mangle

# Маркирам всеки 1 пакет с маркер odd, задължително пропуснете трафика да продължи с passthrough=yes за да можете да го обработвате надолу.

add chain=prerouting in-interface=lan connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes

add chain=prerouting in-interface=lan connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no

# Маркирам всеки следващ пакет с маркер even

add chain=prerouting in-interface=lan connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes

add chain=prerouting in-interface=lan connection-mark=even action=mark-routing new-routing-mark=even passthrough=no

/ip route print

# Всичко което е маркирано като odd го пращам през gateway GW1. Добре е също да проверявате с пинг дали gateway е жив, ако не да ползвате само едната линия.

add dst-address=0.0.0.0/0 gateway=GW1 check-gateway=ping interface=ISP1 gateway-state=reachable scope=255 target-scope=10 routing-mark=odd

# Всичко което е маркирано като even го пращам през gateway GW2

add dst-address=0.0.0.0/0 gateway=GW2 interface=ISP2 gateway-state=reachable scope=255 target-scope=10 routing-mark=even

# Всичко останало да минава през GW2

add dst-address=0.0.0.0/0 gateway=GW2 interface=ISP2 gateway-state=reachable scope=255 target-scope=10

където:

in-interface=lan - локалния интерфейс

GW1 - първия gateway

GW2 - втория gateway

interface=ISP1 - първия външен интерфейс

interface=ISP2 - втория външен интерфейс

схема

                    +-----------------------------+

ISP1 -----------|  Mikrotik Load balansing  | ------- Lan

                     |                                     |

ISP1------------|                                     |

                     +----------------------------+

Забележка: Това работи ако на 2 изходни интерфейса има маскарад. Който маскира трафика да излиза с адресите на изходните интерфейси. Поради простата причина че трябва да се знае от къде да се върне заявения трафик.

За реални мрежи май не е подходящ примера.

/ip firewall nat

add chain=srcnat out-interface=ISP1 action=masquerade

add chain=srcnat out-interface=ISP2 action=masquerade  

p.s. Пак може и при wifi-тата да има проблем защото, идеята на bounding-a, е да агрегатира /събере/ два физически интерфейса /по подразбиране ether/

http://www.kernel.org/pub/linux/kernel/people/marcelo/linux-2.4/Documentation/networking/bonding.txt

Затова и документа се нарича: "Linux Ethernet Bonding Driver mini-howto"

t.e. там се предполага че връзката ще е сигурна.

Link to comment
Share on other sites

Ето и един интересен документ.

http://mum.mikrotik.com/presentations/AR07/Urbina_exposicion.pdf

В него ще видите bonding който прави: 200MBit FD

Кое ми прави впечатление. Микротик навсякъде почти пускат EOIP тунели върху wifi-то. Това може би е защото bonding е агрегатиране на eth интерфейси. Така те правят виртуални eth интерфейси и върху тях вдигат bonding.

Защото самата идея на bonding е създаване на "Ethernet Bonding Driver" поне такава е била идеята на:

 - Willy Tarreau <willy at meta-x.org>

 - Constantine Gavrilov <const-g at xpert.com>

 - Chad N. Tindel <ctindel at ieee dot org>

 - Janice Girouard <girouard at us dot ibm dot com>

Link to comment
Share on other sites

  • Administrator

Това с маркирането го четох във втория линк който постнах , благодаря за обясненията само, че сега трябва да видя как ще стане с wifi.

Не отговарям на постове написани с шльокавица!

Link to comment
Share on other sites

  • Administrator

такаа и аз вече тествам трасе с бондинг ама явно никой не обича да пише за това , постигнатото не е върха на сладоледа но поне работи цялата работа, резултата е 124мбит HD на 24 000p/s , теста е правен заедно с реален трафик от около 53 мбит HD който е включен в резултата , платките са Sr5 , трасето 35 км.

Не отговарям на постове написани с шльокавица!

Link to comment
Share on other sites

Браво.

За разлика от Lacho, твойто е реално.

Дай малко инфо на хората:

1. Как е направен /карти, растояния, сигнал, версия микротик, антени/

2. Малко снимков материал.

Щото този рекорд на микротик: http://www.mikrotik.com/wireless.php#nstrm, вече е стар и ти го би ;)

Link to comment
Share on other sites

Тошко престани да се заяждаш вече защото почна да ме дразниш сериозно !

А ти не издразни ли доста хора ...

но за да запазим добрия тон не го приемай сериозно ;)

Между другото сега като чета форума на микротик /любим сайт/

Техните GURU казват така:

"Bonding provides failover, Dual Nstreme not. Dual Nstreme is easier in configuration."

т.е. трябва да се има едно наум ...

Link to comment
Share on other sites

  • Administrator

Браво.

За разлика от Lacho, твойто е реално.

Дай малко инфо на хората:

1. Как е направен /карти, растояния, сигнал, версия микротик, антени/

2. Малко снимков материал.

Щото този рекорд на микротик: http://www.mikrotik.com/wireless.php#nstrm, вече е стар и ти го би ;)

картите както писах са SR5 - 400mw(AR5213), PC машина на 3ghz, чинии 120 една и 140см останалите 3 ,има доста запас на сигнал нивата на единия линк са -52 другия -59, разстояние 35km, версията на Мт е 2.9.27 , при колапс на единия линк връзката не се разпада. Nstreme 2 ще даде повече скорост но линковете трябва да са ти много надеждни.

п.с. на едната машина ми се дублират IRQ-то на едната WIFI карта и на ether интерфейса който ползвам, но за сега нещата работят натоварването на процесора е около 50%. Това е тест но едва ли тези мегабити мога да бъдат оползотворени, реалното натоварване може да не докара толкова.

Не отговарям на постове написани с шльокавица!

Link to comment
Share on other sites

  • Administrator

Tx Power - default , по подразбиране,  пробвах да ги намалям но така работеха най - добре

Не отговарям на постове написани с шльокавица!

Link to comment
Share on other sites

Това абяснява нещата, защо караш 35 км с 1.20 :) По-принцип са много малки за 35 км. Според мен ще имаш по-добри резултати с по-големи антени и намалена мощност на картите.

www.ev-bg.com  

Link to comment
Share on other sites

Някой ще може ли да ме светне, колко dbm колко mW са ?

И да попитам нещо малко off topic...

На секторна антена на 5 гхз, хубаво ли е да се сложи по мощна карта (400мв), като се има в предвид че клиентите ще са с Нано стейшън 5?

Wireless is more temperamental & variable than a woman’s mood! ;)
"no matter how hard you try, you just can NOT please everyone"

"където глупостта е образец-там разума е безумие.."Гьоте

Link to comment
Share on other sites

  • Administrator

Някой ще може ли да ме светне, колко dbm колко mW са ?

И да попитам нещо малко off topic...

На секторна антена на 5 гхз, хубаво ли е да се сложи по мощна карта (400мв), като се има в предвид че клиентите ще са с Нано стейшън 5?

гугъл знае всичко

калкулатор

Не отговарям на постове написани с шльокавица!

Link to comment
Share on other sites

гугъл знае всичко

калкулатор

А за втория въпрос какво ще кажете ?

Wireless is more temperamental & variable than a woman’s mood! ;)
"no matter how hard you try, you just can NOT please everyone"

"където глупостта е образец-там разума е безумие.."Гьоте

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.