Jump to content

Питане за ОpenWRT - начинаещ


shizo
 Share

Recommended Posts

Имам БТК модел качих му OpenWRT и искам да му инсталирам web interface защото не разбирам от shell команди

Та ако може да хелпнете как да конфигурирам getway-a че да имам нет на рутера и съответно да си сложа web interface-a , благодаря

Link to comment
Share on other sites

Абе с 2 думи се нуждая от luci имам telnet , ssh , scp

ако може едно просто обяснение как да го инсталирам ?

Link to comment
Share on other sites

трябва да се редактира /etc/config/network

може да използваш vi

там добави gateway, dns, промени ip address ако трябва

за да влезе в сила /etc/init.d/network restart

след като вече има Интернет на машинката, трябва да въведеш

opkg update

opkg install luci

само че този Web интерфейс на този рутер нещо не върви добре

Link to comment
Share on other sites

Сега ще тествам ,а то въобще има ли друг дето да върви ?

Иначе как да добавя getway и dns , самия файл ето така излгежда при мен

# Copyright © 2008 OpenWrt.org

config interface loopback

option ifname lo

option proto static

option ipaddr 127.0.0.1

option netmask 255.0.0.0

config interface lan

option type bridge

option ifname eth1

option proto static

option ipaddr 192.168.1.1

option netmask 255.255.255.0

config interface wan

option ifname eth0

option proto dhcp

Edited by shizo
Link to comment
Share on other sites

под

option ipaddr ...

слагаш

option gateway ....

option dns ...

за повече информация може да видиш тук http://wiki.openwrt....doc/uci/network

както и http://wiki.openwrt.org/doc/uci command line utility

Edited by NetworkPro
Link to comment
Share on other sites

Ок конфигурирах DNS и GETAWAY рестартирах тръгна нета инсталирах opkg update и opkg install luci

тръгнаха нещата на на вид нормално това са последните редове

Configuring luci-lib-sys.

Configuring liblua.

Configuring libuci-lua.

Configuring lua.

Configuring luci-lib-core.

Configuring luci-lib-nixio.

Configuring luci-sgi-cgi.

Configuring luci-lib-lmo.

Configuring luci-lib-web.

Configuring luci-proto-core.

Configuring luci-proto-ppp.

Configuring luci-i18n-english.

Configuring luci-mod-admin-core.

Configuring libiwinfo.

Configuring luci-theme-base.

Configuring luci-theme-openwrt.

Configuring luci-app-firewall.

Configuring luci-lib-ipkg.

Configuring luci-mod-admin-full.

Configuring uhttpd.

Configuring luci.

Рестартирах и на 192.168.1.1 през браузер пак няма никой ... Какво още трябва да се направи или бъркам нещо ?

ЕДИТ : Дописах следните редове

/etc/init.d/uhttpd enable

/etc/init.d/uhttpd start

и тръгна

Edited by shizo
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.