Jump to content

RB411 асистенция при насочване на антена


111111
 Share

Recommended Posts

  • Administrator

скрипта е в помощ за насочване на антената

с помощ на LED индикаторите на борда

:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=1 do={
 :if ($"signal-strength" <= -90) do={
  :led led1=no led2=no led3=no led4=no led5=no;
  }
 :if ($"signal-strength" <= -85 && $"signal-strength" > -90) do={
  :led led1=yes led2=no led3=no led4=no led5=no;
  }  
 :if ($"signal-strength" <= -80 && $"signal-strength" > -85) do={
  :led led1=yes led2=yes led3=no led4=no led5=no;
  }  
 :if ($"signal-strength" <= -75 && $"signal-strength" > -80) do={
  :led led1=yes led2=yes led3=yes led4=no led5=no;
  }
 :if ($"signal-strength" <= -65 && $"signal-strength" > -75) do={
  :led led1=yes led2=yes led3=yes led4=yes led5=no;
  }  
 :if ($"signal-strength" <= -20 && $"signal-strength" > -65) do={
  :led led1=yes led2=yes led3=yes led4=yes led5=yes;
  }  
}
}[/code] трябва да се смени wlan1 с името на безжичния интерфейс както и да тунинговате нивото на signal-strength по ваше желание за по голяма прецизност следното връща нормалната функция на LED индикаторите
[code]:led led1=no led2=no led3=no led4=no led5=no

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 1 month later...

Браво! това е много полезно особено ако не разполагаш с лаптоп на някое място. Поздравления за темата. Браво!!! А дали ще тръгне на RB433. Според мен не би трябвало да има проблем. Все пак е МикроТик.

Link to comment
Share on other sites

  • Administrator

ако има налично осветление защо не

може да го преправя със звуков ефект ;)

нещо такова примерно

:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=1 do={
 :if ($"signal-strength" <= -90) do={
  :beep frequency=500;
  }
 :if ($"signal-strength" <= -85 && $"signal-strength" > -90) do={
  :beep frequency=1000;
  }  
 :if ($"signal-strength" <= -80 && $"signal-strength" > -85) do={
  :beep frequency=1700;
  }  
 :if ($"signal-strength" <= -75 && $"signal-strength" > -80) do={
  :beep frequency=2600;
  }
 :if ($"signal-strength" <= -65 && $"signal-strength" > -75) do={
  :beep frequency=3900;
  }  
 :if ($"signal-strength" <= -20 && $"signal-strength" > -65) do={
  :beep frequency=5000;
  }  
}
}[/code]

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...
  • Administrator

разновидност на горното някой е модефицирал и допълнил

постнато е на форума на МТ на Posted: Wed Apr 15, 2009 4:48 pm

BEEP SCRIPT

:local beep "10ms";
:local no "2400ms";
:local s90 "1290ms";
:local s85 "790ms";
:local s80 "590ms";
:local s77 "390ms";
:local s74 "290ms";
:local s71 "240ms";
:local s68 "190ms";
:local s65 "140ms";
:local s62 "90ms";
:local s59 "60ms";
:local s56 "40ms";
:local s53 "20ms";
:local s50 "10ms";
:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=1 do={
:if ($"signal-strength" <= -90) do={
:delay $no;
}
:if ($"signal-strength" <= -85 && $"signal-strength" > -90) do={
:for i from=1 to=2 do={ :beep length=$beep; :delay $s90; }
}
:if ($"signal-strength" <= -80 && $"signal-strength" > -85) do={
:for i from=1 to=3 do={ :beep length=$beep; :delay $s85; }
}
:if ($"signal-strength" <= -77 && $"signal-strength" > -80) do={
:for i from=1 to=4 do={ :beep length=$beep; :delay $s80; }
}
:if ($"signal-strength" <= -74 && $"signal-strength" > -77) do={
:for i from=1 to=6 do={ :beep length=$beep; :delay $s77; }
}
:if ($"signal-strength" <= -71 && $"signal-strength" > -74) do={
:for i from=1 to=8 do={ :beep length=$beep; :delay $s74; }
}
:if ($"signal-strength" <= -68 && $"signal-strength" > -71) do={
:for i from=1 to=10 do={ :beep length=$beep; :delay $s71; }
}
:if ($"signal-strength" <= -65 && $"signal-strength" > -68) do={
:for i from=1 to=12 do={ :beep length=$beep; :delay $s68; }
}
:if ($"signal-strength" <= -62 && $"signal-strength" > -65) do={
:for i from=1 to=16 do={ :beep length=$beep; :delay $s65; }
}
:if ($"signal-strength" <= -59 && $"signal-strength" > -62) do={
:for i from=1 to=24 do={ :beep length=$beep; :delay $s62; }
}
:if ($"signal-strength" <= -56 && $"signal-strength" > -59) do={
:for i from=1 to=34 do={ :beep length=$beep; :delay $s59; }
}
:if ($"signal-strength" <= -53 && $"signal-strength" > -56) do={
:for i from=1 to=48 do={ :beep length=$beep; :delay $s56; }
}
:if ($"signal-strength" <= -50 && $"signal-strength" > -53) do={
:for i from=1 to=80 do={ :beep length=$beep; :delay $s53; }
}
:if ($"signal-strength" <= -20 && $"signal-strength" > -50) do={
:for i from=1 to=120 do={ :beep length=$beep; :delay $s50; }
}
}
}
[/code] LED SCRIPT FOR ACCESS POINT
[code]:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=1 do={
:if ($"registered-clients"=1 ) do={
:for i from=1 to=24 do={:led led5=yes; :led led4=yes; :led led3=yes; :led led2=yes; :led led1=yes; }
}
:if ($"registered-clients"=0 ) do={
:for i from=1 to=24 do={:led led5=no; :led led4=no; :led led3=no; :led led2=no; :led led1=no; }
}
:if ($"signal-strength" <= -63 && $"signal-strength" > -75) do={
:for i from=1 to=48 do={ :led led5=no; :led led4=no; :led led3=yes; :led led2=yes; :led led1=yes; }
}
:if ($"signal-strength" <= -45 && $"signal-strength" > -62) do={
:for i from=1 to=120 do={ :led led5=no; :led led4=yes; :led led3=yes; :led led2=yes; :led led1=yes; }
}
:if ($"signal-strength" <= -10 && $"signal-strength" > -44) do={
:for i from=1 to=120 do={ :led led5=yes; :led led4=yes; :led led3=yes; :led led2=yes; :led led1=yes; }
}
}
}
LED SCRIPT FOR STATION
:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=1 do={
:if ($"signal-strength" <= -86 && $"signal-strength" > -90) do={
:for i from=1 to=24 do={:led led5=no; :led led4=no; :led led3=no; :led led2=no; :led led1=yes; }
}
:if ($"signal-strength" <= -76 && $"signal-strength" > -85) do={
:for i from=1 to=34 do={:led led5=no; :led led4=no; :led led3=no; :led led2=yes; :led led1=yes; }
}
:if ($"signal-strength" <= -63 && $"signal-strength" > -75) do={
:for i from=1 to=48 do={ :led led5=no; :led led4=no; :led led3=yes; :led led2=yes; :led led1=yes; }
}
:if ($"signal-strength" <= -45 && $"signal-strength" > -62) do={
:for i from=1 to=120 do={ :led led5=no; :led led4=yes; :led led3=yes; :led led2=yes; :led led1=yes; }
}
:if ($"signal-strength" <= -10 && $"signal-strength" > -44) do={
:for i from=1 to=120 do={ :led led5=yes; :led led4=yes; :led led3=yes; :led led2=yes; :led led1=yes; }
}
}
}[/code]

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.