Jump to content

локални записи на DHCP клиентите


111111
 Share

Recommended Posts

  • Administrator

правиме си скриптче и го кръщаваме примерно DHCP_DNS

а в съдържанието поместваме следното

:set topdomain "dhcp.my-domain.bg" ;
/ip dhcp-server lease ;
:foreach i in=[find] \
do={ \
/ip dhcp-server lease ;
:if ([:len [get $i host-name]] > 0) do={ \
:set hostname ([get $i host-name] . "." . $topdomain); \
:set hostip [get $i address]; \
:put ( $hostname . " : " . $hostip ) ; \
/ip dns static ;
:foreach di in [find] do = { :if ([get $di name] = $hostname) do {/ip dns static remove $di }}
/ip dns static add name=$hostname address=$hostip
} \
};[/code] [b]dhcp.my-domain.bg[/b] може да бъде заменено с нещо по ваш избор за да работи клиента трябва да получава IP по DHCP (странно защо) и трябва да се пуска периодично ;)
[code]/ system scheduler
add name="DHCP_DNS" on-event=DHCP_DNS start-date=jan/01/1970 start-time=00:00:00 interval=30m comment="" disabled=no

а крайната равносметка клиента има запис от рода

user.dhcp.my-domain.bg

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.