Jump to content
  • 0

Може ли малко помощ за Load Balance изпълнен на МТ2.9.27


kalinskiq

Question

Ползвам микротик 2.9.27 за да обединя интернет от два доставчика до тук всичко е наред load balance си работи нормално.Интернета който ползвам идва от два рутера които са съответно с гайтове 192,168,2,1 и 192,168,11,1 до тук всичко е нормално. При изваждане на кабела от ван1 на микротика интернета минава през другия доставчик ван2 и обратното.Проблема е следния ,как да направя така че при спиране на интернета примерно на някой от ван портовете на самите рутери от които взимам интернет микротика да спре да се обръща към съответния гейт ,защото в случая гейта който пингва микротика за да определи дали има или няма интернет все още отговаря на пинг и микротика продължава да насочва зачвки към него.Другото което немога да наглася е нетуач ползвах някой скриптове които открих по форумите но не се получава можеби не съм задал мейла от който да се изпраща на правилното място или по правилния начин.Дано съм успял да обясня точно какъв е проблема тъй като съм начинаещ в тая област.Конфига на микротика е следния:


/ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether1

 /ip address add address=192.168.2.199/24 network=192.168.2.0 broadcast=192.168.2.255 interface=ether2

/ip address add address=192.168.11.199/24 network=192.168.11.0 broadcast=192.168.11.255 interface=ether3

/ip route add dst-address=0.0.0.0/0 gateway=192.168.2.1,192.168.11.1 check-gateway=ping 

/ip firewall nat add chain=srcnat out-interface=ether2 action=masquerade

/ip firewall nat add chain=srcnat out-interface=ether3 action=masquerade

/ip firewall mangle add chain=input in-interface=ether2 action=mark-connection new-connection-mark=ether2_conn

/ip firewall mangle add chain=input in-interface=ether3 action=mark-connection new-connection-mark=ether3_conn

/ip firewall mangle add chain=output connection-mark=ether2_conn action=mark-routing new-routing-mark=to_ether2

/ip firewall mangle add chain=output connection-mark=ether3_conn action=mark-routing new-routing-mark=to_ether3

/ip route add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_ether2

/ip route add dst-address=0.0.0.0/0 gateway=192.168.11.1 routing-mark=to_ether3

Благодаря предварително

Edited by 111111
пригледност
Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Добре си се насочил. Със скрипт го правя аз. Скрипта е специфичен за всеки случай и отнема 1-2 дни да се направи, тества, доработи.

Опитах да добавям гейтове към тия които ползвам вече но не се получава или не ги следи или аз не правя нещо както трябва като второто е по вероято а за другия проблем с пускането на нетуача не видях меню каде да ваведа имеила също така и самия меил май не става какъв да е

Link to comment
Share on other sites

  • 0
  • Administrator

меил не може да пращаш, защото нямаш опцията

на тази стара версия изисква се от 3 нагоре

купи си един рутерборд 750, 70лв. е, че и по малко ;)

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

меил не може да пращаш, защото нямаш опцията

на тази стара версия изисква се от 3 нагоре

купи си един рутерборд 750, 70лв. е, че и по малко ;)

Ок за мейла ясно значи затова в тоолс няма емайл меню а за проблема с гейтовете имаш ли идея как да направя да следи има ли нет или не въпреки че гейта отговаря на пинг а за рутер борда си прав но просто имах една излишна стара щайга у нас и я впрегнах в работа просто за да се науча кое как става че после да си го пусна на РБ-а

Добре си се насочил. Със скрипт го правя аз. Скрипта е специфичен за всеки случай и отнема 1-2 дни да се направи, тества, доработи.

А дали ще може да ми дадеш този който ползваш а аз евентуално да се опитам да го преработя ,макар че съм начинаещ в областта

благодаря предварително

Link to comment
Share on other sites

  • 0
  • Administrator

но най добре ще е да преминеш н най-новата версия на микротик

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.