Jump to content
  • 0

Mikrotik Two gateways failover


Lacho
 Share

Question

Мислех да сложа темата в скриптове, но уви праснах я тук и мисля, че ще е доста полезна на всички.

Така да започна малко с история... Имам нет по wireless и един наземен бекъп който винаги когато нещо се прецака трябва ръчно да дропя единия и да вдигам другия докато реша проблемите ето, че попаднах на следната "врътка" нагласих я и чакам да се самоизтества ако скоро ми падне основния GW.

Предупреждавам Ви, че не е тествано още дали само ще сваля и ще вдига GW-ите .... ако имате повече или други идеи пишете.

Mikrotik Two gateways failover

This example explains how to use multiple gateways with one taking over when first fails. It begins with adding the gateways. Set bigger distance value for the secondary one, and check-gateway for the first one:

/ip route add gateway=192.168.1.1 check-gateway=ping

/ip route add gateway=192.168.2.1 distance=2

That’s all, there are no more steps!

The first gateway will begin as it’s [...]

Надявам се, че ще е полезно !

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0
  • Administrator

геит по интерфеис има

бодеш ги в 1 правило и си готов

/ip route
add check-gateway=ping disabled=no distance=20 dst-address=0.0.0.0/0 gateway=ISP1,ISP2
[/code]

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Работи, при мен го позлвам на едно място за  бекуп на 1 wireless с адсл

Link to comment
Share on other sites

  • 0

Здравейте на всички !!!

Поздрави към създателите на форума, страхотен е и много полезен.

Конкретния ми въпрос е. Имам два доставчика gateway ISP1=192.168.1.1  gateway ISP2=192.168.3.1 .Врътката която е дал Lacho работи без проблеми когато изчезне връзката до модема на ISP1 ,който прави NAT. Проблема е че при прекъсване на нета getewayISP1=192.168.1.1 не пада а продължава да си отговаря на пинг понеже модема прави NAT както споменах по горе а реално нямам нет но не прехвърля към втория доставчик. Как да реша този проблем ?

Благодаря предварително !!!

Link to comment
Share on other sites

  • 0

Модема в бридж режим е едно нещо което си заслужава да опиташ, така PPPoE връзката ще се осъществява от MikroTik рутера...

Да това е решение но все пак реших да попитам дали има друг вариянт.

Все пак благодаря за отговора !!!

Link to comment
Share on other sites

  • 0

и чакам да се самоизтества ако скоро ми падне основния GW.

Буташ гейта и ти е готов теста. Почти съм убеден, че ще работи.

Link to comment
Share on other sites

  • 0
  • Owner

Има решение :)

правиш статичен рутинг към някой хост през АДСЛ-а , после правиш скрипт, който да пингва нарочения хост.  Като се сбози АДСЛ-а , ще изчезне пинга към хоста и скрипта ще направи disable на гейта.

Да това е решение но все пак реших да попитам дали има друг вариянт.

Все пак благодаря за отговора !!!

Link to comment
Share on other sites

  • 0
  • Owner

Ами обикновено тоя хост е истинския гейт на АДСЛ-а , т.е. първия хоп, ако той не отговаря и нет няма да има :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.