Jump to content
  • 0

VPN между 2 офиса


Pavlov

Question

Здравейте!

Прегледах доста теми, но не открих това което ми трябва. Така става дума, че искам да направя връзка между два офиса. Разполагам с МТ RB 750 във всеки офис. Искам компютрите в 2та офиса да са в една мрежа и да могат да виждат споделените папки. Пробвах с PPTP, получава се тунел, но незнам как да ги вкарам в една обща мрежа. Прочетох доста неща и попаднах на това, че трябва да се направи bridge, но като започна да го правя нета се разпада. Искам да попитам какво точно да направя, за да могат всички компютри да са в една мрежа. В единия офис компютрите са в мрежа 192.168.0.0/24 а другия предстои да се изгражда всичко.

Благодаря ви предварително!

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

трябва да бриджнеш L2TP тунела заедно с интерфейса на вътрешната ти мрежа, така ако имаш в "централния офис" dhcp-server ще раздава адреси и на отдалечения офис

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

Да ама нещо не се получава. Сега ще напиша какво съм направил, а вие ще кажете къде е проблема.

[admin@MikroTik] /ppp secret> print detail

Flags: X - disabled

0  name="sofia" service=l2tp caller-id="" password="123456" profile=default

    local-address=192.168.10.1 remote-address=192.168.10.2

    routes="192.168.0.0/24 192.168.10.1 1" limit-bytes-in=0

    limit-bytes-out=0

[admin@MikroTik] /interface l2tp-server server> print

enabled: yes

max-mtu: 1460

max-mru: 1460

mrru: disabled

authentication: mschap2 default-profile: default-encryption

[admin@MikroTik_1] /interface l2tp-client> print

Flags: X - disabled, R - running

0  R name="l2tp-out1" max-mtu=1460 max-mru=1460 mrru=disabled

      connect-to=94.73.ххх.ххх user="sofia" password="123456"

      profile=default-encryption add-default-route=no dial-on-demand=no

      allow=pap,chap,mschap1,mschap2

[admin@MikroTik] /ip route> add dst-address=192.168.1.0/24 gateway=192.168.10.2

До тук всичко е ОК. Връзват се двата и има пинг от 192.168.10.1 към 192.168.10.2

Започнах да правя birdge за както ми казахте за да мога и да използвам и dhcp servera на Mikrotik

Да уточня Mikrotik (централен офис) а Mikrotik_1 (отдалечен офис)

Централен офис

/interface bridge add name=bridge_local protocol-mode=rstp

/interface bridge port add bridge=bridge_local interface=Local

/interface bridge set bridge_local admin-mac=xx:xx:xx:xx:xx:xx         

Ето го и резултата

[admin@MikroTik] /interface bridge> print

Flags: X - disabled, R - running

0  R name="bridge_local" mtu=1500 l2mtu=1524 arp=enabled

      mac-address=00:0C:42:59:E5:C9 protocol-mode=rstp priority=0x8000

      auto-mac=yes admin-mac=00:0C:42:59:E5:C9 max-message-age=20s

      forward-delay=15s transmit-hold-count=6 ageing-time=5m

/ip address add address=94.73.ххх.ххх interface=bridge_local

/ip address add address=1.1.1.1/24 interface=CTC-PPPoE (посочил съм Public PPPoE връзката на доставчика)

/ppp profile add name=ppp_bridging bridge=bridge_local use-encryption=yes

/ppp secret add profile=ppp_bridging name=ppp1 password=ppp1

резултат

[admin@MikroTik] /ppp secret> print detail

Flags: X - disabled

1  name="pp1" service=any caller-id="" password="pp1" profile=ppp_bridging

    routes="" limit-bytes-in=0 limit-bytes-out=0

/interface pptp-server server set enabled=yes mrru=1600

Отдалечен офис (MIkrotik_1)

/interface bridge add name=bridge_local protocol-mode=rstp

/interface bridge port add bridge=bridge_local interface=Local

/interface bridge set bridge_local admin-mac=xx:xx:xx:xx:xx:xx   

резултат

[admin@MikroTik_1] /interface bridge> print

Flags: X - disabled, R - running

0  R name="bridge_local" mtu=1500 l2mtu=1524 arp=enabled

      mac-address=00:0C:42:58:72:8A protocol-mode=rstp priority=0x8000

      auto-mac=yes admin-mac=00:0C:42:58:72:8A max-message-age=20s

      forward-delay=15s transmit-hold-count=6 ageing-time=5m

/ip address add address=178.169.ххх.ххх/24 interface=bridge_local

/ip address add address=2.2.2.2/24 interface=IG_public (посочил съм Public PPPoE връзката на доставчика)

/ppp profile add name=ppp_bridging bridge=bridge_local use-encryption=yes

/interface pptp-client add profile=ppp_bridging mrru=1600 connect-to=1.1.1.1 user=ppp1 password=ppp1 disabled=no

Това съм направил до тук. Незнам колко е правилно, четох и правих. Но засега компютрите зад Mikrotik_1 (отдалечен офис) не си взимат адрес от микротик в централния офис.

Благодаря предварително!

Link to comment
Share on other sites

  • 0
  • Administrator

външните WAN интерфейси не ги пипаш

бриджа е между ЛАН и виртуалните

когато ги закачиш проверяваш дали от двете страни се виждат рутерите

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.