Jump to content
  • 0

проблем с Hotspot


Mupo neTkoB
 Share

Question

системата 3.22. работи си всичко, но когато пусна хотспот във firewall а светват Invalid правила, след като някой се опита да се автентицира целия рутер забива и ни образ - ни картина. пробвах да махна хотспота и да го пусна наново но ефекта е същия

/ip firewall filter


 Flags: X - disabled, I - invalid, D - dynamic 

 0 D chain=forward action=jump jump-target=hs-unauth hotspot=from-client,!auth 


 1 D chain=forward action=jump jump-target=hs-unauth-to hotspot=to-client,!auth 


 2 D chain=input action=jump jump-target=hs-input hotspot=from-client 


 3 I chain=hs-input action=jump jump-target=pre-hs-input 


 4 D chain=hs-input action=accept protocol=udp dst-port=64872 


 5 D chain=hs-input action=accept protocol=tcp dst-port=64872-64875 


 6 D chain=hs-input action=jump jump-target=hs-unauth hotspot=!auth 


 7 D chain=hs-unauth action=reject reject-with=tcp-reset protocol=tcp 


 8 D chain=hs-unauth action=reject reject-with=icmp-net-prohibited 


 9 D chain=hs-unauth-to action=reject reject-with=icmp-host-prohibited 


ето другите в НАТ
 0 D chain=dstnat action=jump jump-target=hotspot hotspot=from-client 


 1 I chain=hotspot action=jump jump-target=pre-hotspot 


 2 D chain=hotspot action=redirect to-ports=64872 protocol=udp dst-port=53 


 3 D chain=hotspot action=redirect to-ports=64872 protocol=tcp dst-port=53 


 4 D chain=hotspot action=redirect to-ports=64873 protocol=tcp hotspot=local-dst dst-port=80 


 5 D chain=hotspot action=redirect to-ports=64875 protocol=tcp hotspot=local-dst dst-port=443 


 6 D chain=hotspot action=jump jump-target=hs-unauth protocol=tcp hotspot=!auth 


 7 D chain=hotspot action=jump jump-target=hs-auth protocol=tcp hotspot=auth 


 8 D chain=hs-unauth action=redirect to-ports=64874 protocol=tcp dst-port=80 


 9 D chain=hs-unauth action=redirect to-ports=64874 protocol=tcp dst-port=3128 


10 D chain=hs-unauth action=redirect to-ports=64874 protocol=tcp dst-port=8080 


11 D chain=hs-unauth action=redirect to-ports=64875 protocol=tcp dst-port=443 


12 I chain=hs-unauth action=jump jump-target=hs-smtp protocol=tcp dst-port=25 


13 D chain=hs-auth action=redirect to-ports=64874 protocol=tcp hotspot=http 


14 I chain=hs-auth action=jump jump-target=hs-smtp protocol=tcp dst-port=25 

както виждате има доста I :(

забравих да спомена, хотспота вади логин страницата и до тогава работи нормално, но след пробване с име и парола или trial тогава се сбозяват нещата

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0

айде де, никой ли няма предложение  :o

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0
  • Administrator

Как си почнал да го конфигваш?

Първо алабалщините и после хотспота или ???

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

принципно да, пуснах си другите глупости, IPSEC тунел дхцп :) днс и т.н. и след това hotspot, това беше на 2.9.27, всичко работеше нямаше никакви грижи с хотспота, след което ъпгрейднах рутера, нова версия 3.22. почти всичко се прехвърли, мисля че не работи webproxy и хотспота, изтрих го, изтрих и сървър профила, и пробвах да конфигурирам на ново. пробвах без да ползвам SETUP Hotspot, пробвах после и със СЕТЪП, но ефекта е същия, светят в червено правилата във firewall

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0
  • Administrator

DHCP си пали хотспота сам

както писах на едно др. място

всичко ползващо STORAGE е променено

и несъвместимо с ЕХРОRT от 2,9,хх

провери си интерфейсите на които е хотспота

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

DHCP се качва наистина само ако направя SETUP HOTSPOT обаче резултат никакъв,

хотспота ми е на интерфейс Vlan1 който си е влан, той работи защото ако не е пуснат dhcp самите АП-та си взимат адрес, както и клиентите закачени за АП-тата, но само при опит за логване в хотспота ми забива целия рутер

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0
  • Administrator

е как ще пускаш хотспота на vlan

пуска се на интерфеис на които се закача клиента

разясни схемо-топологията на идеята ти

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

имам вътрешна мрежа и исках да отделя безжичната от вътрешната. на безжичната искам да пусна безплатен интернет за клиенти на обекта / trial / които да нямат достъп до вътрешната. за целта съм пуснал един Vlan който е на вътрешния интерфейс. т.е. посрещам АП-тата /2броя /. на този vlan1 интерфейс съм пуснал хотспот който да автентицира клиентите, ако те са се автентицирали ги пускам към вътрешната мрежа /като за някои user profile раздава след автентикация други ИП адреси/

сега ще пусна тук малко от старата конфигурация на х.27 която работеше

/ interface vlan 

add name="vlan1" mtu=1500 arp=enabled vlan-id=1 interface=Local comment="" \

    disabled=no 

/ interface ethernet 

set Public name="Public" mtu=1500 mac-address=00:0B:6A:1D:F5:4F arp=enabled \

    disable-running-check=yes auto-negotiation=yes full-duplex=yes \

    cable-settings=default speed=100Mbps comment="" disabled=no 

set Local name="Local" mtu=1500 mac-address=00:C0:26:86:D7:FA arp=enabled \

    disable-running-check=yes auto-negotiation=yes full-duplex=yes \

    cable-settings=default speed=100Mbps comment="" disabled=no 

/ ip pool 

add name="Wi-Fi_pool2" ranges=192.168.20.2-192.168.20.254 

add name="dhcp_pool1" ranges=172.16.201.2-172.16.201.254 

add name="Wi-fi-dhcp3" ranges=192.168.30.2-192.168.30.254 

/ ip dns 

set primary-dns=83.228.56.162 secondary-dns=194.141.79.1 \

    allow-remote-requests=yes cache-size=10240KiB cache-max-ttl=1w 

/ ip address 

add address=192.168.15.170/24 network=192.168.15.0 broadcast=192.168.15.255 \

    interface=Public comment="" disabled=yes 

add address=192.168.20.1/24 network=192.168.20.0 broadcast=192.168.20.255 \

    interface=vlan1 comment="" disabled=no 

add address=172.16.201.1/24 network=172.16.201.0 broadcast=172.16.201.255 \

    interface=Local comment="" disabled=no 

add address=192.168.10.1/24 network=192.168.10.0 broadcast=192.168.10.255 \

    interface=Local comment="" disabled=no 

add address=83.228.92.X/28 network=83.228.92.X broadcast=83.228.92.X \

    interface=Public comment="" disabled=no 

add address=192.168.30.1/24 network=192.168.30.0 broadcast=192.168.30.255 \

    interface=vlan1 comment="" disabled=no 

Firewall

/ ip firewall nat 

add chain=srcnat src-address=192.168.20.0/24 action=masquerade \

    comment="Masquerade HOTSPOT" disabled=no 

add chain=srcnat src-address=192.168.30.0/24 action=masquerade \

    comment="Masquerade HOTSPOT Our Users" disabled=no 

add chain=dstnat in-interface=vlan1 protocol=tcp dst-port=80 action=redirect \

    to-ports=3128 comment="Proxy fo WiFi" disabled=no 

add chain=forward in-interface=vlan1 src-address=192.168.30.0/24 \

    dst-address=172.16.201.0/24 action=accept comment="Accept HS Authenticated \

    Clients to Local NET" disabled=no 

add chain=forward in-interface=vlan1 out-interface=!Public action=drop \

    comment="Drop Vlan1 to Local " disabled=no 

и тук Хотспот настройките
/ ip hotspot 

add name="HS-Server" interface=vlan1 address-pool=Wi-Fi_pool2 profile=HOTSPOT \

    idle-timeout=5m keepalive-timeout=none addresses-per-mac=1 disabled=no 

/ ip hotspot service-port 

set ftp ports=21 disabled=no 

/ ip hotspot profile 

add name="HOTSPOT" hotspot-address=192.168.20.1 dns-name="" \

    html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0 \

    smtp-server=0.0.0.0 login-by=http-chap,trial split-user-domain=no \

    trial-uptime=1h/10m trial-user-profile=Guest_user use-radius=no 

/ ip hotspot user 

add name="admin" password="admin" profile=Masterwerk-Users comment="" \

    disabled=yes 

add name="Mupo" password="nqkakva parola" profile=[b]Masterwerk_Admin[/b] comment="" \

    disabled=no 

add name="n.goranov" password="nqkakva parola" profile=[b]Masterwerk-Users[/b] comment="" \

    disabled=no 

/ ip hotspot user profile 

add name="Guest_user" address-pool=[b]Wi-Fi_pool2[/b] idle-timeout=none \

    keepalive-timeout=2m status-autorefresh=1m shared-users=1 \

    rate-limit="512000/1024000" transparent-proxy=no 

add name="Masterwerk-Users" address-pool=[b]Wi-fi-dhcp3[/b] idle-timeout=none \

    keepalive-timeout=20m status-autorefresh=1m shared-users=1 \

    rate-limit="2048000/6144000" transparent-proxy=no 

add name="Masterwerk_Admin" address-pool=[b]Wi-fi-dhcp3[/b] idle-timeout=none \

    keepalive-timeout=20m status-autorefresh=1m shared-users=1 \

    transparent-proxy=no 

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

ето сега част от сегашната  конфигурация на 3.22


/ip pool

add name=Wi-Fi_pool2 ranges=192.168.20.2-192.168.20.254

add name=dhcp_pool1 ranges=172.16.201.2-172.16.201.254

add name=Wi-fi-dhcp3 ranges=192.168.30.2-192.168.30.254

/ip dhcp-server

add address-pool=dhcp_pool1 authoritative=after-2sec-delay bootp-support=\

    static disabled=no interface=Local lease-time=3d name=dhcp1

add address-pool=Wi-Fi_pool2 authoritative=after-2sec-delay bootp-support=\

    static disabled=no interface=vlan1 lease-time=1h name=dhcp2

/ip hotspot user profile

set default address-pool=Wi-Fi_pool2 advertise=no idle-timeout=none \

    keepalive-timeout=2m name=default open-status-page=http-login \

    session-timeout=20m shared-users=1 status-autorefresh=1m \

    transparent-proxy=yes

add address-pool=Wi-Fi_pool2 idle-timeout=none keepalive-timeout=2m name=\

    Guest_user rate-limit=512000/1024000 shared-users=1 status-autorefresh=1m \

    transparent-proxy=no

add address-pool=Wi-fi-dhcp3 idle-timeout=none keepalive-timeout=20m name=\

    Masterwerk-Users rate-limit=2048000/6144000 shared-users=1 \

    status-autorefresh=1m transparent-proxy=no

add address-pool=Wi-fi-dhcp3 idle-timeout=none keepalive-timeout=20m name=\

    Masterwerk_Admin shared-users=1 status-autorefresh=1m transparent-proxy=\

    no

/ip hotspot profile

add dns-name=ssm.bg hotspot-address=192.168.20.1 html-directory=hotspot \

    http-proxy=0.0.0.0:0 login-by=http-chap,trial name=HOTSPOT rate-limit="" \

    smtp-server=0.0.0.0 split-user-domain=no trial-uptime=1h/10m \

    trial-user-profile=Guest_user use-radius=no

/ip hotspot

add address-pool=Wi-Fi_pool2 addresses-per-mac=1 disabled=no idle-timeout=5m \

    interface=vlan1 keepalive-timeout=none name=Hotspot profile=HOTSPOT

не знам аз поне не забелязвам някаква разлика но в първия пост съм показал какво излиза в firewall filter и firewall NAT

[Mupo@SSM Masterwerk] > ip firewall filter print dynamic

Flags: X - disabled, I - invalid, D - dynamic

0 D chain=forward action=jump jump-target=hs-unauth hotspot=from-client,!auth

1 D chain=forward action=jump jump-target=hs-unauth-to hotspot=to-client,!auth

2 D chain=input action=jump jump-target=hs-input hotspot=from-client

3 I chain=hs-input action=jump jump-target=pre-hs-input

4 D chain=hs-input action=accept protocol=udp dst-port=64872

5 D chain=hs-input action=accept protocol=tcp dst-port=64872-64875

6 D chain=hs-input action=jump jump-target=hs-unauth hotspot=!auth

7 D chain=hs-unauth action=reject reject-with=tcp-reset protocol=tcp

8 D chain=hs-unauth action=reject reject-with=icmp-net-prohibited

9 D chain=hs-unauth-to action=reject reject-with=icmp-host-prohibited

Firewall NAT :

[Mupo@SSM Masterwerk] > ip firewall nat print dynamic

Flags: X - disabled, I - invalid, D - dynamic

0 D chain=dstnat action=jump jump-target=hotspot hotspot=from-client

1 I chain=hotspot action=jump jump-target=pre-hotspot

2 D chain=hotspot action=redirect to-ports=64872 protocol=udp dst-port=53

3 D chain=hotspot action=redirect to-ports=64872 protocol=tcp dst-port=53

4 D chain=hotspot action=redirect to-ports=64873 protocol=tcp hotspot=local-dst dst-port=80

5 D chain=hotspot action=redirect to-ports=64875 protocol=tcp hotspot=local-dst dst-port=443

6 D chain=hotspot action=jump jump-target=hs-unauth protocol=tcp hotspot=!auth

7 D chain=hotspot action=jump jump-target=hs-auth protocol=tcp hotspot=auth

8 D chain=hs-unauth action=redirect to-ports=64874 protocol=tcp dst-port=80

9 D chain=hs-unauth action=redirect to-ports=64874 protocol=tcp dst-port=3128

10 D chain=hs-unauth action=redirect to-ports=64874 protocol=tcp dst-port=8080

11 D chain=hs-unauth action=redirect to-ports=64875 protocol=tcp dst-port=443

12 I chain=hs-unauth action=jump jump-target=hs-smtp protocol=tcp dst-port=25

13 D chain=hs-auth action=redirect to-ports=64874 protocol=tcp hotspot=http

14 I chain=hs-auth action=jump jump-target=hs-smtp protocol=tcp dst-port=25

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0
  • Administrator

Преди време се опитвах да пусна хотспот на бридж в които има вифи карта и еоип който идваше от друго борд по мрежата, но понякога по неизвестни причини въпреки че компа който се логва си взима ип адрес не му се зарежда началната страница на хотспота. Така и не установих причината :) ..

Не отговарям на постове написани с шльокавица!

Link to comment
Share on other sites

  • 0

при мен началната се зарежда, няма никакви проблеми, взима си ИП-адрес също, но при опит за логване / било то с парола ,или триал /   рутера направо забива. целия комп спира. няма влизане, нито отдалечено - нито локално

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

проблема се оправи, след много пробвания и изтривания и конфигурирания на Hotspot на микротик се отказах.

от версия 3.17 нагоре всеки който се опита да се логне в хотспота крашва машината като при моя случай,

http://forum.mikrotik.com/viewtopic.php?f=2&t=29798&p=148541

за това че светят някой правила в червено като инвалид не е проблем.

наложи се даунгрейдване на версията до 3.13 и за момента работи всичко нормално, не съм забелязвал други проблеми. ако излезе нещо ще пиша за сега толкова

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

въпреки намаляне на версията проблема с IPSec остана, може ли някво предложение

3352f59fe746ae29.JPG

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.