Jump to content
  • 0

Динамична промяна на шейпъра в микротик...как ?


insertoff

Question

insertoff

Hi,

имате ли идея как може динамично да се промени скоростта на закачен (PPP, PPPOE) клиент.

Идеята е да получи различни скорости в различни интервали време.

Ясно е, че Микротик го може - по часове , дни и т.н.

Въпроса е обаче дали може това да се направи в/у динамичен шепър...Който е създаден при закачането на PPP-to, при това без да се реконектва.

Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
Тодор Лазаров

Hi,

имате ли идея как може динамично да се промени скоростта на закачен (PPP, PPPOE) клиент.

Идеята е да получи различни скорости в различни интервали време.

Ясно е, че Микротик го може - по часове , дни и т.н.

Въпроса е обаче дали може това да се направи в/у динамичен шепър...Който е създаден при закачането на PPP-to, при това без да се реконектва.

Това май не го може.

т.е. ppp-to няма такъв атрибут.

Ако някой го е решил нека пише.

Но без разкачане май няма да стане.

п.с. Всеки чака дългоочакваната ROS 4.0 да видим там какво ще има ... може и да има изненади  ;D

Link to post
Share on other sites
  • 0
Тодор Лазаров

т.е. Май може ...

От някой Linux пускаш следния script:

mt-shaper.pl

-----------------------------------------------------------------------------

[highlight]#!/usr/bin/perl

my $host = $ARGV[0];

my $username = $ARGV[1];

my $rate = $ARGV[2];

my $found=0;

use Data::Dumper;

use Net::Telnet ();

$t = new Net::Telnet (

Host => "$host",

Timeout => 10,

Dump_log => "./xyz",

Prompt => '/\[.+\] > $/');

$t->login("mikrotik-RW-user", "mikroti-password");

$t->cmd("/queue simple set \"<pppoe-$username>\" limit-at=$rate max-limit=$rate");[/highlight]

-------------------------------------------------------------------------------

Параметрите мисля че са ясни:

$host - адреса на микротика

$username - името на потребителя /ако е pptp то поправи ppoe на pptp/

$rate - скороста /формат up/down/

т.е. в crontab-a си пускаш script-a в колкото си искаш часа.

например:

mt-shaper.pl 192.168.0.1 alabala 512k/512k

Ако някой доразвие script-a още по-добре.

Link to post
Share on other sites
  • 0
insertoff

eeeeeee brawo  бе човек...

По всичко изглежда, че това ще работи..

Като идвам  на ски ше ти обадя да те черпя :)

Остава да се помисли как да се познае кой усер от базата на радиуса,  в кой микротик е логнат...Но това май не е много сложно.Поне аз имам идея как да го направя при мен.

ps.. като че ли уведомяването на маил не работи отново ?

Link to post
Share on other sites
  • 0
Тодор Лазаров

Това е само идеята.

Другото направи си една база в която опиши потребителите.

И в определено време е препрочиташ и теглиш от нея параметрите.

Успех.

От микротик доста разчитат на ползването на тъй-нареченото API for 3.0

http://wiki.mikrotik.com/wiki/API

Език с който ще си комуникират външни програми с Микротик.

Така много от нещата ще се правят отвън. Идеята не е лоша.

Link to post
Share on other sites
  • 0
  • Administrator

говориме за динамичен киент и за скорости които не се сетват в

/queue simple
ами в
 /ppp profile 
add name="1" local-address=pppoe remote-address=pppoe use-compression=yes use-vj-compression=yes \
   use-encryption=no only-one=yes change-tcp-mss=yes rate-limit="1M/17M 2M/30M 512k/10M 10/10 4 256k/5M" \
   dns-server=172.16.80.1 comment=""[/code]

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites
  • 0
Тодор Лазаров

говориме за динамичен киент и за скорости които не се сетват в

/queue simple
ами в
 /ppp profile 

add name="1" local-address=pppoe remote-address=pppoe use-compression=yes use-vj-compression=yes \

    use-encryption=no only-one=yes change-tcp-mss=yes rate-limit="1M/17M 2M/30M 512k/10M 10/10 4 256k/5M" \

    dns-server=172.16.80.1 comment=""

Я разшивровай този ред:

rate-limit="1M/17M 2M/30M 512k/10M 10/10 4 256k/5M

ето и документацията:

rate-limit (text; default: "") - rate limitation in form of rx-rate[/tx-rate] [rx-burst-rate[/tx-burst-rate] [rx-burst-threshold[/tx-burst-threshold] [rx-burst-time[/tx-burst-time] [priority] [rx-rate-min[/tx-rate-min]]]] from the point of view of the router (so "rx" is client upload, and "tx" is client download). All rates are measured in bits per second, unless followed by optional 'k' suffix (kilobits per second) or 'M' suffix (megabits per second). If tx-rate is not specified, rx-rate serves as tx-rate too. The same applies for tx-burst-rate, tx-burst-threshold and tx-burst-time. If both rx-burst-threshold and tx-burst-threshold are not specified (but burst-rate is specified), rx-rate and tx-rate are used as burst thresholds. If both rx-burst-time and tx-burst-time are not specified, 1s is used as default. Priority takes values 1..8, where 1 implies the highest priority, but 8 - the lowest. If rx-rate-min and tx-rate-min are not specified rx-rate and tx-rate values are used. The rx-rate-min and tx-rate-min values can not exceed rx-rate and tx-rate values.

Link to post
Share on other sites
  • 0
  • Administrator

какво да разшифровам ползвам burst

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites
  • 0

Има ли начин примерно когато има по малко юзери да им се повишава скороста и когато има повече да им се намалява или примерно когато някой дърпа а другите сърфират да го разпределя по някакъв начин ?

Link to post
Share on other sites
  • 0
  • Administrator

за тая цел се прави QOS но не работи с РРРоЕ

ами със статични или динамични адреси

за за да направиш това под РРР трябва да дропнеш конекцията

или да ползваш няколко машини което не винаги е удобно

тук идеино ми идва да им дам на всички РРРоЕ клиенти статичен интерфеис от рода

/ interface pppoe-server 
add name=xyz user=abc service=123 disabled=no[/code]

кадето

name име на феиса

user потребитеско име

service име на услугата (може и празно ако няма име)

много странно изчезват като се напишат в терминала  :o

/ interface pppoe-server pr излиза

/ interface pppoe-server ex неизлиза  :-/

в winbox се виждат в интерфеиси и в ррр

после може и да стана с

/queue simple

лимити на интерфеис

после малко преправки на ТОВА или ТОВА

може да се помисли и над ТОВА

последното е малко некадърно и липсва едно правило

което трябва да се добави в /queue simple и да е parent на под правилата  ;)

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.