Jump to content

µTorrent µTP


kokaracha

Recommended Posts

  • Administrator

За тези който страдат от торенти, увеличени пакети и изходящ трафик, и искат да намалят товара на свойте рутери.

Филтрация utp на шлюз под линукс

/sbin/iptables -I FORWARD -m udp -p udp -m string --hex-string "|7F FF FF FF AB|" --algo kmp \

      --from 40 --to 44 -m statistic --mode random --probability 0.90 -j DROP

Мониторинг на правилото
iptables -L FORWARD -nv | grep statist

Монииторинг в реално време
tcpdump -i ethX -n ip[40:4]=0x7FFFFFFF -X
Правило  за Микротик

/ip firewall layer7-protocol

add comment="" name="\B5TP" regexp="\\x7F\\xFF\\xFF\\xFF\\xAB"

/ip firewall mangle

add action=mark-connection chain=forward comment="" connection-state=new disabled=no \

    layer7-protocol="\B5TP" new-connection-mark="\B5TP" passthrough=yes protocol=udp

add action=mark-packet chain=forward comment="" connection-mark="\B5TP" disabled=no \

    new-packet-mark="\B5TP" passthrough=yes

/ip firewall filter

add action=drop chain=forward comment=\

    "uTP uTorrent " disabled=no layer7-protocol=\

    "\B5TP" packet-mark="\B5TP"

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • Replies 67
  • Created
  • Last Reply

Top Posters In This Topic

  • kokaracha

    18

  • Mile

    12

  • byte

    9

  • NetworkPro

    8

Top Posters In This Topic

Posted Images

Това ми попада в един руски форум...но дали наистина е толкова страшен тоя протокол, че да се вземат чак такива мерки? И не ограничаваме ли по този начин потребителите?

Link to comment
Share on other sites

Този протокол позволява на uTorrent и BitTorrent последните клиенти да се самоограничават. Благодарение на него в моите мрежи се наблюдава подобрение и снижаване на оплакванията на потребителите.

Ако дропиш uTP - torrent клиентите имат fallback към TCP/IP който товари повече.

Допълнителна информация: http://www.telecom-lab.net/bbs/index.php?/topic/9-what-is-µtorrents-µtp-aka-utp

µTP is an open protocol in the process of being standardized – learn more about standardization of µTP on bittorrent.org and at the Internet Engineering Task Force (IETF)
Link to comment
Share on other sites

  • Administrator

Този протокол позволява на uTorrent и BitTorrent последните клиенти да се самоограничават. Благодарение на него в моите мрежи се наблюдава подобрение и снижаване на оплакванията на потребителите.

Ако дропиш uTP - torrent клиентите имат fallback към TCP/IP който товари повече.

Допълнителна информация: http://www.telecom-lab.net/bbs/index.php?/topic/9-what-is-µtorrents-µtp-aka-utp

Освен да пълни канала на клиента и да му отваря 2К сесии по utp  друго файда не виждам. Аиде сега заради това приемущество да си ъпгрейдваме рутерите и капацитетите на трасетата.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

Броя сесии се конфигурира в клиента. Запълването на канала не трябва да е проблем ако имаш например такова

QoS Best Practice @ MUM Czech Republic 2009, pdf by Janis Megis, MikroTik, Latvia

Link to comment
Share on other sites

  • Administrator

Броя сесии се конфигурира в клиента. Запълването на канала не трябва да е проблем ако имаш например такова

Best Practice @ MUM Czech Republic 2009, pdf by Janis Megis, MikroTik, Latvia

Не може да се разчита и задължи клиента да си ограничи конекцийте и трафика сам. С новото "приемущество" се генерира голям брои utp/pps,както и изходящ трафик ipv4/ipv6 с което се товарят рутери трасета. При положение че скоростите на интернет  тарифите вече започват от 15мп/с а всяка следваща е х2 това на 5-10 м/сек пингове това почва да създава главоболия,още повече пък и когато правилата са за град/пиъринг/интернет.

  QoS не виждам с какво би помогнало,особено пък и когато става въпрос  за домашни потребители.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

Където имам поглед като се вдигне CPU потребление на рутер - се слага по-мощен (x86 + MT).

Ако искаш да ти помогна да подкараме някъде един такъв QoS като в PDF-а на Janis и да пробваш. Може да пробваме и на BSD ако трябва (визирам първо пълен проект, одобрение, и след това имплементиране), ще дадеш акъл packet flow-а как е там... и така.

Link to comment
Share on other sites

  • Administrator

Където имам поглед като се вдигне CPU потребление на рутер - се слага по-мощен (x86 + MT).

Ако искаш да ти помогна да подкараме някъде един такъв QoS като в PDF-а на Janis и да пробваш. Може да пробваме и на BSD ако трябва (визирам първо пълен проект, одобрение, и след това имплементиране), ще дадеш акъл packet flow-а как е там... и така.

Абе момче, нали разбираш че тука става въпрос за 1u маркови кошници с по 2/4 ядра и 2гб/рам ,скорости/пакети от порядъка на ~1gb/5xxK pps на интерфейс като това са физическите възможностите на самите кошове. Това са линукс/бсд машини,мт не се справя с това така добре. Темата и правилата бяха насочени към имащите проблем-а с достигане до нуждата от подмяна на рутери с което това се отлага във времето,а не за получаване на съвети от хора несбъсквали се с проблема.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • Administrator

Виж сега как се заяждаш. Тва егото голяма спънка на цивилизацията.

Заяждам ? Разбирам че искаш да помогнеш но лично мен това не ми е нужно.

Темата не беше за търсене на помощ или решение,а за предлагане на такива в случая с проблема.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

Направих замерване колко лош е този протокол.

В момента на един пппое концентратор .. 450 свързани потребители, около 500мбит трафик (90к ппс) .. средно 300 такива пакета в секунда, на друг сървър същото замерване: 600 вързани, 600мбит/с (100к ппс), 500 утп пакета

утре трябва да видя колко ще са в 20-21ч. .. но ми се струва че хич не е далавера да се филтрува това, като се има предвид колко процесорно време се използва за string модула.

Link to comment
Share on other sites

  • Administrator

Направих замерване колко лош е този протокол.

В момента на един пппое концентратор .. 450 свързани потребители, около 500мбит трафик (90к ппс) .. средно 300 такива пакета в секунда, на друг сървър същото замерване: 600 вързани, 600мбит/с (100к ппс), 500 утп пакета

утре трябва да видя колко ще са в 20-21ч. .. но ми се струва че хич не е далавера да се филтрува това, като се има предвид колко процесорно време се използва за string модула.

Ами гледай си графиките,средното натоварването и пиковете.При мен лоадна малко памет,но пак товара на процесорите падна почти 15-20%. Мисля че ще спечелиш само запас на ппп-та докам ~9xx.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

След блока на uTP клиента минава на добрия стар tcp. Ние не го блокираме щото така и така ъпгрейдваме... душа има всичко да извлекат още 2х клиенти хем не съм любител на покупките за "във времето". Иначе лоада се видя от към месец.. месец и нещо.

Link to comment
Share on other sites

Гледам графики .. гледам .. то по цял ден това правя, ама ефект от това при мен няма грам.

процесорното натоварване на пппое концентраторите не се промени, нито пък натоварването на бордер-а

Link to comment
Share on other sites

  • Administrator

Гледам графики .. гледам .. то по цял ден това правя, ама ефект от това при мен няма грам.

процесорното натоварване на пппое концентраторите не се промени, нито пък натоварването на бордер-а

То общо взето само това правим,гледаме графики  :) . А в графиките ти  от декември  до сега има ли промяна ?

Друго ,къде са ти правилата сетнати на  бордер-а ,акцесите или  направо на суича ?

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.