Jump to content
  • 0

Port forward


tension
 Share

Question

Здравейте ползавам от няколко месеца Микротик но до сега не ми се беше налагало да използвам Port forward. След четена и разхождане из форумите продалжавам да имам проблем с презкачането на Микротик рутера. Проблемът е следният искам отвън да се конектна за вътрешна машина през SSH но при всеки опит единствено се конектва към рутера не към изканото IP от вътрешната мрежа. Нстроиките които ползвам са (/ip firewall nat add chain=dstnat dst-address=x.x.x.x protocol=tcp dst-port=22 \

action=dst-nat to-addresses=x.x.x.x to-ports=22 )А настроиките до сега са тези благодаря предварително на всички които биха отговорили по темата.

Link to comment
Share on other sites

Recommended Posts

  • 0

Промени dst-port= на нещо друго и използвай новия порт когато се опитваш да се логнеш.

Link to comment
Share on other sites

  • 0

Така опитах го и този вариант (ip firewall nat add chain=dstnat dst-address=aaa.aaa.aaa.aaa protocol=tcp dst-port=bbbb \

  action=dst-nat to-addresses=xxx.xxx.xxx.xxx to-ports=yyyy) но ефекта е същият.

Link to comment
Share on other sites

  • 0

Да спрях го опитах всички неща които съм посочил до сега и продължава ефекта да е същият.

Link to comment
Share on other sites

  • 0

Би ли описал интерфейсите /етер1 и т.н./, кой на къде е

и вътрешната машина има ли дифаут гейт ?

конекшън тракинга на микротика пуснат ли е ?

Link to comment
Share on other sites

  • 0
  • Administrator

/ ip firewall nat

add chain=dstnat dst-address=x.x.237.86 protocol=tcp dst-port=9000 action=dst-nat to-addresses=192.168.7.4 to-ports=22 comment="ssh" disabled=no

Това работи идеално и за други услуги става

и SSH  на МТ нетрябва да се спира ;)

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

111111 много ти благодаря че разобличи моята грешка. Все забравям че всеки service трябва да го разделям с коментар за да не влиза в предния. Много ви благодаря на всички за отзивчивостта. Поздрави !!!

Link to comment
Share on other sites

  • 0

Аз ли бъркам нещо или за www(80) не работи?

add chain=dstnat dst-address=xx.xxx.45.99 protocol=tcp dst-port=6812 action=dst-nat to-addresses=192.168.

1.2 to-ports=80 comment="http" disabled=no

ако може някой да ми предложи решение да се достъпи веб сървър зад маскарад

Link to comment
Share on other sites

  • 0
  • Administrator

правилата са подредени по ерархия от 0-ххххх (отгоре надолу)

щракни на първата колона трябва да се появят сиви Х пред всички

за да ги разместваш с мишката

виж да нямаш правило което блокира преди цитираното от теб

за тест сложи правилото най отпред(отгоре)

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Например това при мен работи (RouterOS v3.25)

/ip firewall nat

add action=dst-nat chain=dstnat comment="1.10 torrent" dst-port=45578 in-interface=ether1 protocol=tcp to-addresses=192.168.1.10

забележете че в този случай няма посочен src-addr а пък dst-addr изобщо не е практика да се посочва, при условие че има посочен in-interface ...

както и че to-ports се посочва, когато порта е различен, например порт 80 на вътрешна машина можем да достъп от порт 32180 на външен адрес ...

torrent - само като пример, иначе за torrent е добре да се активира UPnP .

Link to comment
Share on other sites

  • 0
  • Administrator

Торентите се пускат на upnp а дестинешън портове трябват

когато "редиректваш"

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Продължавам темата защото проблема е сходен:

Интернет-->Микротк-->С-->АП192.168.1.2:80 -->PC192.168.4.254

                                   у-->АП192.168.1.3:80 -->PC192.168.4.253

                                   и-->АП192.168.1.4:80 -->PC192.168.4.252

                                   ч-->АП192.168.1.5:80 -->PC192.168.4.251

на микротика има

Public:eth5 10.10.10.152/24

Private:eth4 192.168.1.1/24

                  192.168.4.2/24

статичен път за 0.0.0.0/0 шлюз 10.10.10.1 през eth5

+ динамичните пътища

srcnat

src address=192.168.4.0/24

Out.Interface=ether5 (interface connected WAN)

action masqerade

Трябва ми достъп до ввв-то на ап-тата.

С посочените по-горе примери неможах да го докарам.  :-/

благодаря на всички проявили интерес  :)

Link to comment
Share on other sites

  • 0
  • Administrator

искаш от интернет да отваряш 192.168.1.х

отвън ип на микротика :82 /:83/ :84/ :85

към съответните АP

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

да от интернет

Представям си го нещо като порт редирект

10.10.10.152:6812-->192.168.1.2:80

10.10.10.152:6813-->192.168.1.3:80

10.10.10.152:6814-->192.168.1.4:80

10.10.10.152:6815-->192.168.1.5:80

ама не ми се получава :-[

Link to comment
Share on other sites

  • 0
  • Administrator

правилно си го схванал

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.