Jump to content

Mikrotik to Cisco Gre tunnel


Mupo neTkoB
 Share

Recommended Posts

искам да направя тунел с cisco от другата страна и да е gre

дали има съвместимост и някакви насоки. пробвах с IPIP тунел, сложих му после ип-адрес, но от другата страна на cisco-то дава че тунела е down и няма нищо. при мен се вижда само една конекция от тяхното IP към 47 protocol  - GRE, но ми го дава unreplied

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

Така, кой може да помогне, че толкова съм зациклил че вече не знам какви глупости правя

направих въпросния тунел с колегите.

имам следния проблем сега. моя рутер има 2 доставчика АДСЛ и Интербилд, АДСЛ-а е в бридж режим, до сега работеше на рутера PCC лоад балансинг на NetworkPro има го в wiki.mikrotik.com та. до тук добре, обаче сега като се опитвам да направя тунела явно нещо се омазва там защото Connection_Mark  ми я дава примерно че минава през Public2 а този интерфейс е на другия доставчик не на този който сме посочили в IPIP тунела. след като спра правилата в Mangle минава кратко време да се опомни и тунела тръгва, - ping, tracert и т.н. След като пусна правилата пак в Мангле се омазват нещата отново. другото което забелязах до момента е че в ip route правилата които са с приоритет за 0.0.0.0/0 и гейт на единия и другия доставчик светят в синьо все едно не са активни, това се получи когато бриджнах модема и вместо гейтуей там /192.168.1.1/ сложих интерфейс на гейта което се пада PPPoE конекцията към БеТеКарите.

другия проблем който имам е също с рутирането. От мрежата която ми се пада вътрешна не мога да пингвам оттатък тунела компютрите. какво ли не пробвах ама яко съм зациклил така че сега малко текуща конфигурация

 

Flags: X - disabled, I - invalid, D - dynamic 

 #   ADDRESS            NETWORK         BROADCAST       INTERFACE                                                                                             

 0   192.168.10.1/24    192.168.10.0    192.168.10.255  Local                                                                                                 

 1   10.81.12.101/16    10.81.0.0       10.81.255.255   Public2                                                                                               

 2   172.16.200.1/24    172.16.200.0    172.16.200.255  Local                                                                                                 

 3   172.16.1.2/30      172.16.1.0      172.16.1.3      IP-IP-to-Sofia                                                                                        

 4 D 83.228.56.162/32   212.39.87.244   0.0.0.0         ADSL          


Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 

 #      DST-ADDRESS        PREF-SRC        GATEWAY-STATE GATEWAY                                           DISTANCE INTERFACE                                 

 0 A S  0.0.0.0/0                          reachable     10.81.0.1                                         1        Public2                                   

 1 A S  0.0.0.0/0                          reachable     ADSL                                              1        ADSL                                      

 2   S  0.0.0.0/0                          reachable     10.81.0.1                                         3        Public2                                   

 3   S  ;;; PCC Routes

        0.0.0.0/0                          reachable     ADSL                                              2        ADSL                                      

 6 ADS  0.0.0.0/0                          reachable     212.39.87.244                                     1        ADSL                                      

 7 A S  ;;; Stastic Route to Sofia - IP IP Tunnel

        10.16.32.0/24                      reachable     172.16.1.1                                        1        IP-IP-to-Sofia                            

 8 ADC  10.81.0.0/16       10.81.12.101                                                                    0        Public2                                   

 9 ADC  172.16.1.0/30      172.16.1.2                                                                      0        IP-IP-to-Sofia                            

10 ADC  172.16.200.0/24    172.16.200.1                                                                    0        Local                                     

13 ADC  192.168.10.0/24    192.168.10.1                                                                    0        Local                                     

14 ADC  212.39.87.244/32   83.228.56.162                                                                   0        ADSL                        

 

 Flags: X - disabled, I - invalid, D - dynamic 

 0   ;;; Mark Incoming (to router itself) connections so their reply packets get routed to the interface the connections came in

 1   chain=input action=mark-connection new-connection-mark=Public_conn passthrough=yes connection-state=new in-interface=ADSL 

 2   chain=input action=mark-connection new-connection-mark=Public2_conn passthrough=yes connection-state=new in-interface=Public2 

 3   ;;; Prevent Outgoing connections to clients' IP addresses from being mangled and routed by PCC

     chain=output action=accept dst-address-list=clients 

 4   chain=output action=accept dst-address=192.168.10.0/24 

 5   chain=output action=accept dst-address=172.16.200.0/24 

 6   ;;; Prevent proper to gateway connections from hitting the PCC mangles and being re-assigned to other gateway

     chain=output action=accept connection-state=new dst-address=83.228.56.162 

 7   chain=output action=accept connection-state=new dst-address=10.81.0.0/16 

 8   ;;; Mark outgoing from router connections w PCC by dst-address for proxy (and everything from router) balancing

     chain=output action=mark-connection new-connection-mark=Public_conn passthrough=yes connection-state=new dst-address-type=!local 

     per-connection-classifier=dst-address:2/0 

 9   chain=output action=mark-connection new-connection-mark=Public2_conn passthrough=yes connection-state=new dst-address-type=!local 

     per-connection-classifier=dst-address:2/1 

10   chain=output action=mark-routing new-routing-mark=to_Public passthrough=yes connection-mark=Public_conn 

11   chain=output action=mark-routing new-routing-mark=to_Public2 passthrough=yes connection-mark=Public2_conn 

12   ;;; Accept rules - Prevent local connections from being marked and sent to the Internet gateways where they would be dropped since the addresses wont ma>

     chain=prerouting action=accept dst-address=83.228.56.162 src-address-list=clients 

13   chain=prerouting action=accept dst-address=10.81.0.0/16 src-address-list=clients 

14   chain=prerouting action=accept src-address-list=clients dst-address-list=clients 

15   ;;; Mark connections from clients ip addresses w PCC balance before they get routed so they can be assigned routing rules later and get routed

     chain=prerouting action=mark-connection new-connection-mark=Public_conn passthrough=yes connection-state=new dst-address-type=!local 

     src-address-list=clients per-connection-classifier=both-addresses:2/0 

16   chain=prerouting action=mark-connection new-connection-mark=Public2_conn passthrough=yes connection-state=new dst-address-type=!local 

     src-address-list=clients per-connection-classifier=both-addresses:2/1 

17   chain=prerouting action=mark-routing new-routing-mark=to_Public passthrough=yes src-address-list=clients connection-mark=Public_conn 

18   chain=prerouting action=mark-routing new-routing-mark=to_Public2 passthrough=yes src-address-list=clients connection-mark=Public2_conn 


Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

малко снимки

тези връзки които съм маркирал би трябвало да минават през Public а не през втората!

post-171-130900725523_thumb.jpg

post-171-13090072553_thumb.jpg

post-171-130900725536_thumb.jpg

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

и още един въпрос. какво да добавя в mangle за да може да окажа на микротика че примерно някой ип адреси да ползват само единия доставчик, или примерно торенти маркирани с layer7 и вкарани в група да минават само през бтк примерно

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

така, колеги с единия от проблемите мисля че се справих, на PPPoE конекцията бях оставил ADD DEFAULT ROUTE и за това светеше "синичко" на рутинг таблицата

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

ехоо, някой може ли да даде насока?!?!

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

искам да направя тунел с cisco от другата страна и да е gre

дали има съвместимост и някакви насоки. пробвах с IPIP тунел, сложих му после ип-адрес, но от другата страна на cisco-то дава че тунела е down и няма нищо. при мен се вижда само една конекция от тяхното IP към 47 protocol  - GRE, но ми го дава unreplied

Опитай pptp tunel  към cisco-то да направиш.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

това предполагам ще стане, лошото е че на cisco-то искат да работи само гре.

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

това предполагам ще стане, лошото е че на cisco-то искат да работи само гре.

Проблема е в теб,не при  cisco-то и гре-то.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

знам, написал съм го горе, като спра PCC matcher-а и гре тунела се възва и имам пинг и т.н. / друг въпрос е че съм осрал нещо рутирането ама това е по-малкия яд/

обаче като пусна PCC-то всичко спира. гре тунела се показва в Public2 Connection Mark което не е нормално защото гре-то е пуснато от ADSL-a=Public

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

някой може ли да удари едно рамо?

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

къде бъркам с това рутриане?

 

 /ip route

add check-gateway=ping comment="" disabled=no distance=1 dst-address=\

    0.0.0.0/0 gateway=10.81.0.1 routing-mark=to_Public2 scope=30 \

    target-scope=10

add check-gateway=ping comment="" disabled=no distance=1 dst-address=\

    0.0.0.0/0 gateway=ADSL routing-mark=to_Public

add check-gateway=ping comment="" disabled=no distance=3 dst-address=\

    0.0.0.0/0 gateway=10.81.0.1 scope=30 target-scope=10

add check-gateway=ping comment="PCC Routes" disabled=no distance=2 \

    dst-address=0.0.0.0/0 gateway=ADSL

add comment="Stastic Route to Sofia - IP IP Tunnel" disabled=no distance=1 \

    dst-address=10.16.32.0/24 gateway=172.16.1.1 pref-src=192.168.10.1 scope=\

    30 target-scope=10

add comment="To Other Offices" disabled=yes distance=1 dst-address=\

    172.16.192.0/20 gateway=172.16.200.1 scope=30 target-scope=10

add comment="Route Masterwerk" disabled=no distance=1 dst-address=\

    172.16.201.0/24 gateway=172.16.201.1 scope=30 target-scope=10

add comment="Route Autoplus" disabled=no distance=1 dst-address=\

    172.16.202.0/24 gateway=172.16.202.1 scope=30 target-scope=10


172.16.200.0/24 локална мрежа

172.16.1.2 - ip address на IPIP-tunnel-a, 172.16.1.1 - ип адрес на колегите на тунела

10.16.32.0/24 вътрешната мрежа на колегите

10.81.0.0/16 - мрежата на доставчика ми - втория?

от сървъра имам пинг до 10.16.32.1, 32.10, 32.20...... от компютрите след сървъра няма. tracert спира до 172.16.200.1

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.