Jump to content

Затруднения с конфигуриране на Synology NAS зад Mikrotik Router


Recommended Posts

Здравейте на всички.

Срещам затруднения с конфигурирането на Synology NAS /DS216j/ или на рутера, който използвам /RB962UiGS-5HacT2HnT/.

Въпросният NAS преди това работеше зад TP-Link Archer C20 без никакви затруднения.

Използвам статичен IP адрес от ISP.

Настройките на рутера и NAS бяха следните, направил съм си screenshots:
Forum1.thumb.JPG.6260ede7ec1f05c4a258da39a527ce15.JPG

Настройките на NAS:
Forum2.JPG.b2efd8b80e55425f05aceea3f3b75a4a.JPG

Моля да ми посочите как да постигна същото с настоящия Mikrotik?
Ако е нужна каквато и да е информация що се отнася до рутера, моля посочете ми как да я достигна и да ви я представя.
В момента, в който направя Port Mapping /използвам краткия начин, бутона Port Mapping в Quick Set във winbox/, така както бяха в TP-Link рутера, първото изображение, спира въобще интернета. Имам чувството, че forward правилата на NAS и на Mikrotik пречат едно на друго. Изтрия ли тези от рутера, интернетът тръгва, но не мога да достъпя до NAS от външна мрежа.

Благодаря предварително за отделеното време.

Link to comment
Share on other sites

  • Administrator

Здравейте, не ползвайте куик сет за да си настройвате рутера. Може да добавите две правила през терминал едно за протокол TCP портовете и едно за UDP портовете. Естествено променете, ако е нужно интерфейса, който ви е WAN или пък сложете за всеки порт самостоятелно правило!

/ip firewall nat
add action=dst-nat chain=dstnat dst-port=80,443,5001,5002,6690,32400 in-interface=ether1 protocol=tcp to-addresses=192.168.0.115
add action=dst-nat chain=dstnat dst-port=80,443,5001,5002,6690,32400 in-interface=ether1 protocol=udp to-addresses=192.168.0.115

 

Link to comment
Share on other sites

Благодаря, всичко е наред сега. Добавих правила чрез GUI на winbox, не през терминала, но предполагам, че това няма значение.

Използвах възможността в Quick Set, тъй-като се доверих на видео на Mikrotik /Normunds Rustanovics - Technical Support Manager на Mikrotik/, но явно лесният вариант не е най-удачният или поне не във всички случаи.

Може да е наивна емоцията ми, но ми се струва странно NAS да налага правила на Firewall NAT на Mikrotik, макар и да извежда предупреждение, че ще го направи, в графичното меню на NAS. Въвеждам някакъв forward в графичното меню на NAS и той директно ъпдейтва настройките на рутера, в реално време, без да съм въвеждал никакви credentials за достъп до рутера.

Link to comment
Share on other sites

  • Administrator

Такъв контрол от NAS може да се осъществи, ако на рутера е активен UPnP. Ако е активен го изключете задължително!

Link to comment
Share on other sites

Аз го включих, когато експериментирах с настойките за forward на портовете. Изключвам го веднага, благодаря за съвета.

----

Ако е полезно за потребители с малък опит като мен и имащи подобен казус, когато изключих UPnP, рутерът изтри наложените му от NAS forward правила и е наложително те да се конфигурират отново в рутера.

Link to comment
Share on other sites

  • Administrator

То това е работата на  Universal Plug and Play прави автоматични динамични правила.

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.