Jump to content
  • 0

Работещ failover с частичен проблем в рутирането


IvanRalchev
 Share

Question

Здравейте,

имам много странен проблем с recursive failover на Mikrotik routeros 7.5. Но същото се получава и при v6.x

Ще се радвам ако някой помогне поне с идея къде да търся проблема.

Първо имаме два доставчика, един местен и бърз - Телнет.

И втори който е предплатена услуга на Yettel с техен рутер със сим карта и реално ИП. Рутера на Yettel e с изключен dhcp и WiFi, и реалното ИП което по принцип се назначава на самия рутер, но в случая   е пренасочен към микротика. Yettel рутера е като bridge.

Когато е реализирана и завършена конфигурацията по failover флаговете са правилни, само route Inet-Telnet e A - Active.

Route на Теленор е в ичакване.

При тестове с отпадане на главния интернет всичко работи.

Но....

Когато и двата интерфейса на Микротик са enable въпреки, че единия route е active а другия не е, когато дойде външна заявка от ип от мрежа на Yettel възниква грешка.

Например при опит за достъп до http://109.199.139.93:8080 съответната страница не е достъпна.

Ако същата страница се опитвам да я отворя от Мтел, Виваком и който и да е друг доставчик няма проблем!

Когато дам disable на interface Inet-Telenor същия адрес http://109.199.139.93:8080 вече се достъпва и от хора ползващи Yettel на телефоните си.

Не мога да си обясня какво точно се случва, прегледах дистанциите, освен че route-a на Теленор не е Active той е и с по-нисък приоритет дистанция - 2.

По-долу принтвам конфигурацията на ip-тата + принт на route table. Ип-тата са примерни, сменил съм ги. Ще се радвам ако някой подскаже какво точно се случва. :)

/ip/address/print detail
Flags: X - disabled, I - invalid, D - dynamic

0 address=192.168.10.1/24 network=192.168.10.0 interface=bridge1
actual-interface=bridge1

1 address=10.10.10.10/24 network=10.10.10.0 interface=bridge1
actual-interface=bridge1

2 D address=109.199.139.93/23 network=109.199.138.0 interface=Inet-Telnet
actual-interface=Inet-Telnet

3 D address=149.62.234.200/16 network=149.62.0.0 interface=Inet-Telenor
actual-interface=Inet-Telenor
= = = = = = = = = = = = = = = = = = = = = = = = = = =

/ip route/print detail follow
Flags: D - dynamic; X - disabled, I - inactive, A - active;
c - connect, s - static, r - rip, b - bgp, o - ospf, d - dhcp, v - vpn, m - modem, y - copy;
H - hw-offloaded; + - ecmp
DAd + dst-address=0.0.0.0/0 routing-table=main pref-src="" gateway=109.199.138.1

immediate-gw=109.199.138.1%Inet-Telnet distance=1 scope=30 target-scope=10

vrf-interface=Inet-Telnet suppress-hw-offload=no


0 s ;;; Backup Route - Main Route via Telenor
dst-address=0.0.0.0/0 routing-table=main pref-src="" gateway=8.8.4.4 immediate-gw=149.62.0.1%Inet-Telenor check-gateway=ping distance=2
scope=30 target-scope=11 suppress-hw-offload=no

1 As + ;;; Default Route - Main Route via Telnet
dst-address=0.0.0.0/0 routing-table=main pref-src="" gateway=8.8.8.8
immediate-gw=109.199.138.1%Inet-Telnet check-gateway=ping distance=1 scope=30 target-scope=11
suppress-hw-offload=no


2 IsH ;;; Monitor External Host via ISP2-Telenor
dst-address=8.8.4.4/32 routing-table=main pref-src="" gateway=149.62.0.1 immediate-gw=""
distance=1 scope=10 target-scope=10 suppress-hw-offload=no

3 As ;;; Monitor External Host via ISP1-Telnet
dst-address=8.8.8.8/32 routing-table=main pref-src="" gateway=109.199.138.1
immediate-gw=109.199.138.1%Inet-Telnet distance=1 scope=10 target-scope=10 suppress-hw-offload=no

DAc dst-address=10.10.10.0/24 routing-table=main gateway=bridge1 immediate-gw=bridge1 distance=0
scope=10 suppress-hw-offload=no local-address=10.10.10.10%bridge1

DAc dst-address=109.199.138.0/23 routing-table=main gateway=Inet-Telnet immediate-gw=Inet-Telnet
distance=0 scope=10 suppress-hw-offload=no local-address=109.199.139.93%Inet-Telnet

DAc dst-address=149.62.0.0/16 routing-table=main gateway=Inet-Telenor immediate-gw=Inet-Telenor distance=0 scope=10 suppress-hw-offload=no
local-address=149.62.234.200%Inet-Telenor

DAc dst-address=192.168.10.0/24 routing-table=main gateway=bridge1 immediate-gw=bridge1 distance=0
scope=10 suppress-hw-offload=no local-address=192.168.10.1%bridge1

 

 

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0
  • Administrator

опитай с VRF рутинг или с маркиране на трафика
активния лоудбалансинг не работи директно
 

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.