Jump to content

ПОМОЩ - относно изграждане на домашна Wi-Fi мрежа.


Иван Лефтеров
 Share

Recommended Posts

Здравейте на всички. Имам един въпрос и се надявам да намеря отговора при вас. :) 

Казуса е следния - Живея в кооперация, където интернета е на Хотспот принцип с юзърнейм и парола - под наем съм и собственика иска да печели от всеки апартамент директно. Организирал е доставчик на интернет в цялата сграда и всеки заплаща месечно използване - дотук всичко ок. Проблема е, че съм с 4 устройства и ако трябва да плащам за всяко едно... става доста солена сума на месец.

Та преди време, идва едно момче, приятел на мой познат, който ми настрои домашната мрежа така, че да се свързва с хотспота чрез рутер на MikroTik, който първо се свързва с Хотспота - въвеждам Юзърнейм и парола (ежемесечно, понеже достъпа е за месец).Микротика пък е свързан посредством кабел с друг рутер на Zyxel, който след това да пръска сигнала в къщи.  Надявам се, че го обясних разбираемо... 😄 😄 😄

Въпроса ми към вас е, как точно се води този тип настройка, понеже търсих доста в интернет вкл. и видеа в Ютуб, но не мога да се ориентирам. Момчето, което настрои мрежата е в София, не се и познаваме, за да го питам, а и надали ще се сети, дори и да го издиря.

Много ще съм благодарен ако някой ме насочи, както казах бос съм в тази сфера, буквално ще се радвам на информация, която мога да намеря Step-by-step 😄 

Модела на MikroTik рутера е ТОЗИ, а модела на Zyxel-a e ТОЗИ

Предварително благодаря на всеки, отзовал се. За допълнителна информация - оставам на линия. Хубав ден на всички! :)))

Link to comment
Share on other sites

  • Administrator

Да кажа, какво бих направил аз (разбира се, вече съм го правил): Купуваш си един двубандов рутер 2.4/5GHz.

С интерфейса на 2.4GHz сканираш за мрежи, намираш HotSpot мрежата и го конфигурираш като WAN (Dhcp-client, NAT, Firewall). HotSpot-a не разбира, че зад NAT-а на твоя рутер има други клиенти.

Всички други интерфейси включително и този на 5HGz в един бридж ги правиш на LAN с Dhcp-server, така оптада нуждата от втори рутер защото имаш домашен WIFI на 5GHz и 5 порта за LAN etrenet.

Сега трябва да си намериш човек който да ти го конфигурира :)

Тъй като това е HotSpot мрежа се предполага, че Интернета е мъртвец, затова ти предлагам най евтиния двубандов на MikroTik (с по мощен нищо няма да постигнеш)

hAP ac lite TC

Link to comment
Share on other sites

Благодаря за бързият отговор. Ами да ти кажа честно, май ще ми е трудничко да го направя сам.

Идеята ми беше, ако е нещо, което мога да видя стъпка по стъпка, както казах, понеже явно съм голям лаик в тази област.

Доколкото си спомням, това момче, когато правихме мрежата беше с подобна идея. В последствие, се оказа, че трябва втори рутер... не знам защо. Може би, за да ми го продаде просто... не съм сигурен, но както и да е.

Търся в интернет, но всичко, което намирам за настройки на MikroTik e по-скоро, както да го настроя като Хотспот, който в случая излъчва в цялата кооперация, но не и, като виртуално устройство, което да влезе с юзърнейм и парола.

Допускам и варианта, аз да бъркам, в смисъл, първо да е върза Zyxel-а към хотспота, след това бридж към MikroTik-а, и вече, той да пръска сигнала. Абе... обърках се вече и аз. 😄 Сложничко ми се вижда, а и няма никой в района, който да може да ми помогне. Това общо взето ме накара да се опитам сам да си помогна. 😉 

 

Link to comment
Share on other sites

  • Administrator

Ами като за начало, рутера няма да се логва в HotSpot-а а първия "компютър/таблет/телефон" който е зад него (това се случва когато има NAT). В HotSpot-а се свързва WLAN интерфейса на 2,4Ghz което на практика става WAN. Всички останали интерфейси се правят в един Bridge и те стават LAN. Тази конфигурация може да се изпълни от "любител/лайк" администратор (тоест нивото е ниско) Ако ти не си такъв (явно не си), не мисля, че е проблем да намериш. В решението което ти предлагам - рутера ти въобще не знае, че е свързан в HotSpot (не, че има и как да знае де) затова търсиш грешно. Рутера ти трябва да се свърже с WIFI мрежа, той няма браузер и не може да се логва но може да маскира компютрите ти зад него с NAT и те да го правят a HotSpot на хазяйна ти да си мисли, че това е едно устройство. Просто WAN интерфейса на рутера ти освен меден кабел или оптично влакно може да е антената за WIFI.

Link to comment
Share on other sites

Добреее, имаме напредък! 😄 😄 Значи сега от казаното от теб, разбирам, че ако купя двубандов рутер, ще ми бъде в пъти по-лесно. Може би, тоя пич е бил наясно, че са на 2.4 тези и двата и за това го е направил по по-сложният начин. Добре, в такъв случай тези двата отпадат като вариант, и без това само заемат повече място. Въпроса от тук натам е, ако си купя двубандовия.... дали ще се справя сам? 😄 😄 😄 Почвам да ровя в интернет, дано намеря насока как се случват нещата. БЛАГОДАРЯ ти много за информацията, поне ме насочи да действам на някъде, че бях в голяма дупка и всичката информация, която търся ме закопаваше още повече. 😄 

Link to comment
Share on other sites

  • Administrator

Тъй като съм за каузата да има справедливост на този свят и да бием алчните хазяи през ръчичките сглобих едно бързо ръководство с този сценарии у дома тествано с моя лаптоп.

/interface bridge
add name=bridge1

/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm mode=dynamic-keys name=profile1 supplicant-identity="" unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=WIFIPASS wpa2-pre-shared-key=WIFIPASS

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country=bulgaria disabled=no frequency=2422 installation=indoor security-profile=profile1 ssid=WIFI

/interface wireless
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-XXXX country=bulgaria default-forwarding=no disabled=no installation=indoor mode=ap-bridge ssid=Home

/ip pool
add name=dhcp_pool0 ranges=192.168.201.2-192.168.201.254

/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=bridge1 lease-time=1d name=dhcp1

/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan2

/ip address
add address=192.168.201.1/24 interface=bridge1 network=192.168.201.0

/ip dhcp-client
add disabled=no interface=wlan1

/ip dhcp-server network
add address=192.168.201.0/24 dns-server=192.168.201.1 gateway=192.168.201.1

/ip dns
set allow-remote-requests=yes

/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan1

/system clock
set time-zone-name=Europe/Sofia

hotspot5.png

 

hotspot4.pnghotspot3.png

hotspot2.pnghotspot1.png

  • Thanks 1
Link to comment
Share on other sites

Ето и от мен едно клипче правено преди време за подобен казус, но с рутер с едно радио, какъвто имате наличен в момента!

Link to comment
Share on other sites

Така, първо благодаря много и на двама Ви, за оказаното съдействие! Убедих се вече, че няма да станат нещата по този начин. Много сложен ми идва този рутер нещо. Уж се имам за сравнително технически човек, но и в двете "ръководства" по средата удрям на камък и настройките, които излизат при вас - при мен ги няма. Съответно стигам до задънена улица. Майната му, изглежда, че ще ми прашасват тук и двете устройства, поне до момента, в който не им намеря място.

Изниква ми обаче друг въпрос: Ако си взема двубандов рутер или някакъв repeater на сигнала, няма ли да се получи? В смисъл, да е нещо по-елементарно - да се влезе в определен адрес, въвеждам си данните и край! 😄 Или през AnyDesk може ли да се конфигурира? Дистанционно така да се каже, не че имам вариант към момента, но пак ще ми помогне. Благодаря още веднъж! Надявам се да проявите снизхождение към "капацитет" като мен! 😄 😄

Link to comment
Share on other sites

Преди 4 часа, Иван Лефтеров написа:

....Или през AnyDesk може ли да се конфигурира? Дистанционно така да се каже, не че имам вариант към момента, но пак ще ми помогне. Благодаря още веднъж! Надявам се да проявите снизхождение към "капацитет" като мен! 😄 😄

Пишете ми на лично да видим кога да настроим сегашният ви рутер , а вие ще прецените дали ви устройва!

  • Like 1
Link to comment
Share on other sites

Писах ЛС! БЛАГОДАРЯ за вниманието и жеста! Ей сега вече няма начин да не стане... 😄 😄

Link to comment
Share on other sites

Такааа! Минавам само да кажа, че всичко вече е наред! Не заради мен, разбира се, а благодарение на колегата @JohnTRIVOLTA! ОГРОМНИ благодарности, колега, за отзивчивостта и изгубеното време с мен! Жив и здрав бъди ти и семейството ти! Имам да черпя, казах ти къде съм - заповядай! Благодаря и на другите колеги, които се отзоваха! Проблема е решен, темата е за ключ. Живи и здрави! 😎🎶🥳

  • Like 1
Link to comment
Share on other sites

Браво на всички съдействали на човека.

Но  всичко това може да стане с едно устройство през web gui интерфейса с един евтин ac рутер за 80лв и самото устройство да взима и да раздава едновременно.

Всеки рутер с openwrt го може това също.

Човека не е необходимо да има невероятни технически умения за да кликне точно на 2 места.

Операционни система за рутери и  суичове : Linux и FreeBSD.
OpenWRT - Open Wireless Router.
Всичко останало е просто търговско наименование.

Mikroshit.png

Link to comment
Share on other sites

преди 10 минути, sairos написа:

Браво на всички съдействали на човека.

Но  всичко това може да стане с едно устройство през web gui интерфейса с един евтин ac рутер за 80лв и самото устройство да взима и да раздава едновременно.

Всеки рутер с openwrt го може това също.

Човека не е необходимо да има невероятни технически умения за да кликне точно на 2 места.

В случайя всичко пак стана с едно устройство, просто това бе налично от предходна година !

Link to comment
Share on other sites

Браво за което и че си се отзовал,  но пак човека имаше нужда от помощ за да се случи, тъй като интерфейса не е потребителски ориентиран.

Операционни система за рутери и  суичове : Linux и FreeBSD.
OpenWRT - Open Wireless Router.
Всичко останало е просто търговско наименование.

Mikroshit.png

Link to comment
Share on other sites

  • Administrator

sairos предлагаш на JohnTRIVOLTA да инсталира OpenWRT на MikroTik hardware за да намали кликовете ли ?

Два клика, три клика с OpenWRT, я покажи как става ама със забранените WIFI интерфейси по Default, да сканираш WIFI мрежата, да я конфигурираш, да махнеш WLAN от Bridge и да го направиш на WAN с NAT и т. н. - колко клика станаха в OpenWRT ?

Тук конфигурацията не е потребителски ориентирана за да се използва потребителски интерфейс - И да, RouterOS има и такъв интерфейс казва се Quick Set. Колко по потребителски да е от цялата конфигурация в един панел.

 

Quick_Set.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.