Jump to content
  • 0

Пренасочване на интернет през Wireguard peer (Mikrotik client)


Cobran89
 Share

Question

Здравейте,

 

Вдигнал съм един VPN тунел между два микротика и работи без проблем. LAN клиентите след клиентският микротик излизат в интернет през публичният адрес на микротик wireguard сървъра. Въпроса ми е следният:

Може ли да се направи в другата посока- клиентите зад микротик-а който е сървър да излизат в интернет през публияният адрес на микоритк клиента(peer-a). Пробвах с различни настройки на NAT, MANGLE и Routing Rules, но без успех. Може да е нещо дребно, ако някой има повече опит от мен ще се радвам да сподели.

Благодаря!

Link to comment
Share on other sites

Recommended Posts

  • 0
  • Administrator

Маскарадинг с дестинационни адреси, работи чудесно.

Всичко което не е към впн мрежата излиза през локалния геит.

Опиши си маскарадинг правилата не ги ползвай глобално.

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Трябва освен нат да има рутинг таблица със съответните правило/а/ за нея!

Edited by JohnTRIVOLTA
Link to comment
Share on other sites

  • 0

пробвах това което си описал, но не ми тръгва интернет трафика 

Link to comment
Share on other sites

  • 0
преди 8 минути, Cobran89 написа:

пробвах това което си описал, но не ми тръгва интернет трафика 

Трябва да имате и снат правило за адреса на тунела при отдалеченият рутер , ако няма глобално правило!

Edited by JohnTRIVOLTA
Link to comment
Share on other sites

  • 0
Posted (edited)

Това са настройките на локалният , който играе ролята на VPN server. Искам мрежата зад него да излиза през публичният адрес на клиентският микротик

table.png

NAT.png

route server.png

rules.png

 

Това е на отдалеченият

remoterouter.png

 

192.168.100.2-VPN address remote router

192.168.100.1 -VPN address local router VPN server

 

Edited by Cobran89
Link to comment
Share on other sites

  • 0

Да това са настройките ! Виж си и стената да няма нещо в нея.

Link to comment
Share on other sites

  • 0
Posted (edited)

Toва е на отдалечения рутер, няма настройки.

 

 

remoteside.png

 

Това е на локалния:

loclaside.png

Edited by Cobran89
Link to comment
Share on other sites

  • 0

Ако си сложил на локалният WG allowed address 192.168.100.2 сложи на него място 0.0.0.0/0

Link to comment
Share on other sites

  • 0

Точно това направих и всичко e like a charm :) Благодаря ти. Дребна грешка, която не я видях преди това. Много благодаря отново :)

  • Like 1
Link to comment
Share on other sites

  • 0
преди 10 минути, Cobran89 написа:

Точно това направих и всичко e like a charm :) Благодаря ти. Дребна грешка, която не я видях преди това. Много благодаря отново :)

Моля ! Заповядайте отново :)

Link to comment
Share on other sites

  • 0
Posted (edited)

само да попитам ако имате идея де. След като трафика минава през Клиентският VPN как да разреша да се достъпва лан мрежата на микротика(VPN сървъра)

, защото се губи връзката след като активирам рутирането на трафика

Edited by Cobran89
Link to comment
Share on other sites

  • 0
преди 54 минути, Cobran89 написа:

само да попитам ако имате идея де. След като трафика минава през Клиентският VPN как да разреша да се достъпва лан мрежата на микротика(VPN сървъра)

, защото се губи връзката след като активирам рутирането на трафика

Направи изключение за снат на 50та мрежа към лан мрежата на отдалечения рутер и такова същото правио добави в рутинга да гледа този път основната таблица.

Link to comment
Share on other sites

  • 0

Може ли малко подсказка за командите, че се опитах да сътворя нещо, което не сработи. Благодаря предварително!!!

Link to comment
Share on other sites

  • 0
Преди 1 час, Cobran89 написа:

Може ли малко подсказка за командите, че се опитах да сътворя нещо, което не сработи. Благодаря предварително!!!

/routing/rule/add src-address=192.168.50.0/24 dst-address=192.168.0.0/24 action=lookup table=main place-before=0
/ip/firewall/nat/add chain=srcnat src-address=192.168.50.0/24 dst-address=192.168.0.0/24 place-before=0

192.168.0.0/24 ти е локалната мрежа на отдалечената мрежа . Предполага се че и в основните таблици имаш вече пътища щом си имал преди достъп!

Edited by JohnTRIVOLTA
Link to comment
Share on other sites

  • 0

Опитах тези настройки , но без успех. Трябва да изключа dstnat 192.168.100.2 to adresses 192.168.50.0/24 за да има достъп към 50-та мрежа

Edited by Cobran89
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.