Jump to content
  • 0

Проблем с PPPoE връзка към ISP


Иван Тодоров
 Share

Question

Здравейте!

На RB3011 осъществявам връзка към ISP по PPPoE. Проблемът ми е, че веднъж на няколко седмици - трафикът по интерефеса pppoe-out1 спира, но вързката не се прекъсва. Когато и направя Disable - Enable или рутерът се рестартира трафикът тръгва.

Пробвах да сложа следния скрипт на връзката

##### Script Settings #####
:local WanName "pppoe-out1"
:local HostPingA "8.8.8.8"
:local HostPingB "8.8.4.4"
#####################

:local PingCount "5"
:local WanStat
/interface pppoe-client monitor $WanName once do={ :set WanStat $status}
:if ($WanStat = "connected") do={
:local pingresultA [/ping $HostPingA count=$PingCount];
:if ($pingresultA = 0) do={
:local pingresultB [/ping $HostPingB count=$PingCount];
:if ($pingresultB = 0) do={
:log error message="Script can not ping thru <$WanName>. Try to reconnect...";
:interface pppoe-client disable $WanName;
:delay 5;
:interface pppoe-client enable $WanName;
:log warning message="PPPoE has Reconnected by script";

 

Но въпреки, че в секция Scripts - показва, че го стартира многократно - реално при проява на проблема не го решава, а никъде в лога не виждам да изписва съобщенията от скрипта.

Предварително благодаря на всеки, който има идея и я сподели!

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

При мен това работи:

/tool netwatch
add disabled=no down-script="/interface pppoe-client disable pppoe-out1\r\
    \n/interface print\r\
    \n/interface pppoe-client enable pppoe-out1\r\
    \nlog info \"NET IS DOWN\"" host=8.8.8.8 interval=10m timeout=400ms up-script="log info \"NET IS UP\""

 

Link to comment
Share on other sites

  • 0

Благодаря! Ще го пробвам и ще го наблюдавам следващия месец.....

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.