Jump to content

Питане за EoIP тунел


Recommended Posts

psyx0

Здравейте, имам следното неудобство в момента 

със тунел между Б2 и Бибиком

Реални ай пита - ОК 

Скорост - ОК 

Но, при DHCP промяна на един от адресите и всичко отива някъде другаде. Та в графите 

Локал 

Ремоте 

Как може да стане динамично опресняване на адресацията? ми е въпроса 

image.png.463e95fd4141a5664700826cbe43f00d.png

image.png

I never saw a wild thing sorry for itself . A small bird will drop frozen dead from a bough wit hour ever having felt sorry for itself.

Link to post
Share on other sites
  • Owner
Влади

IP > Cloud 
image.png

След което вместо IP слагаш DNS Name дето имаш от микротик-а и работи, имам такова нещо вече повече от година

 

Също ако ти е само за телевизия то имам и един линк дето аз го карам първо с PPTP и след това EOIP с вътрешните ти адреси. Като се закачи PPTP Client-a и тунела ти светва веднага

image.png

 

image.png

image.png

Разликата между английските ,руските и българските форуми:

в английския форум задаваш въпрос, отговарят

в руския задваш въпрос ,отговарят ти и на свой ред те питат нещо

в българския форум, като зададеш въпрос всички започват да ти обясняват колко си прост

Недей да спориш с глупака. Първо ще те приравни до неговото ниво, после ще те бие с опита си.

-------------------

Когато фактите говорят и боговете мълчат

Link to post
Share on other sites
yHuKyM

И още - ако можеш, избягвай EoIP. Колкото и да ти е бърза връзката, по-добре GRE с рутриране, главно заради поведението на Windows-ите.

Link to post
Share on other sites
  • Owner
Влади
преди 2 минути, yHuKyM написа:

И още - ако можеш, избягвай EoIP. Колкото и да ти е бърза връзката, по-добре GRE с рутриране, главно заради поведението на Windows-ите.

Мисля, че го ползва за IPTV, там само това работи :)

Разликата между английските ,руските и българските форуми:

в английския форум задаваш въпрос, отговарят

в руския задваш въпрос ,отговарят ти и на свой ред те питат нещо

в българския форум, като зададеш въпрос всички започват да ти обясняват колко си прост

Недей да спориш с глупака. Първо ще те приравни до неговото ниво, после ще те бие с опита си.

-------------------

Когато фактите говорят и боговете мълчат

Link to post
Share on other sites
psyx0

За EoIP тунела, нищо не нося освен ТВ, но това със Cloud dns на микротика е чудесно нещо. Обаче когато пействам тътърътъ.майнет.нет и се генерира айпито, а от странана на бибиком на 2-3 седмици я тока спре или тъщата дръпне адаптера все независещи положения. Та въпроса ми е, мога ли да си улесня животеца, и това динамично айпи на този hEX да се нашива, като за хора който са скарани с програмирането. 😉 

I never saw a wild thing sorry for itself . A small bird will drop frozen dead from a bough wit hour ever having felt sorry for itself.

Link to post
Share on other sites
  • Administrator
111111
Преди 8 часа, psyx0 написа:

За EoIP тунела, нищо не нося освен ТВ, но това със Cloud dns на микротика е чудесно нещо. Обаче когато пействам тътърътъ.майнет.нет и се генерира айпито, а от странана на бибиком на 2-3 седмици я тока спре или тъщата дръпне адаптера все независещи положения. Та въпроса ми е, мога ли да си улесня животеца, и това динамично айпи на този hEX да се нашива, като за хора който са скарани с програмирането. 😉 

Обнови си версията и ще си остава ДНС записа

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to post
Share on other sites
psyx0

Здравей, колега. rOS 6.48.2 толкова ли е стара за да не се случват нещата. Поне при мен след като пусна b85b09йййй.sn.mynetname.net в таба на локалния адрес с аплай си отива на IP адрес, и при промяна от DHCP-то и всичко приключва. За отсрещната машина записа си е точен. Да не имаш в предвид че бъркам с локалния адрес, трябва да е вътрешната ми мрежа. 

I never saw a wild thing sorry for itself . A small bird will drop frozen dead from a bough wit hour ever having felt sorry for itself.

Link to post
Share on other sites
JohnTRIVOLTA
Преди 5 часа, psyx0 написа:

Здравей, колега. rOS 6.48.2 толкова ли е стара за да не се случват нещата. Поне при мен след като пусна b85b09йййй.sn.mynetname.net в таба на локалния адрес с аплай си отива на IP адрес, и при промяна от DHCP-то и всичко приключва. За отсрещната машина записа си е точен. Да не имаш в предвид че бъркам с локалния адрес, трябва да е вътрешната ми мрежа. 

Както ти казаха вече вдигни си един pptp с локални адреси на връзката през която ще караш този EoIP и драмата да свършва !

Link to post
Share on other sites
  • 2 weeks later...

Та на въпроса ми, неволята има решение. 

:global "EoIPTunnel" "EoIP-1.Vivacom"
:global "EoIPRemote" "xxl.sn.mynetname.net"
:global "EoIPLocal" "llx.sn.mynetname.net"
:global "EoIPRemoteIP" [:resolve $"EoIPRemote"]
:global "EoIPLocalIP" [:resolve $"EoIPLocal"]
:global "EoIPConnectTo" [/interface eoip get $EoIPTunnel remote-address]
:global "EoIPConnectFrom" [/interface eoip get $EoIPTunnel local-address]
:if ($EoIPRemoteIP != $EoIPConnectTo) do={:log info "****** Updating EoIP Tunnel - Remote end for $EoIPTunnel"

/interface eoip set $"EoIPTunnel" remote-address=$"EoIPRemoteIP"}

:if ($EoIPRemoteIP = $EoIPConnectTo) do={:log info "**** No Update necessary for EoIP Tunnel - Remote End $EoIPTunnel"}
:if ($EoIPLocalIP != $EoIPConnectFrom) do={:log info "****** Updating EoIP Tunnel - Local End for $EoIPTunnel"}

/interface eoip set $"EoIPTunnel" local-address=$"EoIPLocalIP"}

:if ($EoIPLocalIP = $EoIPConnectFrom) do={:log info "**** No Update necessary for EoIP Tunnel - Local End $EoIPTunnel"}

/system scheduler
add interval=60m name=EoIP-1.Vivacom on-event=EoIP-1.Vivacom policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=\
jan/01/1970 start-time=00:00:01

Дано помогне на някой със същия проблем

  • Like 1

I never saw a wild thing sorry for itself . A small bird will drop frozen dead from a bough wit hour ever having felt sorry for itself.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.