Jump to content

Помощ за настройка на рутер Cisco 1811


ivankrivodol
 Share

Recommended Posts

Oпитвам да пренастроя един рутер Cisco 1811 за да рутира според настройките на нов доставчик на интернет - ползван е на друго място, с други настройки и неизвестни потр. име и парола. Това с паролата го оправих, свързвам се към рутера с оригинален кабел, ползвайки SecureCRT 6.0 - става и с HyperTerminal, но с последната не успях да махна старите настройки. Първия проблем е че не успявам да накарам рутера да запомни това, което му настройвам - правя настройки на WAN, парола, име и докато е включен показва променените настройки, но след изключване всичко е отначало. Не мога да го накарам и да има мрежа с компютъра - на компютъра показва, че конекцията е ограничена или липсва - с едно триъгълниче излиза. Освен това не успявам да се свържа с рутера чрез Cisco SDM - с какъв кабел трябва да се свържат? Аз всъщност имам много въпроси по тая тема, но засега, ако някой помогне дотук като начало ще е ОК. Предварително благодаря.

Link to comment
Share on other sites

Ще ти обелее всичко и ще загубиш дни преди да научиш Циско простотиите. Ако има публично IP и успееш да го подкараш, пусни

ip http server
в configure режим и кажи какви настройки искаш да му се вкарат.
Link to comment
Share on other sites

след като въведа настройките става това:

[0] Go to the IOS command prompt without saving this config.

[1] Return back to the setup without saving this config.

[2] Save this configuration to nvram and exit.

Enter your selection [2]: 2

Building configuration...

Use the enabled mode 'configure' command to modify this configuration.

Press RETURN to get started!

*Nov 19 09:32:17.659: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State change

d to: Initialized

*Nov 19 09:32:17.679: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State chang......

след натискане на ентер се показва името на рутера, което съм задал - KR и ако напиша enable ми иска парола - приема тая, която съм задал

KR>enable

Password:

KR#copy running-config startup-config

Destination filename [startup-config]? ?

%Error copying nvram:? (Invalid argument)

KR#copy running-config startup-config

Destination filename [startup-config]? KR

%Error copying nvram:KR (Invalid argument)

KR#copy running-config startup-config ?

  <cr>

KR#copy running-config startup-config

Destination filename [startup-config]? startup-config

Building configuration...

[OK]

KR#exit

и после като изключа захранването всичко си е като преди настройките. Искам да му задам за WAN 192.168.50.15 mask - 255.255.255.0, DNS 85.196.183.254

Link to comment
Share on other sites

Започвам така (пропускам малко инфо, което се извежда - мися, че ме е нужно)

Installed image archive

Cisco 1811 (MPC8500) processor (revision 0x400) with 118784K/12288K bytes of memory.

Processor board ID FHK1103102Z, with hardware revision 0000

10 FastEthernet interfaces

1 Serial interface

1 terminal line

31360K bytes of ATA CompactFlash (Read/Write)

        --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: Y

At any point you may enter a question mark '?' for help.

Use ctrl-c to abort configuration dialog at any prompt.

Default settings are in square brackets '[]'.

Basic management setup configures only enough connectivity

for management of the system, extended setup will ask you

to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: Y

Configuring global parameters:

  Enter host name [Router]: KR

  The enable secret is a password used to protect access to

  privileged EXEC and configuration modes. This password, after

  entered, becomes encrypted in the configuration.

  Enter enable secret: RR

  The enable password is used when you do not specify an

  enable secret password, with some older software versions, and

  some boot images.

  Enter enable password: RC

  The virtual terminal password is used to protect

  access to the router over a network interface.

  Enter virtual terminal password: CI

  Configure SNMP Network Management? [yes]: Y

    Community string [public]: public

Current interface summary

Any interface listed with OK? value "NO" does not have a valid configuration

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0              unassigned      NO  unset  up                    down   

FastEthernet1              unassigned      NO  unset  up                    down   

FastEthernet2              unassigned      YES unset  initializing          down   

FastEthernet3              unassigned      YES unset  initializing          down   

FastEthernet4              unassigned      YES unset  initializing          down   

FastEthernet5              unassigned      YES unset  initializing          down   

FastEthernet6              unassigned      YES unset  initializing          down   

FastEthernet7              unassigned      YES unset  initializing          down   

FastEthernet8              unassigned      YES unset  initializing          down   

FastEthernet9              unassigned      YES unset  initializing          down   

Vlan1                      unassigned      YES unset  up                    down   

Async1                    unassigned      YES unset  down                  down   

Enter interface name used to connect to the

management network from the above interface summary: FastEthernet1

Configuring interface FastEthernet1:

  Use the 100 Base-TX (RJ-45) connector? [yes]: Y

  Operate in full-duplex mode? [no]: Y

  Configure IP on this interface? [yes]: Y

    IP address for this interface: 192.168.50.15

    Subnet mask for this interface [255.255.255.0] : 255.255.255.0

    Class C network is 192.168.50.0, 24 subnet bits; mask is /24

The following configuration command script was created:

hostname KR

enable secret 5 $1$RZAi$sjJk1RhAcFrVulYUv8MbO/

enable password RC

line vty 0 4

password CI

snmp-server community public

!

no ip routing

!

interface FastEthernet0

shutdown

no ip address

!

interface FastEthernet1

no shutdown

media-type 100BaseX

full-duplex

ip address 192.168.50.15 255.255.255.0

!

interface FastEthernet2

shutdown

no ip address

!

interface FastEthernet3

shutdown

no ip address

!

interface FastEthernet4

shutdown

no ip address

!

interface FastEthernet5

shutdown

no ip address

!

interface FastEthernet6

shutdown

no ip address

!

interface FastEthernet7

shutdown

no ip address

!

interface FastEthernet8

shutdown

no ip address

!

interface FastEthernet9

shutdown

no ip address

!

interface Vlan1

shutdown

no ip address

!

end

[0] Go to the IOS command prompt without saving this config.

[1] Return back to the setup without saving this config.

[2] Save this configuration to nvram and exit.

Enter your selection [2]: 2

media-type 100BaseX

^

% Invalid input detected at '^' marker.

Building configuration...

Use the enabled mode 'configure' command to modify this configuration.

Press RETURN to get started!

*Nov 19 10:27:37.663: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Initialized

*Nov 19 10:27:37.683: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Enabled

*Nov 19 10:27:46.659: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up

*Nov 19 10:27:46.659: %LINK-3-UPDOWN: Interface FastEthernet1, changed state to up

*Nov 19 10:27:47.659: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to down

*Nov 19 10:27:47.659: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1, changed state to down

*Nov 19 10:27:48.687: USB init complete.

*Nov 19 10:30:05.939: %LINK-5-CHANGED: Interface FastEthernet0, changed state to administratively down

*Nov 19 10:30:07.395: %LINK-5-CHANGED: Interface FastEthernet2, changed state to administratively down

*Nov 19 10:30:07.395: %LINK-5-CHANGED: Interface FastEthernet3, changed state to administratively down

*Nov 19 10:30:07.395: %LINK-5-CHANGED: Interface FastEthernet4,

KR> changed state to administratively down

*Nov 19 10:30:07.399: %LINK-5-CHANGED: Interface FastEthernet5, changed state to administratively down

*Nov 19 10:30:07.399: %LINK-5-CHANGED: Interface FastEthernet6, changed state to administratively down

*Nov 19 10:30:07.403: %LINK-5-CHANGED: Interface FastEthernet7, changed state to administratively down

*Nov 19 10:30:07.403: %LINK-5-CHANGED: Interface FastEthernet8, changed state to administratively down

*Nov 19 10:30:07.407: %LINK-5-CHANGED: Interface FastEthernet9, changed state to administratively down

*Nov 19 10:30:07.415: %LINK-5-CHANGED: Interface Vlan1, changed state to administratively down

*Nov 19 10:30:08.491: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2, changed state to down

*Nov 19 10:30:08.491: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet3, changed state to down

*Nov 19 10:30:08.495: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet4, changed state to down

*Nov 19 10:30:08.495: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5, changed state to down

*Nov 19 10:30:08.495: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet6, changed state to down

*Nov 19 10:30:08.495: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet7, changed state to down

*Nov 19 10:30:08.495: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet8, changed state to down

*Nov 19 10:30:08.495: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet9, changed state to down

*Nov 19 10:30:08.495: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down

*Nov 19 10:30:13.955: %SYS-5-RESTART: System restarted --

Cisco IOS Software, C181X Software (C181X-ADVIPSERVICESK9-M), Version 12.4(9)T1, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright © 1986-2006 by Cisco Systems, Inc.

Compiled Wed 30-Aug-06 14:24 by prod_rel_team

*Nov 19 10:30:13.955: %SNMP-5-COLDSTART: SNMP agent on host KR is undergoing a cold start

*Nov 19 10:30:14.015: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF

KR>write memory

    ^

% Invalid input detected at '^' marker.

KR>ENABLE

Password:

KR#write memory

Building configuration...

[OK]

KR#

******

Такава настройка правя след включване

И после това:

KR#sh ru

Building configuration...

Current configuration : 1138 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname KR

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$RZAi$sjJk1RhAcFrVulYUv8MbO/

enable password RC

!

no aaa new-model

!

resource policy

!

no ip routing

!

!

no ip cef

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

no ip route-cache

shutdown

duplex auto

speed auto

!

interface FastEthernet1

ip address 192.168.50.15 255.255.255.0

no ip route-cache

speed auto

full-duplex

!

interface FastEthernet2

shutdown

!

interface FastEthernet3

shutdown

!

interface FastEthernet4

shutdown

!

interface FastEthernet5

shutdown

!

interface FastEthernet6

shutdown

!

interface FastEthernet7

shutdown

!

interface FastEthernet8

shutdown

!

interface FastEthernet9

shutdown

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Async1

no ip address

encapsulation slip

no ip route-cache

!

!

!

no ip http server

no ip http secure-server

!

snmp-server community public RO

!

!

!

!

!       

!

control-plane

!

!

line con 0

line 1

line aux 0

line vty 0 4

password CI

login

!

end

KR#

Link to comment
Share on other sites

Не си приключил до край процедурата по рестартирането на рутера и за това всеки път ти зарежда дефаултната конфигурация. Прегледай документацията относно рестартирането и изпълни инструкциите до край.

Link to comment
Share on other sites

KR#copy running-config startup-config

Destination filename [startup-config]?

Building configuration...

[OK]

KR#

Уж го правя - така пише в мануала, дава и ОК, но после не го е записал.

Link to comment
Share on other sites

Здравейте

Ако искаш намери ме в скаипа (flexa_1) и ще ти отговоря на всички въпроси свързани с този рутер :)

When you dream,there are no rulz...

Link to comment
Share on other sites

  • 3 months later...

Здрасти

Забелязах нещо без което няма да тръгне дори да записваш старт конфигурацията

Има един ред - no ip routing

Пробвай

#conf t

config#ip routing

exit

#write memory

Успех.

P.S. Ще е хубаво и да пуснеш този service - service password-encryption -той криптира паролите:-)

Hint: #conf t

configure#service password-encryption

configure#exit

#write memory

А плюс това за да рутираш доставчик към локална мрежа се псука ip nat inside със source  и  detination  адреси на мрежи, има един филм който се казва  ip name server, ( #conf t => configure#ip name server (IP addres)-dns server който е посочил доставчика, може и повече от един да се вкарат), и като за начало се вкарва IP адрес от доставчика със съответна маска на другия ти интерфейс т.е. на:

(interface FastEthernet0

no ip address - ip address на доставчика/ subnet mask

no ip route-cache

shutdown

duplex auto

speed auto).

Link to comment
Share on other sites

  • 2 weeks later...

Здрасти,

Кажи как ресетна паролата. Там се сменяха един цифрички :D и доколкото си спомням ако след смяна на паролата не ги върнеш по старо му зареждаше всеки път дефаулт настройките. Може и да се бъркам, но имаше нещо такова със сигурност.

Link to comment
Share on other sites

Здрасти,

Кажи как ресетна паролата. Там се сменяха един цифрички :) и доколкото си спомням ако след смяна на паролата не ги върнеш по старо му зареждаше всеки път дефаулт настройките. Може и да се бъркам, но имаше нещо такова със сигурност.

Така е. Стартирай в rommon режим и пусни - има една команда с която си избираш как да зарежда (цифричките ти ги дава какво означават). Това е което си спомням :) и което мога да препоръчам като добър начин за справяне с тия проблеми.

Link to comment
Share on other sites

  • 4 months later...

точно така .. единствената причина за това е че си го резетнал като мен и не си следвал останалите стъпки.

аз преди 3 месеца направих същият номер .. и след 2-3 дни се отказах да се занимавам, понеже не ми е притрябвало мн. устройството. но сега си викам защо да не го ползвам и дори му ъпдейтвах софта до средата на 2009-та год. понеже е последна версия на 32 мб флаш.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.