Jump to content
  • 0

Баланс на натоварването + BACKUP между 3 или 5 GW


diyan
 Share

Question

Здравейте.Четах доста от темите и коментарите във форума, но неуспях да конфигурирам MIkroTIk  така, че да работи както аз бих искал:

1.Имаме в наличност 3 ISP i 4ри IP адреса

\ISP1 EKK: DHCP (10.10.10.29, 192.168.10.6)

\ISP2 BTK:192.168.1.1

\ISP3 KbelTel DHCP (IPto nego znam to4no(minava prez ruter) da priemem 4e e  10.10.10.4)

2.Имам в наличност 5x100 Мбпс lan + 1x1000 Mbps lan = 6 Лан карти

Искам да обединя трафика от ISP1 двете IP-ta , ако може и 3ри и 3рето ще пусна, имам го свободно в наличност. и така БГ трафика ще стане 2х45 Mbps = 90 Mbps или 130 Mbps ако и 3те минат на 45 Mbps трафиК.Като обединението да представлята Load Balance на трафика през тези 3ри Примерни ИП-та, и при случаи че прекасне вразката (падне 1-то  - саответно и другите ипта, понеже се движат по еидн кабел) да прехварля интернета към другите ISP-та ISP2 , ISP3, за да може да има интернет някакав, като ISP2  и ISP3 пак са в режим Load Balance.

В момента имам Рутер с такава функция TL-R480T+http://www.tp-link.com/products/product_des.asp?id=14 и обединява трафика на 2те ИП-та от ISP1 но понякога забива. Четах много теми http://dobri.biz/software/-mikrotik/  и http://wiki.mikrotik.com/wiki/Load_Balancing_Persistent и всички от този форум, но несработва системата.

Основни проблеми:

1.Като се включи някой му дава интенет от едното реално ИП, а на следващият човек от следващото реално ИП, но ако изкарам кабела (спитам едното реално ИП) този които е кам него варзан остава бе НЕТ а другият си има, този които е без нет ако си смени мак адреса автоматично получава интернет , но само след смяна на МАЦ адрес - съответно получава и ново ИП.

2.Реалните ми ИПта неса фиксирани получавам го по DHCP  в смисал че може да ги сменят колкото пати си искат, без аз да разбера. пробвах таиз команда но не става /ip route add dst-address=0.0.0.0/0 gateway=ether1,ether2 поневе видях че някои във форума беше писал че работи.

3.Бих искал да мога да задам групово (за всички абонати) максимален брий едновременни вразки на IP (локално).

Ще ви малка част от командите които от 4 дена се мъча да подкарам,Дано да иам някои който ми внесе яснота по проблема,Знам че може да стане, но знам че и несам достатъчно компетеннтен зада го направя,Ако някои може да ми да ясното по вапроса, знам че безплатен обяд няма, така че ако някой мисли че мойе да помогне да коментира.

Мога да псуна доступ до машината през някое от реалните ИПта за тестове, стига някои да се навие!

-----------------

'''/ ip address'''

add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local

add address=10.10.10.29/24 network=10.10.10.0 broadcast=10.10.10.255 interface=wlan2

add address=192.168.10.6/24 network=192.168.10.0 broadcast=192.168.10.255 interface=wlan1

'''/ ip route'''

add dst-address=0.0.0.0/0 gateway=10.10.10.1,192.168.10.2 check-gateway=ping

'''/ ip firewall nat'''

add chain=srcnat out-interface=wlan1 action=masquerade

add chain=srcnat out-interface=wlan2 action=masquerade

-----------------------------------------------------------

Това би трябвало да работи, но при мен не сработи :(

Добавяме необходимите IP адреси (по един на всеки от интерфейсите на машината ни):

ip address - отиваме в съответната секция

add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface= Local comment="" disabled=no

add address=192.168.10.6/24 network=192.168.10.6.0 broadcast=192.168.10.6.255 interface= wlan1 comment="" disabled=no

add address=10.10.10.29/24 network=10.10.10.0 broadcast=10.10.10.255 interface= wlan2 comment="" disabled=no

192.168.0.1 е за локалната ни мрежа, 192.168.10.6, 10.10.10.29 са IP адреси на двата мрежови интерфейса, които се свързват към съответния гейтуей.

ip firewall mangle - отиваме в съответната секция

add chain=prerouting in-interface= Local connection-state=new nth=1 action=mark-connection new-connection-mark=odd passthrough=yes comment="" disabled=no

Чрез горното правило взимаме всеки втори пакет, които отваря нова сесия и го маркираме с маркера за връзка "odd". Поради тази проичина всички всички пакети принадлежащи на тази сесия, ще носят същия маркер. След това чрез passthrough=yes пропускаме пакетите към следващото правило.

add chain=prerouting in-interface= Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no

Чрез горното правило, маркираме всички пакети, които са на "odd" връзката с рутинг маркера "odd". Чрез passthrough=no прекратяваме други подобни операции във веригата.

Следващите две правила правят същото със останалата част от трафика.

add chain=prerouting in-interface= Local connection-state=new nth=1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no

add chain=prerouting in-interface= Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

"odd" трафикът се натва към 192.168.10.6, а останания - "even", към 10.10.10.29

ip firewall nat

add chain=srcnat connection-mark=odd action=src-nat to-addresses= 192.168.10.6 to-ports=0-65535 comment="" disabled=no

add chain=srcnat connection-mark=even action=src-nat to-addresses= 10.10.10.29 to-ports=0-65535 comment="" disabled=no

И правилата за рутиране:

•      за "odd" трафика използваме гейтуей 192.168.10.1

•      за "even" - 10.10.10.1

•      трафика за самия рутер - през 10.10.10.1

ip route

add dst-address=0.0.0.0/0 gateway=10.22.35.16 scope=255 target-scope=10 routing-mark=odd comment="" disabled=no

add dst-address=0.0.0.0/0 gateway=80.70.20.40 scope=255 target-scope=10 routing-mark=even comment="" disabled=no

add dst-address=0.0.0.0/0 gateway=80.70.20.40 scope=255 target-scope=10 comment="" disabled=no

При самата конфигурация небитрябвало  да се конктеризират ИП адреси на IPS-to понеже те са динамични.

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0
  • Owner

Колега ,  май малко с трици маймуни ще ловиме :)

Подобно балансиране става , ама да кажем за вкъщи или за малък офис.

Ако постановката трябва за професионални цели  (непрекъсваемост най вече) , две оптики , AS и BGP .

Ако все пак си решил да е по този начин, опитай се първо да балансираш само два доставчика.  Изобщо не разчитай на кой знае какви резултати за подобни скорости.

/ip route add dst-address=0.0.0.0/0 gateway=ether1,ether2

не работи - бях се заблудил :) Една подсказка - ДХЦП то може да ти мену адресите , ама гейтуеите ти са едни и същи .

Така, балансирането е два вида - per packet и per destination.

За първия вид балансиране не ти трябва никакво маркиране на пакети, то става само с един ред :

'''/ ip route'''

add dst-address=0.0.0.0/0 gateway= gateway1,gateway2,gateway3  check-gateway=ping

Втория е малко по-сложен,  при него вече трябва маркиране на пакетите по дестинация и съответния default route за дестинацията

Link to comment
Share on other sites

  • 0

Колега ,  май малко с трици маймуни ще ловиме :)

Подобно балансиране става , ама да кажем за вкъщи или за малък офис.

Ако постановката трябва за професионални цели  (непрекъсваемост най вече) , две оптики , AS и BGP .

Ако все пак си решил да е по този начин, опитай се първо да балансираш само два доставчика.  Изобщо не разчитай на кой знае какви резултати за подобни скорости.

/ip route add dst-address=0.0.0.0/0 gateway=ether1,ether2

не работи - бях се заблудил :) Една подсказка - ДХЦП то може да ти мену адресите , ама гейтуеите ти са едни и същи .

Така, балансирането е два вида - per packet и per destination.

За първия вид балансиране не ти трябва никакво маркиране на пакети, то става само с един ред :

'''/ ip route'''

add dst-address=0.0.0.0/0 gateway= gateway1,gateway2,gateway3  check-gateway=ping

Втория е малко по-сложен,  при него вече трябва маркиране на пакетите по дестинация и съответния default route за дестинацията

'''/ ip route'''

add dst-address=0.0.0.0/0 gateway= gateway1,gateway2,gateway3  check-gateway=ping

Това не работи при мен, пробвах какви ли не комбинации... но ефекта е :invalid value for argument address

[admin@MikroTik] ip route> add dst-address=0.0.0.0/0 gateway= gateway1,gateway2,192.168.10.3 check-gatewa

y=ping

като и с 2 или 3 GW  в момента активни, дава едно и също, забелязах че като стигна го [admin@MikroTik] ip route>  add dst-address=0.0.0.0/0 gateway= аутокомпиита нищо не ми дава като възможен правилен параметър/аргумент

с версия x.27 съм, разбраг че тя не поддържала добре driver  за 1000 Mbps  ланкарти - релатек по специално (Realtek Semiconductor Co.... RTL-8169 Gigabit Etherne). Ина4е в момента съм с 3com 10/100

[admin@MikroTik] > system resource pci print

# DEVICE   VENDOR                                   NAME                                     IRQ      

0 01:05.0  Realtek Semiconductor Co., Ltd.          RTL-8139/8139C/8139C+ (rev: 16)          5        

1 01:00.0  3Com Corporation                         3c905C-TX/TX-M [Tornado] (rev: 120)      5        

2 01:01.0  3Com Corporation                         3c905C-TX/TX-M [Tornado] (rev: 120)      5        

3 01:02.0  3Com Corporation                         3c905C-TX/TX-M [Tornado] (rev: 120)      11        

4 00:1f.5  Intel Corporation                        82801EB/ER (ICH5/ICH5R) AC'97 Audio C... 5        

5 00:1f.3  Intel Corporation                        82801EB/ER (ICH5/ICH5R) SMBus Control... 5        

6 00:1f.1  Intel Corporation                        82801EB/ER (ICH5/ICH5R) IDE Controlle... 0        

7 00:1f.0  Intel Corporation                        82801EB/ER (ICH5/ICH5R) LPC Interface... 0        

8 00:1e.0  Intel Corporation                        82801 PCI Bridge (rev: 194)              0        

9 00:1d.7  Intel Corporation                        82801EB/ER (ICH5/ICH5R) USB2 EHCI Con... 11        

10 00:1d.3  Intel Corporation                        82801EB/ER (ICH5/ICH5R) USB UHCI Cont... 10        

11 00:1d.2  Intel Corporation                        82801EB/ER (ICH5/ICH5R) USB UHCI #3 (... 5        

12 00:1d.1  Intel Corporation                        82801EB/ER (ICH5/ICH5R) USB UHCI Cont... 3        

13 00:1d.0  Intel Corporation                        82801EB/ER (ICH5/ICH5R) USB UHCI Cont... 10        

14 00:02.0  Intel Corporation                        82865G Integrated Graphics Controller... 10        

15 00:00.0  Intel Corporation                        82865G/PE/P DRAM Controller/Host-Hub ... 0        

[admin@MikroTik] > system resource irq print

IRQ OWNER                                                                                              

1   keyboard                                                                                            

2   APIC                                                                                                

3   [usb-uhci]                                                                                          

4   serial port                                                                                        

5   [usb-uhci]                                                                                          

5   Local                                                                                              

5   wlan3                                                                                              

5   wlan2                                                                                              

8   [rtc]                                                                                              

10  [usb-uhci]                                                                                          

10  [usb-uhci]                                                                                          

11  wlan1                                                                                              

14  IDE 1                                                                                              

[admin@MikroTik] > system resource print

                  uptime: 1h9m35s

                 version: "x.27"

             free-memory: 489004kB

            total-memory: 507932kB

                     cpu: "Intel®"

           cpu-frequency: 2663MHz

                cpu-load: 0

          free-hdd-space: 3832764kB

         total-hdd-space: 3901140kB

 write-sect-since-reboot: 11600

        write-sect-total: 80088

Link to comment
Share on other sites

  • 0

Версия  3.15 можеш да използваш за да задаваш интерфейс вместо IP адрес за gateway :) А скоро ще излезе 3.21 където има някакви минимални кръпки свързани с това. Ако искаш да спестиш от сметката за тока дето прави едно PC можеш да вземеш рутерборд дето си върви с лиценза за софтуера.

Link to comment
Share on other sites

  • 0

01:05.0  Realtek Semiconductor Co., Ltd.          RTL-8139/8139C/8139C+ (rev: 16)          5        

1 01:00.0  3Com Corporation                         3c905C-TX/TX-M [Tornado] (rev: 120)      5        

2 01:01.0  3Com Corporation                         3c905C-TX/TX-M [Tornado] (rev: 120)      5      

Сам помисли кое не изглежда наред тук. Дори да успееш да постигнеш работещо решение ще е "по-здраво от яйце".

Link to comment
Share on other sites

  • 0

"С трици маймуни да ловиим" няма проблеми колеги, на когото не му харесва - има конкурентни ISP-та - клиентите да ходят там. :) В конкретния случай има повече от 100Mbit Internet скорост devilish.png ... благодарение на възможността на великия MikroTik рутер да комбинира връзките.

Двете оптики, AS-a и BGP-то струват много повече + за BGP ти трябва по-скъпо администриране. Иначе всеки иска, да.

При комбиниране на "трици" може да се разчита на прекрасни резултати с правилната конфигурация devilish.png

RouterOS има проблем когато е зададен интерфейс като gateway - пускат се arp request-и по интерфейса търсещи интернетските IP адреси, вместо RouterOS-а да си открие веднъж gateway IP-то и да си му праща директно на него. Това съм го докладвал на латвийците наскоро като проблем. (последно тествано с 3.24-3.28, routing-test, 4.0beta4 и се дънеше с изброените)

Може да се ползват PPPoE и други тунел интерфейси като gateway вместо IP адрес - тогава такъв проблем няма devilish.png.

Да - DHCP-то като мени адресите е много досадно понеже се налага да се ползват още купища рутери или скриптове които да кърпят нещата при смяна на адреси. Най-гадното е когато трябва да се балансират линкове с gateways в една подмрежа, тогава трябват допълнителни рутери за всеки линк. Може и SOHO такива да свършат работа ако имат достатъчно памет за conntrack записи devilish.png

Лично аз съм почитател на per connection балансирането осъществено с новия PCC механизъм devilish.png достъпен след версия 3.24. Относно per packet: за TCP/IP където имаме ack за всеки получен пакет има възможност закъснението на пакетите да е различно по различните линкове и това да доведе до снижаване на скоростта на TCP конекцията, няма да може да си адаптира window-а толкова бързо. И за udp би имало проблем с по-голям и неконтролируем jitter. Може би ако двата линка са наши и са с еднакви капацитети и от двете страни контролираме трафика с яки рутери (MikroTik хе хе devilish.png) имаме управление на приоритетите за елиминиране на тоя jitter по еднакъв начин по двата линка - тогава може и да работи добре per packet балансирането. Но защо да си усложняваме живота като можем да направим per connection балансиране по тия два линка. Пък може да се тества да се види кое работи по-добре, ако се тества с достатъчно натоварване и различните видове услуги които могат да текат по нета и изискват яки линкове - игри, voip. И за скорсотите - download, torrent (без/със новия uTP протокол).

@diyan, Ethernet контролерите трябва да са на отделни IRQ. Става въпрос за промени в BIOS. За справяне с проблема с IRQ-тата ще е добре да спреш всички устройства и вградени на дъното устройства и портове, които не използваш, дори IRQ за Video не е нужно. Включи ACPI и APIC опциите. Действай. Ако си кажеш точния модел на дънната платка мога да ти дам пълен списък с правилните настройки в BIOS.

Link to comment
Share on other sites

  • 0

Плати на някои да ти пусне едно бсд и ще можеш да правиш това което искаш по горе.Реализирането с възможностите на великия MikroTik як рутер да комбинира връзките е много куцо.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • 0

Много ми харесва поста ти. :)

Би ли дал линк към пример или името на метода/технологията да го намеря с гугъла, да се убедя с очите си

Ако исках да пробваш пробвай с pfsense

http://niko.gramophon.com/index.php?op=ViewArticle&articleId=4869

Пак дали е по добро от микротик ти прецени

Разликата е че при BSD се ползва pf

Link to comment
Share on other sites

  • 0

Тодоре ше объркаш хората така само  :)  ,малко си се поправил де.

Use since

OpenBSD 3.x

FreeBSD 4.x

Centos 5.x Debian 3.x Ubuntu 7.x

Аз съм фен на OpenWRT.

 

Горчивината от лошото качество остава дълго след като е преминало удоволствието от ниската цена.

_____________________________

___|____|____|____|____|____|__

_|____|____|____|____|____|____

___|____|_ Удряй _|____|____|__

_|____|___ главата ___|____|____

___|____|_ си тук!! |____|____|__

_|____|____|____|____|____|____

___|____|____|____|____|____|__

Link to comment
Share on other sites

  • 0

А работи ли когато двата доставчика gateway-ите са от една подмрежа? Ами когато и IP адресите за клиента и gateway-ите на всеки Internet линк са еднакви? На RouterOS в момента това му куца и ва тази тема конкретно на diyan това му трябва.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.