Jump to content
  • 0

2 IP адреса на един Ether


Mitko
 Share

Question

Здравейте! Имам следния проблем - трябва да пусна на външния интерфейс от доставчика още един /илидва /айпи адрес(а) и да го пренасоча в локалната мрежа навътре. От доставчика имам 5 статични айпи адреса но ползвам само един - искам и останалите да ги ползвам като реални айпита и да ги пренасоча вътре във мрежата, фтп, мейл.... уеб. МТ е RB433AH. П.П Питах чичко Гугъл.. рових се но не открих информация. :( Ще се радвам ако някой е правил такава врътка да сподели опит.  :)

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0
  • Owner

Вдигаш си новите адреси на външния интерфейс.

после:

/ip firewall nat

add action=dst-nat chain=dstnat comment="" disabled=no dst-address=1.1.1.1 to-addresses=2.2.2.2

където:

1.1.1.1 - новия ти ип адрес

2.2.2.2 - вътрешния ти адрес към който пренасочваш.

Link to comment
Share on other sites

  • 0

Значи не е проблем на един интерфейс да добавя още едно или две айпита? Да не стане някаква боза? Че рутера е във Варна а аз съм във София... ;D

Link to comment
Share on other sites

  • 0
  • Owner

Разбира се, че не е проблем :)

Flags: X - disabled, I - invalid, D - dynamic

#   ADDRESS            NETWORK         BROADCAST       INTERFACE                                                                                                                        

0   78.40.140.7/28     78.40.140.0     78.40.140.15    bridge1                                                                                                                          

1 D 78.40.140.6/28     78.40.140.0     78.40.140.15    bridge1              

Link to comment
Share on other sites

  • 0

:) Сработи... а аз се притеснявах... БЛАГОДАРЯ! :)  Когато "нещото" е на 500 км... а не до теб...  ;) Ако идваш към Сф /предполагам че не си от Сф/ имаш бира от мен! Сериозно говоря! Ще се радвам да се запознаем и да черпя! Ползвам МТ от около две години... като рутер на няколко места, но тепърва ми се налага да правя доста изчанчени неща... не че на един от МТ-ците не съм си играл доста по Load Balancing... а тепърва предстои трети доставчик на него  :-/ Да, признавам - черпел съм инфо и от тук ;) Мисля, че е едно много добро BG място за хора ползващи МТ. :)

Малко Offtopic темата - имате ли проблем със Winbox - по-точно като отида във секцията IP - Firewall - NAT или Mangle и ако реша да редактирам някое правило рутера се рестартира  >:( Случва се на всички рутери - RB433 вкл. и на PC х86 базиран рутер?

Link to comment
Share on other sites

  • 0
  • Owner

хехе, аз съм полу-софиянец, полу-дупничанин :)

Това с винбокса не е нормално. Никога не ми се е случвало да се рестартира МТ заради винбокс.

Пусни си system logging да логва на диска и виж дали дава някакви грешки.

Най-често МТ се саморестартира поради калпаво захранване.

п.с.

Абе ние имаме "неща" не само на по 500 км. , ами по върхове и планини :) , та много правилно - 5 пъти премисляш и тогава преконфигурираш.

Link to comment
Share on other sites

  • 0
  • Administrator

по упътване цяла С мрежа /24 адреси може да се накачат на интерфеис

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Значи ще пием по бира!  ;) Да, така е - знаеш поговорката - три пъти мери - един път режи.  До 11111 - не го бях правил никога и... реших да питам все пак.  :)Но нещо имам чувството, че ми убягва с нат-а.. освен dst-nat не трябва ли да укажа и src-nat? за да е пълно изкарването на този вътрешен адрес отвън? ::)

Link to comment
Share on other sites

  • 0
  • Administrator

в упътването има раздел

"1:1 NAT" там е описано как точно става

/ip firewall nat add chain=dstnat dst-address=11.11.11.1-11.11.11.254 action=netmap to-addresses=2.2.2.1-2.2.2.254
/ip firewall nat add chain=srcnat src-address=2.2.2.1-2.2.2.254 action=netmap to-addresses=11.11.11.1-11.11.11.254  
[/code]

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

:( Нещо не работи... аз ли бъркам... поствам част от конфигурацията:

/ip address

add address=192.168.1.1/24 broadcast=192.168.1.255 comment="" disabled=no \

   interface=Local network=192.168.1.0

add address=85.92.141.10/21 broadcast=255.255.255.248 comment="" disabled=no \

   interface=Net-SpNET network=85.91.136.0

add address=192.168.2.1/24 broadcast=192.168.2.255 comment="" disabled=no \

   interface=Local2 network=192.168.2.0

add address=85.92.141.12/21 broadcast=255.255.255.248 comment=\

   "IP Posiflex" disabled=no interface=Net-SpNET network=\

   85.92.136.0

   /ip firewall mangle

add action=mark-connection chain=forward comment="" disabled=no \

   new-connection-mark=users-con passthrough=yes src-address=192.168.2.0/24

add action=mark-packet chain=forward comment="" connection-mark=users-con \

   disabled=no new-packet-mark=users passthrough=yes

   /ip route

add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\

   85.92.141.9 pref-src=85.92.141.12 scope=30 target-scope=10

add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=\

   192.168.1.2,Net-SpNET scope=10 target-scope=10

add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\

   85.92.141.9 scope=30 target-scope=10

add comment="" disabled=yes distance=1 dst-address=192.168.1.0/24 gateway=\

   Net-SpNET

   /ip firewall nat

add action=dst-nat chain=dstnat comment="" disabled=yes dst-address=\

   192.168.1.0/24 in-interface=Net-SpNET to-addresses=\

   192.168.1.0-192.168.1.255 to-ports=0-65535

add action=masquerade chain=srcnat comment="" disabled=no out-interface=\

   Net-SpNET src-address=192.168.1.0/24

add action=masquerade chain=srcnat comment="" disabled=no out-interface=\

   Net-SpNET packet-mark=users src-address=192.168.2.0/24

add action=netmap chain=dstnat comment="Router Posiflex" disabled=yes \

   in-interface=Net-SpNET src-address=85.92.141.12 to-addresses=\

   192.168.2.188 to-ports=0-65535

add action=netmap chain=srcnat comment="Router Posiflex" disabled=yes \

   src-address=192.168.2.188 to-addresses=85.92.141.12 to-ports=0-65535

Идеята е - 85.92.141.12 да се вижда отвън и да е пренасочено към 192.168.2.188, даже мисля да го отделя в мрежа 192.168.10.2 защото във втроа имам и други клиенти а искам да ги разгранича. Може би така трябва да направя защото маркирам пакетите в мрежа 2 за да ограничавам скоростта.

Link to comment
Share on other sites

  • 0

Искай някой да ти го направи, щото много грешки виждам. Нямам време да чета внимателно цялата тема, да измислям и да предлагам, за това така препоръчвам сега. Успех.

Link to comment
Share on other sites

  • 0
  • Administrator

сигурен ли си че доставчика ти ги е дал на един мак адрес ?

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Абсолютно да на един и същи мак адрес. Справих се някак си -  :)  Но имам и други грижи...  :(

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.