Jump to content
  • 0

MT и pppoe и ppptp


Boyan
 Share

Question

/interface ethernet

set 0 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited \

    comment="" disabled=no full-duplex=yes mac-address=00:0C:42:14:EF:3D \

    master-port=none mtu=1500 name="Local" speed=100Mbps

set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited \

    comment="" disabled=no full-duplex=yes mac-address=00:0C:42:14:EF:3E \

    master-port=none mtu=1500 name="wan1" speed=100Mbps


/ip pool

add name="dhcp_pool1" ranges=10.0.0.50-10.0.0.250


/ip dhcp-server

add add-arp=yes address-pool=dhcp_pool1 authoritative=after-2sec-delay \

    bootp-support=static disabled=no interface=Local lease-time=3d \

    name="dhcp1"


/interface pppoe-client

add ac-name="****" add-default-route=yes allow=pap comment="" \

    dial-on-demand=no disabled=no interface=wan1 max-mru=1480 max-mtu=1480 \

    mrru=disabled name="Public" password="****" profile=default \

    service-name="****" use-peer-dns=yes user="*******"


/ip address

add address=10.0.0.1/24 broadcast=10.0.0.255 comment="" disabled=no \

    interface=Local network=10.0.0.0

add address=192.168.1.200/24 broadcast=192.168.1.255 comment="" disabled=no \

    interface=wan1 network=192.168.1.0


/ip firewall mangle

add action=jump chain=forward comment="[tcp], mss" disabled=no jump-target=mss

add action=change-mss chain=mss comment="[tcp], mss fixation" disabled=no \

    new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=!536-1460

add action=change-mss chain=mss comment="[tcp], mss 1440 for mtu 1492" \

    disabled=no new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=1453-65535

add action=change-mss chain=mss comment="[tcp], mss clamp-to-pmtu" disabled=no \

    new-mss=clamp-to-pmtu protocol=tcp tcp-flags=syn

add action=change-ttl chain=prerouting comment="[tcp], mss ttl fix" \

    disabled=no new-ttl=increment:7 src-address-list=!not_in_internet


/ip firewall nat

add action=masquerade chain=srcnat comment="" disabled=no out-interface=Public

add action=dst-nat chain=dstnat comment="Torrent Toshko" disabled=no \

    dst-port=52255 protocol=tcp to-addresses=10.0.0.50 to-ports=0-65535

add action=dst-nat chain=dstnat comment="Torrent" disabled=no dst-port=52155 \

    protocol=tcp to-addresses=10.0.0.10 to-ports=0-65535

add action=dst-nat chain=dstnat comment="HFS" disabled=no dst-port=80 \

    in-interface=Public protocol=tcp to-addresses=10.0.0.10 to-ports=80

add action=dst-nat chain=dstnat comment="" disabled=no dst-port=8000 \

    in-interface=Public protocol=tcp to-addresses=10.0.0.10 to-ports=8000

add action=dst-nat chain=dstnat comment="" disabled=no dst-port=8001 \

    in-interface=Public protocol=udp to-addresses=10.0.0.10 to-ports=8001


/ip dhcp-server network

add address=10.0.0.0/24 comment="" dns-server=10.0.0.1 gateway=10.0.0.1 \

    ntp-server=195.20.20.114,89.25.11.9


/interface pptp-server server

set authentication=mschap2 enabled=yes keepalive-timeout=30 max-mru=1460 \

    max-mtu=1460 mrru=512


/ppp secret

add caller-id="" comment="" disabled=no limit-bytes-in=0 limit-bytes-out=0 \

    local-address=123.123.123.1 name="user" password="test" \

Какво трябва да добавя за да мога от локалната да виждам адресите на wan1 а също и адресите от впн връските

Разочарованието от лошото качество, остава дълго след удоволствието от ниската цена..

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Рутиране, на машините на локалната какво им е зададено като default gateway?

p.s. аз го постигнах в последствие и с NAT но моя проблем може да е бил по-различен...

Link to comment
Share on other sites

  • 0
  • Administrator

NAT ще трябва задълже

правилото

add action=change-ttl chain=prerouting comment="[tcp], mss ttl fix" disabled=no new-ttl=increment:64 src-address-list=!not_in_internet

не е пълно инак добре е направено (копирано от друг мой пост)

трябва да добавиш

/ ip firewall address-list

add list=not_in_internet address=0.0.0.0/8 comment="" disabled=no

add list=not_in_internet address=172.16.0.0/12 comment="" disabled=no

add list=not_in_internet address=192.168.0.0/16 comment="" disabled=no

add list=not_in_internet address=10.0.0.0/8 comment="" disabled=yes

add list=not_in_internet address=169.254.0.0/16 comment="" disabled=no

add list=not_in_internet address=127.0.0.0/8 comment="" disabled=no

add list=not_in_internet address=224.0.0.0/3 comment="" disabled=no

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0
  • Administrator

С каква цел е това?

във вътрешните мрежи не ти менка ТТЛ

при мен като го измислях ми трябваше да гледам ТТЛ на AI108

които показва параметрите на връзката на бриджа

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

С каква цел, за какво практически помага "във вътрешните мрежи не ти менка TTL" между другото май не се прави така, но все още не е ясно за каво е това  :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.