Jump to content
  • 0

проблем с прокси


bozio
 Share

Question

Инсталнах си МТ 2.9.27 на ПЦ конфигуриран и работещ хотспот намерих от вашия форум статийка за конфигуриране на прокси сървър но нещата нещо не се получават при мен с това прозрачно прокси заявките на клиента минават само когато на браузера му сложа

настройки на проксито

ето и какво съм направил

ether1 WAN

ether2 LAN -hotspot

пускам прокси

/ ip web-proxy

set enabled=yes src-address=0.0.0.0 port=8080 hostname="proxy.boza.net" transparent-proxy=yes parent-proxy=0.0.0.0:0 cache-administrator="support@boza.net" max-object-size=131072KiB cache-drive=system max-cache-size=unlimited max-ram-cache-size=unlimited

прехвърлям заявките към интернет насочени към порт :80

/ ip firewall nat

add chain=dstnat in-interface=ether2 protocol=tcp dst-port=80 action=redirect to-ports=3128 comment="proxy" disabled=no

пробвах да сменя  аction=redirect to-ports=3128 на аction=redirect to-ports=8080

но няма разлика и с едното правило и с другото когато сложа на клиент настройка на бараузера му  в статуса на проксито виждам че кешва  а когато няма настройки на клиентското пц не минава нищо през проксито

Link to comment
Share on other sites

Recommended Posts

  • 0

Опитай само с

/ ip firewall nat

chain=dstnat action=redirect to-ports=8080 protocol=tcp dst-port=80

/ip firewall filter

chain=input action=drop protocol=tcp in-interface=ether1 dst-port=8080

Link to comment
Share on other sites

  • 0

ммм не пак е същото

Да попитам и друго в IP менюто ма МТ имам 2 проксита едното пише proxy а на другото Web proxy

нещо не съм го инсталирал както трябва ли ?

Link to comment
Share on other sites

  • 0
  • Administrator

имаш проблем в Порта на проксито които си задал и към който редиректваш

ползвай IP\Web Proxy

на другото махни отметката че е активно

http://mikrotik-bg.net/index.php?topic=131.0

така се получава когато се преписва без да се осмисля

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

да точно от тук четох и преди да paste се опитвам да го осмисля :

по горе съм писал :

пробвах да сменя  аction=redirect to-ports=3128 на аction=redirect to-ports=8080

но няма разлика и с едното правило и с другото когато сложа на клиент настройка на бараузера му  в статуса на проксито виждам че кешва  а когато няма настройки на клиентското пц не минава нищо през проксито

Link to comment
Share on other sites

  • 0

значи с две думи че ми се спи пък и съм пил "малко"

идеята е на които порт пускаш web proxy-то към този порт да пренасочваш заявките от компютрите във мрежата към сървъра ти

пример:

слагаш прокси-то да работи на 3128 порт

после слагаш това правило

 

 / ip firewall nat

add chain=dstnat in-interface=LAN protocol=tcp dst-port=80 action=redirect to-ports=3128 comment="proxy" disabled=no


Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0
  • Administrator

абсолютно правилно не може да редиректваш във въздуха

то точно в това е осмислянето  ;)

п.с поправих поста в темата за проксито да няма грешни :)

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

Направих опити с това което сте казали до сега оказа се че когато клиентското ПЦ е с статичен ип адрес минава през проксито

но след сетъп на хотспот и го прекарам клиентското пц през него не редиректва към проксито

Link to comment
Share on other sites

  • 0

ти няма нужда да добавяш прокси сървър на всеки един компютър, достатъчно е този ред дето го бях написал в предния си пиян пост :)

той кара компютрите които ползват този сървър за гейтуей, и които правят заявка към 80-порт на някой адрес /www.abv.bg/ да минават през проксито на компютъра

там няма алтернатива за компютрите в лана-ти - искат-не искат минават през проксито

ето как е направено при мен, ако го копи->пейстнеш /ех че звучи гадно на български / ще работи

 

/ip firewall nat

add action=redirect chain=dstnat comment="Proxy for Local" disabled=yes \

dst-port=80 in-interface=Local protocol=tcp to-ports=3128

add action=redirect chain=dstnat comment="Proxy fo WiFi" disabled=no \

dst-port=80 in-interface=vlan1 protocol=tcp to-ports=3128 
 

 /ip proxy

set always-from-cache=yes cache-administrator="SSM Administrator" \

cache-drive=secondary-master cache-hit-dscp=4 cache-on-disk=yes enabled=\

yes max-cache-size=unlimited max-client-connections=1000 max-fresh-time=\

3d max-server-connections=1000 parent-proxy=0.0.0.0 parent-proxy-port=0 \

port=3128 serialize-connections=no src-address=0.0.0.0

/ip proxy access

add action=deny comment="block telnet & spam e-mail relaying" disabled=no \

dst-port=23-25

/ip proxy cache

add action=deny comment="" disabled=no dst-host=":cgi-bin \\\?"

/ip proxy direct

add action=deny comment="" disabled=no dst-address=87.120.40.3 

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

Направих опити с това което сте казали до сега оказа се че когато клиентското ПЦ е с статичен ип адрес минава през проксито

но след сетъп на хотспот и го прекарам клиентското пц през него не редиректва към проксито

няма значение дали на определения интерфейс има или няма хотспот услуга. в моя случай на интерфейса Local нямам хотспот услуга а на Vlan1 имам. и двата интерфейса минават през проксито

хотспота не се бърка на проксито /нито динамични или статични адреси /

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0

нещо явно немога да обесня затова пействам нстройките на моя фиревал

[admin@MikroTik] ip firewall nat> print

Flags: X - disabled, I - invalid, D - dynamic

0  ;;; proxy

    chain=dstnat in-interface=ether2 protocol=tcp dst-port=80 action=redirect

    to-ports=3128

1  ;;; masquerade hotspot network

    chain=srcnat src-address=192.168.170.0/24 action=masquerade

[admin@MikroTik] ip firewall nat>

където на ether2 e пуснат хотспота

когато няма хотспот тоест ресетна МТ и настроя само ИП-тата,гейта,днс-а,webproxy port=3128 masuerade на мрежа 192.168.170.0/24 тогава клиентското ПЦ 192.168.170.3 има интернет и минава прес проксито

но setyp-на ли хотспот и настроя узер с 192.168.170.200 както по горе firewalla

ПЦ-то неще да мине през проксито минава единствено когато в настройките на IE или firefox сложа да ползват прокси сървър

Link to comment
Share on other sites

  • 0

къде го гледаш дали минава или не?

пусни настройките и на проксито ти

както и ако можеш на хотспота

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

  • 0
  • Administrator

Направих опити с това което сте казали до сега оказа се че когато клиентското ПЦ е с статичен ип адрес минава през проксито

но след сетъп на хотспот и го прекарам клиентското пц през него не редиректва към проксито

при ползването на хотспот

от настройките на хотспота има каде да се окаже че има прокси

IP/Hotspot/Servers/Profiles или

/ip hotspot profile (от конзолата)

се оказва за хотспот

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

ето конфига на проксито

[admin@MikroTik] > ip web-proxy print

                enabled: yes

            src-address: 0.0.0.0

                    port: 3128

                hostname: "proxy.provider.net"

      transparent-proxy: yes

            parent-proxy: 0.0.0.0:0

    cache-administrator: "support@provider.net"

        max-object-size: 131072KiB

            cache-drive: system

          max-cache-size: unlimited

      max-ram-cache-size: unlimited

                  status: running

      reserved-for-cache: 5269504KiB

  reserved-for-ram-cache: 2048KiB

това е на хотспота

[admin@MikroTik] > /ip hotspot print

Flags: X - disabled, I - invalid, S - HTTPS

#  NAME                            INTERFACE ADDRESS-POOL PROFILE IDLE-TIMEOUT

0  hotspot1                        ether2    hs-pool-2    hsprof1 5m         

[admin@MikroTik] > ip hotspot profile print                 

Flags: * - default

0 * name="default" hotspot-address=0.0.0.0 dns-name="" html-directory=hotspot

    rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0

    login-by=cookie,http-chap http-cookie-lifetime=3d split-user-domain=no

    use-radius=no

1  name="hsprof1" hotspot-address=192.168.170.1 dns-name=""

    html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:3128

    smtp-server=0.0.0.0 login-by=cookie,http-chap http-cookie-lifetime=3d

    split-user-domain=no use-radius=no

[admin@MikroTik] > /ip hotspot user print

Flags: X - disabled, D - dynamic

#  SERVER  NAME                          ADDRESS        PROFILE UPTIME     

0  hotspot1 admin                                        default 21m27s     

1  hotspot1 user                                          uprof1  1h1m2s     

статистика гледам през Winboxa на webproxy setings status

Link to comment
Share on other sites

  • 0
  • Administrator

1  name="hsprof1" hotspot-address=192.168.170.1 dns-name=""

    html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:3128

    smtp-server=0.0.0.0 login-by=cookie,http-chap http-cookie-lifetime=3d

    split-user-domain=no use-radius=no

http-proxy=127.0.0.1:3128

или

http-proxy=192.168.170.1:3128

Харесай поста ^^^
acer.gif htc.gifsigpic4024_2.gif

Форумът е за взаимопомощ а не за свършване на чужда работа


ɹɐǝɥ uɐɔ noʎ ǝɹoɯ ǝɥʇ 'ǝɯoɔǝq noʎ ɹǝʇǝınb ǝɥʇ

Link to comment
Share on other sites

  • 0

да много интересен адрес 0.0.0.0:3128 :)

аз там в хотспот сървър профилите го нямам написано, но все пак си работи като е пуснато прокси на интерфейс

Теория - това е когато знаете всичко, но нищо не работи

Практика - това е когато всичко работи, но не знаете защо

При нас съчетаваме теорията с практиката - НИЩО не работи и нямаме понятие защо!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.